Windows Legacy OS forum

General discussion

Laptop USB ports stopped working

by gashomme / December 31, 2005 5:44 PM PST

I have a Sony VGN-T1XP Vaio laptop with an Intel Pentium M Processor running XP Pro SP2. For some reason the two USB ports have stopped working and no USB devices are recognised. I have looked at the device manager under USB controllers and there are four USB controllers listed which are as follows:

Intel 82801DB/DBM USB 2.0 enhanced host controller 24CD
Intel 82801DB/DBM USB universal host controller 24C2
Intel 82801DB/DBM USB universal host controller 24C4
Intel 82801DB/DBM USB universal host controller 24C7

Underneath those are four USB root hubs.

I have previously used a USB card reader and external hard drive on both ports without any problems but now when I connect any device nothing at all happens.

I have deleted and reinstalled the USD controllers to no avail and I have created a new user account but this has an identical hardware profile as the main user account.

I suppose I could reset the machine back to the factory settings but would prefer to avoid this.

I have tried to be as specific as possible but I don?t really know much about what I am doing so apologies if I have omitted something.

Can anyone help please?

Thanks and Happy New Year!

Discussion is locked
You are posting a reply to: Laptop USB ports stopped working
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Laptop USB ports stopped working
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
(NT) (NT) Did you use System Restore since it's so recent?
by R. Proffitt Forum moderator / December 31, 2005 9:09 PM PST
Collapse -
Re System Restore
by gashomme / December 31, 2005 10:02 PM PST

Yes I did but it didn't solve the problem.

Collapse -
Then more clues are needed.
by R. Proffitt Forum moderator / December 31, 2005 10:42 PM PST
In reply to: Re System Restore

Since system restore to before the issue didn't cure it, it's half as likely that installing the OS will fix it.

Any other clues would be helpful.


Collapse -
re more clues
by gashomme / January 4, 2006 5:37 AM PST

Not sure what else I can tell you.

I have been using a USB hard disk and was having problems with write delay failures to the master file table. I have been using the chkdsk command periodically because of this and suddenly the usb ports just stopped working. I don't know if I have somehow accidentally uninstalled some hardware but I have tried searching for new hardware both with and without items connected to the usb ports. I have also checked the drivers on every piece of hardware listed in device manager and uninstalled and reinstalled the usb controllers and root hubs.



Collapse -
There's a clue.
by R. Proffitt Forum moderator / January 4, 2006 5:45 AM PST
In reply to: re more clues

" I have also checked the drivers on every piece of hardware "

Hopefully you did so by check with Sony as to what drivers they had, the file dates and never that DRIVER UPDATE button that Microsoft has yet to implement proper.

If you did use the Microsoft Update Driver or accept Windows Update drivers, I'm raising the chances that reloading from Sony's restore CD will fix it to better than 90%.


Collapse -
Found this on the net
by retired / January 4, 2006 5:51 AM PST
In reply to: There's a clue.

see if it may help.

USB Devices Quit Working Unexpectedly in Microsoft Windows XP

A USB device, such as a camera, scanner, or printer, loses its connection and stops working unexpectedly. The device may appear to work fine when Windows first starts up but later stops working. Use the steps (below) to resolve this issue.

Disable power management on the USB hub
To preserve power, Microsoft Window XP tries to disable USB when a device is not used. Under certain circumstances this function does not work and may cause USB devices to fail to respond when called. To resolve this issue, disable power management on the USB hub by doing the following:
Click Start, and right-click My Computer.

Click Properties, then click Hardware.

Click Device Manager.

Double-click the Universal Serial Bus Controllers branch to expand it.

Right-click USB Root Hub, and then click Properties.

Click Power Management.

Deselect Allow the computer to turn off this device to save power.

Repeat Steps 5 through 7 for each USB Root Hub.

Click OK, and close Device Manager.

Collapse -
Refound this on the net
by gashomme / January 6, 2006 7:16 PM PST
In reply to: Found this on the net

Thanks for taking the trouble to dig this out for me. Unfortunately, it hasn't solved the problem.

Collapse -
Re: Found this on the net
by NightSky72 / March 31, 2010 12:46 AM PDT
In reply to: Found this on the net

Wow, thanks a lot! I was having the same trouble as this individual (I have Windows 7 Professional) and your solution worked. Thank you so much.

Collapse -
Simple and great!
by spicytee / March 25, 2013 1:04 AM PDT
In reply to: Found this on the net

Works like charm.. Thank you

Collapse -
Laptop USB ports stopped working
by sammiemugane / December 23, 2015 11:08 AM PST
In reply to: Found this on the net

Thanks alot. This method has worked for me on Windows 7. The USB ports are now working.

Collapse -
Re : Found this on the net
by mushm6 / January 21, 2016 2:10 AM PST
In reply to: Found this on the net

Thanks a lot. You have no idea how relieved I am. You made my day. The steps mentioned by you worked on my Toshiba satellite laptop running Windows 7.

Collapse -
re there's a clue
by gashomme / January 6, 2006 7:42 PM PST
In reply to: There's a clue.

I don't have any driver discs for this pc so the drivers used would be the windows drivers. I backed up my system and tried using the sony vaio recovery utility but that has not solved the problem so I have gone back to the backup to get back to the pre recovery state.

Next I am going to try sony support and if they can't help me then I am at a loss.

Collapse -
That makes me think the ports are blown.
by R. Proffitt Forum moderator / January 7, 2006 2:41 AM PST
In reply to: re there's a clue

This has happened to a few and the fix is a new motherboard. Since laptop boards are expensive I try a PC-Card USB card first.


Collapse -
by Kono Kusotare / January 4, 2006 9:46 AM PST

Just out of curiosity, check your CMOS setup screens to see if USB support is set to Auto, Enabled, or Disabled.

Collapse -
by gashomme / January 5, 2006 4:15 AM PST
In reply to: USB

Hi there,

Sorry if this is a stupid question but how do I do that. When I power up the laptop I have the option to press f8 which enables me to choose how to start windows i.e. safe mode, normal, last known good configuration etc. I am not given any other options on start up.



Collapse -
At startup...
by Kono Kusotare / January 5, 2006 6:48 AM PST
In reply to: USB

look for the words BIOS or Setup at the bottom of your screen. Generally F1 or something like that.

Collapse -
Re startup
by gashomme / January 6, 2006 7:19 PM PST
In reply to: At startup...

Discovered that pressing f2 takes me into bios but there is nothing there which enables me to look at cmos settings. The options are limited and include things like changing system passwords.

Collapse -
try disk management in the control panel ?
by don h / February 10, 2006 8:20 AM PST

have you tried ...

control panel / administrative tools / computer management / storage / disk management /

the available drives are shown on the right top and bottom panels ...

if the drive is visable but does not have a drive letter ... right click and assign a unused drive letter ... usually higher than g: on my desktop

i have been using the method on my home desktop and my work computer because i use a number of usb flash drives, external usb harddrives, compact flash card, stick flash, and sc cards ...sometimes the op syst gets confused and does not recognize the drive or the wrong combination of drives causes this problem ...
hope this help

don h

Collapse -
I have the same problem with my SONY VGN-UX 180P
by spicynugget / October 15, 2006 1:39 PM PDT

called sony and they said I needed to call microsoft. Tried all the steps that our great experts reccomended - the problem first appeared when I plugged in an HP camera to my sony ux usb port. Any other tips?

Collapse -
Same problem?
by R. Proffitt Forum moderator / October 15, 2006 9:15 PM PDT

If it is the same problem (your claim) and you did the same as in this discussion the ports are blown.

Try a PC-Card with USB 2.0 ports.


Collapse -
The ONLY solution, sorry it's a bad one :(
by gremlinstomper / May 28, 2007 10:29 PM PDT
In reply to: Same problem?

Hi everybody. Yet again this month, a customer has arrived with Windows showing faulty USB in Device Manager. . . . I see this about once every 8 months.

This time, i sat and considered 'every' angle. The bad news is, as is logically fathomable, It's purely down to Windows losing it's mind (again).

1st) USB - ALWAYS continues working on other installations/operating systems/even in DOS :-o

2nd) It's not a physical hardware fault - DO NOT change your mainboard etc., If you think it's hardware broken, try using USB in UBUNTO (linux) or DOS, and it will 99.9% work perfectly. I handle 250 PC's a year, and only 1 laptop & 1 tower have 'ever' had real faults, so it's more likely you will meet Santa at a party than it actually breaking Wink

3rd) i have entensivly tested/reinstalled/repaired/guided/and even copied carefully EVERY USB bit of data to try the latest repair, it makes no difference. Even a complete registry re-write did not fix it, so 'something' in Windows can totally lose it (presumably it becomes a 'part' of a large DAT file that gets corrupt).

4th) You honestly don't have to do a thing to get it to break this way, it simply happens, totally by chance (& bad luck) Sad

5th) A reinstallation of Windows (all versions) is the 'almost' guaranteed solution.

6th) Normal BIOS's default to USB ON (laptops rarely even have an option), but usually USB 2.0 is OFF by default. This is not relevant - if your USB works, but Device Manager shows a yellow warning triangle, it's because USB 1.1 is working properly - to get USB 2 (in XP) you need special drivers (or Service Pack 2) to get the higher speed.

Always keep in mind, Windows is only an User Interface, it makes mistakes, and goes wrong, It does not mean your PC needs to be replaced by a 'new' anything :-o it most likely just needs a clean reinstallation.

I recommend to anybody who doesn't want to get this problem to stop their fun, always partition your HD in two parts. Then use a back-up utility (i have to recomend "Drive Image 2002", fastest & best i've used) and make a System Snapshot on the 2nd partition. When things wrong on mine, it takes me 1minute,45seconds to be up & running again - and aint that just what we 'all' want eh?

Good Luck to anybody with the problem.
And i'd just love to know which file(s) are to blame for the error being so 'sticky'. Email me please, if you find it - i can't Happy

Collapse -
Thanks for the update. Add this discussion too. USB SURGE.
by R. Proffitt Forum moderator / May 28, 2007 10:42 PM PDT
Collapse -
Hardware fault
by crimsontwo / January 14, 2009 1:52 AM PST

Well, clearly those "PC's" that you deal with are not Sony VAIO Wink

This is NOT a Windows problem. I've just had this happen to my VGN-AW190 system (Sony's top-of-the-line laptop). My mouse stopped working all of a sudden. I've documented the problem here:

The computer is going back to Sony tomorrow (since I am waiting for a replacement system anyway).

Collapse -
Just checking our Vista FAQ?
by R. Proffitt Forum moderator / January 14, 2009 4:39 AM PST
In reply to: Hardware fault
Collapse -
Non-Vista problem
by crimsontwo / January 14, 2009 5:00 AM PST

Sorry, but did you read my post on (link in my original post)?

This has nothing to do with the operating system. Linux, Windows - USB mouse doesn't work anywhere. Obviously, I did reinstall Windows to rule out the driver problem and then tried Linux. Also internal computer's components with USB drivers (such as the built-in webcam, for instance) don't work either.

Searching for this problem on the internet brings up a number of reports of this happening with VAIO systems. I wish there was a way to bring it to Sony's attention (except for contacting their useless support).

Collapse -
Sure did. Here's the first paragraph you mention Vista.
by R. Proffitt Forum moderator / January 14, 2009 8:50 AM PST
In reply to: Non-Vista problem

"I tried booting Windows (Vista 64) installation from DVD and the mouse didn't work there as well, although it always works once you're presented with a menu. I then formatted my parition, did a clean install... and... same thing. USB ports don't recognize my 2 mice (Microsoft and Logitech)."

Best of luck in recovery.

Collapse -
USB ports not working?
by cgcarlson / May 6, 2008 2:11 PM PDT
Collapse -
See the date of the original post?
by MarkFlax Forum moderator / May 6, 2008 8:06 PM PDT
In reply to: USB ports not working?

That poster has most likely fixed the problem now, or moved on.


Collapse -
doesn't work
by CM_FTL / October 28, 2010 11:21 PM PDT
In reply to: USB ports not working?

that link didn't help a bit. we've all tried their suggestions, but for the final choice; only to find out this solution doesn't apply to windows 7

Collapse -
You bet.
by R. Proffitt Forum moderator / October 29, 2010 12:53 AM PDT
In reply to: doesn't work

As this is the XP forum the solutions for XP may not apply. The only one that seems to apply is the old CODE 39 and EXPLORER issues (still with us 10 years later?)

Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?