just disable the tapping feature of the trackpad. sould be in the settings