The first solution could be to update the BIOS of your laptop. It should really work if it doesn't then go to the "power setting" then go to change the plan settings, then find the change advanced power settings. The dialog box opens in the multimedia option, click open playing videos and there change the plugged-in option to balanced.

Hoping that this solves your problem

Thanks!