HolidayBuyer's Guide

Networking & Wireless forum

General discussion

Laptop doesn't recognize the router.

by tigwelder56 / February 8, 2006 10:51 PM PST

I have an Acer Travelmate 290 with integrated wireless. Running XP PRO sp2, 512MB SDRAM. Cable Broadband and a Linksys WRT54G router. The host system is a Dell 8300 cabled to the router. I have used this laptop on this network for over a year with no problems. I have a desktop in another room that also utilizes the router via a wireless connection. That connection works fine. I turned on the laptop the other day and have no connection, the laptop doesn't see the router. I can connect the laptop via an ethernet cable and can access the Internet easily. I have checked all the security settings and there are no differences there. I even removed all security and tried operating the system open and the laptop still would not recognize the router. I have checked everything I can think of, such as: the wireless switch on the laptop is on, checked the wireless card in the device manager and it is enabled and without conflicts, you name it I think I've tried it. I connected a separate USB wireless adapter to the notebook, confirmed all settings and still the notebook doesn't see the router. The notebook does list the wireless hardware. Does anyone have a final suggestion before I put a bullet in this? All suggestions welcome!

Discussion is locked
You are posting a reply to: Laptop doesn't recognize the router.
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Laptop doesn't recognize the router.
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Try this tool.
by R. Proffitt Forum moderator / February 8, 2006 10:53 PM PST


If it fixes it, the machine likely has some pest or spyware.

Collapse -
by tigwelder56 / February 9, 2006 1:45 AM PST
In reply to: Try this tool.

Hi Bob,
I thought you had it there. I have System Mechanic on all my computers and thought between that and my regular use of Spybot S&D and Ad-Aware that I had surely removed something. But that isn't the case. It made no difference at all. I have removed the drivers, reinstalled them, tried the tool again and nothing. With an integrated adapter, what is the procedure of starting the whole thing over? Uninstalling the software and reinstalling it doesn't do anything, so what will? What could be lost that wouldn't allow new hardware to recognize the router? This is odd, huh?

Collapse -
I'd need more clues such as that IP 169 or 192. But
by R. Proffitt Forum moderator / February 9, 2006 2:55 AM PST
In reply to: Nope
Collapse -
IP Address Clues?
by tigwelder56 / February 9, 2006 7:19 AM PST

Bob, the only information I can give you about IP addresses are this, opens the router panel on each machine. What more can I give you? The network adapter is visible in the device manager, it's an Intel (R) PRO/Wireless 2200BG Network Connection. It's set for an automatic DHCP config, identical local IP's and subnet, DHCP server is enabled. It's located at PCI bus 2, device 2, function 0. It is working properly and is enabled.

''Advanced'' tab: ''Wireless device off'' button is not checked. Values are set to ''Default''. Hardware Version: 0.1.3
Driver Version:
NCPA Version:

''Driver'' tab:
Date: 3/8/2004

Details tab: Shows an obscene number sequence if you need them!

Resource tab: settings listed upon request and no conflicting devices.

If there is anything else I can give you please let me know! Thanks for your help.


Collapse -
More info
by tigwelder56 / February 10, 2006 2:04 AM PST

I went on the Intel site and downloaded new and updated software for my Intel adapter (in the laptop). I thought trying different software might make a difference. (Not!) It's a strange dilemma and it continues to be one after the new software. The new Intel software also provides a console so you can work with the adapter and it's features, etc. Everything installed perfectly. The new drivers are there, the laptop lists the adapter in the device manager, states there are no conflicts and is enabled. The Intel software provides an icon in the systray to work from. When I use this feature it tells me that the adapter is switched off. I make the attempt to turn it on (checking) and it tells me that the ''Intel(R) PRO/Wireless Network Connection is still disabled. Use your hardware switch to enable it.'' Of course the switch is on and has been. I have disabled all security and firewalls and all the comps are configured identically and I went ahead a disabled that. I have tried MS's suggestions with and without the Wireless Zero Configuration (checked new and old drivers for it, you name it). I have attempted to contact Acer's customer service and the only thing they offer is web support that they pay no attention to. Any other idea's you can suggest? I tried a separate 11.b adapter and the issue remained the same.

Any idea are appreciated! Thanks, Brady

Collapse -
Some firewalls have no true disable.
by R. Proffitt Forum moderator / February 10, 2006 2:15 AM PST
In reply to: More info

But you never revealed the IP address assigned to the laptop or the other details. Some think it's a security risk to tell that is my laptop IP and my DNS is but without details you may have to get this serviced.


Collapse -
Media disconnected
by tigwelder56 / February 11, 2006 3:50 AM PST

I can't provide an IP address for the Intel PRO/Wireless 2200BG Network, it's claimed to be disconnected. There isn't more than one physical switch on this notebook and it's on. The Ethernet NIC has an IP of I've tried the winsockxpfix with no success. New firmware on the router, new software/drivers for the adapter. I have checked that the Wireless Zero Configuration is started. It's time M$ and the wireless orgs. find a fix for this. The frustration this has caused ''us'' is exponential. If running an adware program (for one) causes this in some machines, they should tell you before running it. Spending all the money I did for a wireless notebook only to have it trashed while trying to keep it clean and updated is a crime on my wallet! I hope that someone can figure out this problem and when they do I think we should name a holiday after them.

PS: My thoughts are with you Bob.

Collapse -
You can use Run command for the IP address
by Melati Hitam / February 11, 2006 4:37 AM PST
In reply to: Media disconnected

Start, Run type command (or cmd), type ipconfig /all, enter.

what IP did you get on your ethernet, and what IP did you get for the wireless, while you are there, make a note on DNS, gateway, etc.

it just a mis-configuration somewhere... hopefully..

Note: adware, spyware and viruses do cause trouble, and those all anti adware, anti spyware and anti virus, will tell you before you run it...

Collapse -
Thanks for the kind thoughts.
by R. Proffitt Forum moderator / February 11, 2006 7:25 AM PST
In reply to: Media disconnected

But reading your last post does cause a light bulb to glow however dimly. The IP address of the Ethernet NIC has an IP of is not good!

Here's why.

Let's say I wanted to use my wifi connection. When it gets an IP it will be in the 192.168.1.x range but with a NETMASK of that would be non-routable and in short dead on arrival.

Unplug the ethernet, use IPCONFIG /RELEASE (or all) in a command window (or gui if you have such) and then reboot but do not plug in the ethernet cable. In fact I might even disable the NIC in the device manager.


Collapse -
Done, but not over...
by tigwelder56 / February 12, 2006 12:57 AM PST

I disconnected the ethernet and disabled the nic in the device manager. Rebooted and opened a cmd window. Checked the ipconfig/all to see what was listed and it lists a disconnected ethernet adapter and a disconnected wireless connection. I ran the winsock fix just for the heck of it too. No changes noted.

Now I'm going to enable the ethernet connection and get some numbers for you. ipconfig/all gets some odd information. It shows the laptop as the "Host name" the "DNS suffix" is blank, mixed node, IP routing enabled - "No" ? WINS Proxy enabled - "No"
Ethernet adapter Wireless Net. Conn. -- disconnected.
Ethernet NIC:
Physical Address---00-02-3F-19-0F-3E
Dhcp Enabled----Yes
Autoconfig enabled----Yes
IP Address----
Subnet Mask---
Default Gateway----
DHCP Server----
DNS Server----68,87.74.162 &
Lease Obtained---today
Lease Expires---tomorrow

That is all--


Collapse -
What numbers do you need??
by tigwelder56 / February 12, 2006 1:36 AM PST
In reply to: Done, but not over...

I'm more than willing to provide any numbers you need! I thought I had listed everything you needed and am confused now. Where are these elusive numbers located? Thanks for the help...sorry about the other deal. I used it to keep some sort of privacy.

Collapse -
The 192.x.x.x numbers of
by R. Proffitt Forum moderator / February 12, 2006 1:58 AM PST

Network adapters, the 192.x.x.x number of the router for instance. Your posts never supply a compete picture and since it can change as you work on it, using bits and pieces from one post, then another won't do.

It's a puzzle, but to see if the numbers are right, all the pieces need to be seen at one time.


Collapse -
Need direction!
by tigwelder56 / February 12, 2006 3:20 AM PST

Tell me what to do exactly and I'll provide you everything you need. I thought I was giving you all the information needed. The wireless adapter on the notebook when queried says the the media is disconnected. The ethernet adapter LAN says this:
Connection-specific DNS
IP Address:
Subnet Mask:
Default Gateway:

The router starting address is , the subnet mask is I thought that all routers were accessed with that sequence, isn't that true?


Collapse -
Wireless in that instance should not work.
by R. Proffitt Forum moderator / February 12, 2006 3:52 AM PST
In reply to: Need direction!

The ethernet address is already "on the LAN" and as such I would not expect the wifi to obtain or use a valid IP.

I've seen this before as a person keeps connecting a laptop via ethernet cable or has typed in the IP numbers. It took a few weeks for it to sink it that we have to decide which connection we're going to use.

And that's the information I was seeking to see in a single post. NO, not all routers use that scheme. Some use, others can be changed by the owners and the DNS might be the ISP entries or the IP of the router.

Nothing like a standard in which you can choose from many.


Collapse -
What IP did you get, while on wireless?
by Melati Hitam / February 9, 2006 2:22 AM PST or

or is it possible that someone change something on the desktop?

Collapse -
This is the first time
by tigwelder56 / February 12, 2006 4:05 AM PST

This is the first time I connected this laptop to an actual ethernet cable. From day one I connected wirelessly. Is there a solution for this? Seems like a lot of work so far. I appreciate your help.

Collapse -
I cleaned up your internet information.
by R. Proffitt Forum moderator / February 12, 2006 7:12 AM PST

Avoid posting those numbers but they are fine for the internet connection.

"As for security changes I did enable WPA Personal on the other desktop a week ago. When I turned on the laptop I changed those numbers too. I have changed the security settings in the past with no issues. I had WEP set up before going with WPA Personal. I have gone back and forth since this started to see what might change and nothing has made any differences with the signal. The network is currently encrypted and all machines share identical settings. Removing security makes no difference with the problem. Changing the broadcast also makes no difference and my standard setting is disabled."

Start STOCK as the router goes for wifi. What we need is the laptop's NIC to not have a 192.x.x.x assignment so the wifi card can obtain an address.

We've made some progress with you sharing the NIC IP numbers, but everytime I've read them, I see why a wifi would not function.


Collapse -
Addendum. Time to travel to some hotspot.
by R. Proffitt Forum moderator / February 12, 2006 7:14 AM PST

If I wanted to test my laptop's wifi I'd head out to a hotspot and try there.

This way I'd have a clue if it was my router or my laptop. So far, with that 192.x.x.x on the Ethernet NIC, that's not good.


Collapse -
RP, actually, I have similar problem and so
by Melati Hitam / February 12, 2006 4:29 PM PST

I follow this thread.. (I restrain myself from adding/post to the thread, but, I get confused...)

You ask (even I asked) for the IP address...

But then when he posted the IP, you said don't post for security reason... (but then you ask again)

Then you said Ethernet NIC IP (192.x.x.x) is BAD (what is good, how do you change it? manually? automatically?) --

I did sometimes, use wireless, without disconnecting the hardwire (ethernet cable) .. -- have not encountered any problem yet.--

and that is all the information I get from this thread..

By the way, I fix my problem (On one of my laptop) by UNINSTALLING and REMOVED the devices and drivers, that are related to the network (using safe mode), and restart the laptop (without connecting to the network hardwired or wifi, I also turn off the Router/accesspoint too)... let windows found and install new hardware and drivers (I need the original CD, to get the drivers) ...

But for the other laptops (that also have the same problem of connection), I have to do a repair install and/or clean install.

Note: Not because it can not be fix.. but I have no success using my above step and I can afford to erase the HD, on some of the laptops.

Note2: I have the ethernet NIC IP -- IF only ONE computer connected to the router, the next computer will have 101, 102 etc. --

Collapse -
Message #7 ?
by tigwelder56 / February 12, 2006 1:14 PM PST

I'm confused Bob! I thought you asked me to post those numbers. I never post anything that could or might jeopardize security as a rule. That was one reason for using the private address. Oh well... I guess I have more to watch now.

What Internet information did you clean up? I'm not sure what you meant/did. Any idea why the NIC would have a sequence? I'm not sure what it should be or how to get it corrected to the right IP sequence. I ran some checks on my other system that uses the same router. I have a Linksys PCI adapter in it. That system works fine and has never had any issues, even remotely. I'll clear the information tomorrow AM and will start everything fresh and let you know how it goes. Thanks Bob...


Collapse -
Internal 192.x.x.x, 169.x.x.x, 10.x.x.x are fine.
by R. Proffitt Forum moderator / February 12, 2006 9:10 PM PST
In reply to: Message #7 ?

When I looked up your last numbers, they were your real "internet" addresses. The internal numbers are non-routeable and as such a nonsecurity problem. As such I looked them over and cleaned up the posts with them.

The numbers, by the way looked valid.

I see only 2 items left to work.

1. What happens when the ethernet (wired) nic is disabled and has no IP. What does the wifi adapter get?

2. Travel to a hotspot and try to connect there. There is no firm clue that your router's wifi is functional.


Collapse -
Hello -- IP info
by tig56 / February 13, 2006 3:15 AM PST

Happy Monday,
The IP address of the wireless adapter shows a ''disconnected media'' notice with the NIC disabled. It does list the wireless adapters name. However it shows a physical address: 00-0E-35-XX-XX-XX. The Windows IP Config. shows a blank primary dns suffix, mixed node and the IP routing & WINS proxy not enabled.

I tried uninstalling and reinstalling the wireless adapter, removing the router from the picture completely, basically started from scratch. Nothing changed whatsoever. Still have the same issue. Everything shows up but it says the wireless adapter is disabled and to enable it. At the same time the Device Manager says it is enabled and the hard switch is ''on''. I haven't had a chance to take it to a hotspot, there aren't any close to me but I'll get there. Remember though that I have another system upstairs that uses this router and has no problems reaching the internet. Doesn't that tell you the router isn't the problem? In the event this notebook adapter is the problem can I repair it? It's integrated. I do have a card slot so an add on card is possible. Wish I knew someone with one, might make things easier! Thanks!


Collapse -
by R. Proffitt Forum moderator / February 13, 2006 6:09 AM PST
In reply to: Hello -- IP info

I've had machines that connect and not and have changed the routers firmware to fix the machine that wouldn't connect. The clue I used to figure that out was to take the non-working machine to a hotspot and connect there.

Hope this does not confuse you.


Collapse -
I'll track down a hotspot tomorrow.
by tig56 / February 13, 2006 10:16 AM PST
In reply to: Nope.

I'll check into it tomorrow. I've got a kitchen faucet that just blew, water all over. Just installed new cabinets five days ago. 8&@@##!! I've been a little preoccupied today...

I have the newest firmware for the router. I updated the drivers so all is new and shiny, it just doesn't work.

Collapse -
Join the remodeling club. Off topic.
by R. Proffitt Forum moderator / February 13, 2006 11:15 AM PST

My dishwasher failed 3 weeks ago. A faucet started dripping, the new one piece bathroom countertop arrived in 2 pieces (busted in transit.) And a personal loss last weekend.

I hope we hear your faucet tale ends faster than this wifi case.


Collapse -
Too Funny- OS
by tig56 / February 14, 2006 9:17 AM PST

I finally got things cleaned up and made my way to Lowe's. Just happens they had one faucet left (had to be exactly the same, predrilled granite top). So I get it home, put it in, all works well, yippee...It turns out that it was a hidden cartridge in the control handle that was leaking. (Finally had the schematic of the original, most people wouldn't look at those I guess!) Lowe's says tuff luck, it's used now and I'm too honest to lie. Just another $250 bucks! I think I'll run out quick and buy a new adapter for the notebook and share the pain...

Collapse -
Just a suggestion
by glen_king / February 13, 2006 1:20 AM PST

Hi tigwelder56,
I had a very similar (possibly identical) situation to yourself recently. I have an Acer travelmate and after no problems with the wireless network for ages one day it just refused to detect a thing. I scanned for spyware, viruses, disabled startup items and the rest yet still no change. But then i created a test user profile logged in and low and behold the network was up and running in seconds. Logging back in to my original profile knocked it out. As I had various settings on the network connected to that username i simply moved all my files i wanted kept (favourites/my docs etc.) out of the Docs and settings folder to another location on the disc, logged into the other profile and deleted, then recreated my orginal account after a restart. Logging back in the network worked fine again and i just copied my files back to their original location.
I have know idea what caused it, but the issue hasn't come back since and the solution only took 5 mins rather than the hours of frustrating troubleshooting that preceded it.
I hope this helps, and if you do try this make sure you have everything backed up from the profile first.

Collapse -
Hello Glen
by tig56 / February 13, 2006 4:37 AM PST
In reply to: Just a suggestion

Thanks for the reply. I tried your recommendation and unfortunately it didn't work either. It was a promising idea for a few minutes!! Thanks again.


Collapse -
If thats the case..
by glen_king / February 13, 2006 5:17 AM PST
In reply to: Hello Glen

..then i would suggest uninstalling the drivers in safe mode and re-installing them. restart in 'safe mode with networking' and see if you can now detect the network. As you say, you have another machine connecting wirelessly without issue so i believe the problem would be with the laptop and not the router.
if you still cannot see the network after this in safe mode, the last steps would be a backup before clean install (sounds more drastic than it is, provided you have your image cds that came with the laptop). If you're still having bother seeing the network its more than likely a hardware issue.
As you say the wireless on acers is integrated but if you look underneath you'll see a panel for the wireless mini-pci antenna with two wires attached to it. there is a slight chance that this connection has come loose. if all this fails i would check your warranty repair.

Collapse -
by tig56 / February 13, 2006 9:52 AM PST
In reply to: If thats the case..

Not so much as a wiff of the network. After cleaning house it still comes back with a NIC IP address of, Bob. As a matter of fact every single number I gave you yesterday remains the same. Greg, is that wifi panel the one dead center under the notebook? or on the side next to the power inlet? I guess I need to do some homework. Thanks guys--


Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions

The Samsung RF23M8090SG

One of the best French door fridges we've tested

A good-looking fridge with useful features like an auto-filling water pitcher and a temperature-adjustable "FlexZone" drawer. It was a near-flawless performer in our cooling tests.