Question

LaCie Rugged FW not responding

After i updated to Windows 10, my external hard drive. After following many tutorials, but not finding any help, I have come to the decision to ask the internet, great yeah? When i try to open it, it opens a property folder. Please help, all my stuff is on there

Discussion is locked
Follow
Reply to: LaCie Rugged FW not responding
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: LaCie Rugged FW not responding
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Clarification Request
Firewire?

The usual I run into are driver issues. Microsoft gets it better in 10 but it still has me checking my machine drivers like it's 1995. I did encounter this one and the LaCie had USB so we tried that and it worked. The client wanted FireWire (FW) to work but didn't want to sign for our service so never did find out what driver it was on those cases. Support isn't cheap today.

- Collapse -
No firewire port on laptop

I do have a firewire cable, but my laptop doesn't have a firewire input. Any other way to make it work without buying a firewire-usb cable?

CNET Forums