Standard kybds. shouldn't cause a problem. HOWEVER, if you have a kybd. that uses a driver or special setup pgm. then expect a bleak future. Thus, it *may* need some Vista driver release or patch. Then again, if this is a common kybd. it should be ok. Overall, I haven't seen any issues, but as you noted, "some compatibility issues" can crop-up on a new OS release.

tada -----Willy Happy