I don't know laptops, but have you tried those yet?

Assuming you are using Windows XP, (you didn't say), go into Power Options, (either from Start > Control Panel > Performance and Maintenance > Power Options, or right click any empty part of your Desktop, select Properties, then Screen Saver tab > Power settings button), and make the necessary changes there.

Mark