JPEG to JFIF automatically! HELP!

Been working on my website and blog and this issue is wearing me out! Any JPEG image I download is automatically converted to a JFIF file when saved. It was random at first, but now it is doing it regularly and my uploaders for my sites won't recognize JFIF files. I keep having to go to converters online, which don't always work. It's needless and time consuming and is pissing me off! I am not very tech savvy, but I get by. I even tried to open them in paint and rename/save them. NO LUCK! Still a JFIF file. Is this a Windows 10 thing? A Chrome thing? I just want it to stop.

Any suggestions on what this is, why it's doing this and how to fix it??

Thanks in advance and please excuse my rant!!

Kindly, Melissa

Discussion is locked
Reply to: JPEG to JFIF automatically! HELP!
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: JPEG to JFIF automatically! HELP!
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
- Collapse -
Clarification Request
Just last week.

I had a very confused client that took time to grasp that a file extension does not need to match the file association. I don't know how long you've used Windows or if you are looking at the file extension or the misleading Explorer file type.

Tell more.

- Collapse -
Re: jpeg and jfif tells about jfif (jpeg file interchange format). Any hex editor (I'm using hxd) lets you look inside the file to see if it's jfif indeed. Also have a look at the original file to see if they are different or the same. If they are the same, just rename.

It's not really clear from your post what you or 'uploaders' up- or download from what to what using what programs, and what platform your website and blog are running on/written in.
But I've never seen a binary ftp to a site changing a file extension, nor in fact, a download from a site to my browser.
- Collapse -
Clarification Request
1) EZ. 2) Be Careful!

I just ran into something similar on my new Note9. If your attempt to rename doesn't "take" this works for me.
1. Open any file manager. (i find it easier to use than doing it in a photo app.)
2. Find your prob pic.
3. Tap the top-R 3 (dots/lines).
4. Tap "rename."
5. ERASE everything AFTER the LAST period.
6. Tap OK.
7. Go to rename (again).
8. Type the file extension you prefer (e.g. <jpg&gtWink. It doesn't have to include the "e" & it doesn't have to be in CAPS.
9. Tap OK (again). = Done.

(Note: if you're using a PC instead of a phone, read "click" instead of tap.)

#2: "Be Careful" – PLEASE – if you're new to PCs, Windows or programming, even if you trust the source & even if they give what looks like EZ+clear, detailed, step-by-step instructions, DO NOT go ANYWHERE NEAR regedit – NEVER !!! The chances of making a fatal error, aka Blue Screen of Death, are just too great. In truth, it's not fatal. Neither you nor your device will die, but the worst case scenario is you'll have to do a COMPLETE reset = uninstall/reinstall of your OS. Too often that means you can lose ALL your data & files. I guess it would be OK ... IF ... you have a week you don't need. LOL. Because that's what it could take to get everything back to your full satisfaction. Even if the workaround has a lot of steps (like mine, above) it'll still be a whole lot faster & waaay lots less stressful than doing the reset! & it won't take a year off your life expectancy!!

I'm not a technician but i have worked really hard to save too many dying machines. I even got 2 job offers (if i'd been willing to move to India). Even tho i have gone into regedit, the *only* way i'll do it is if i'm speaking IRT with a level 2 (or above) tech AND we're in a remote session. Just sayin.

- Collapse -
Still confused...

Thanks for responding! I'm using Ipage for my website and this also includes WordPress for my blog. All I am doing is finding images to use and saving image as (im making sure they are JPEG/JPGs) and then when it is downloaded, the little download box will name it and put it as a JFIF. I have tried changing it/resaving it in paint as a JPEG but it wont do it. When I go to upload the image, I am told that there was an error, that this format is not recognized. Apparently it is a more recent problem because I am seeing people posting the same issue throughout various forums and online with little to no answers. Sorry I am not really technical to explain it!

- Collapse -
What I didn't share (priors.)

Post was last edited on November 7, 2016 2:23 PM PST

- Collapse -
Not applicable

She is saving the file and then the system autosaves the file as jfif its got nothing to do with drag and drop I've been doing that for years and your answer is irrelevant and makes no sense at all it seems like you yourself are new to PC's and completely don't know what you are talking about!!! some simple advice if you don't read the problem you can't respond if you don't know what you are saying don't respond you are simply wasting time getting nowhere, This problem occurs with a default save method set as jfif change that and your sorted... Open Regedit from your searchbar navigate to HKCR\MIME\Database\Content Type\image/(jpeg key) you will see the Extension value set to ".jfif". change it to ".jpg", and the problem is fixed.

Subject line changed by moderator.

Post was last edited on September 26, 2018 4:45 AM PDT

- Collapse -
Years late but consider this.

Everyday users do not edit the registry. Please supply everyday users a solution.

Here I can share we can rename just as easy and every PC Windows user can usually handle renaming a file.

Thanks for your solution but consider the time of the discussion and think of wide range of user skill levels.

That said I do run into folk that think everyone should "learn up" if they want to use a Windows PC. I'm going to disagree.

- Collapse -
This worked!

"This problem occurs with a default save method set as jfif change that and your sorted... Open Regedit from your searchbar navigate to HKCR\MIME\Database\Content Type\image/(jpeg key) you will see the Extension value set to ".jfif". change it to ".jpg",

thank you Happy.
I never can handle any tech jargons and when i'm looking for help, I just need the instructions like this.

- Collapse -
Divorta's absolutely correct, this is the fix simplified

Yes, I just had the issue and that is the proper solution. Maybe I can try to make it easier following Divorta's advice. This may sound confusing if you don't understand the OS (Operating system) but its not hard, takes a few seconds and will fix the issue. Click start (the windows button on the bottom left of your taskbar below) and just start typing "regedit" and hit enter. Don't do anything to it except the following steps. Navigate thru the list of folders to `Computer\HKEY_CLASSES_ROOT\MIME\Database\Content Type\image/jpeg` then locate Extension. will say ".jfif" under the Value Data. Double click that and change it to ".jpg and your problem will be solved when you attempt to save something else after that. I hope that can help break down the solution for anyone else having this issue that stumbles upon this page.

- Collapse -
Not rocket science

Those instructions did make it very easy to accomplish. I would definitely say anyone unsure at all should leave the registry alone, but if you just go to the specific folder and file, it's not a big deal.

- Collapse -
I'm having the same problem

This is my exact scenario. . . editing my own photos, which have been turned from .jpg files to JFIF, and won't upload to wordpress. Following for a good answer! Thanks!

- Collapse -
JPEGs downloaded stored as JFIF

I discovered this happened as a result of the windows creator update. Every jpeg file identified by the browser as a jpeg when it is downloaded from the web is saved by windows 10 creator as a JFIF file which nearly nothing recognises. However I started a command window navigated to the offending files and using the ren command renamed the files to end with jpg and they now work correctly and will be opened by everything as normal. I t would be very easy to write a little batch file to do this for multiple files if the probel is a big issue. But who knows what Microsoft were dreaming about. I have tried 3 different browsers and behaviour is in all 3.

- Collapse -
Jpegs coverted to Jfif

Hi. I am having this problem, and not being "techy" at all, I didn't understand your instructions. I take the pics with a Galaxy S7 (yes I know, I need a new phone) and email to myself, windows based computer. I then upload to a real estate site, MLS. It converts the pic to a .jfif, which MLS does not recognize.
Is the problem with my phone or computer and how shall I correct?

- Collapse -
Re: jpeg converted to jfif

It's not the file that is converted, it's just the extension that is changed to .jfif. All you have to do: rename it back to .jpg. Renaming a file is basic Windows knowledge, isn't it?

- Collapse -
Re: jpeg converted to jfif

That response seems unnecessarily rude. Removed the extension from the file name has no effect, in this scenario the file extension is automatically reassigned, and removing the file extension from the name doesn't effect the problem.

- Collapse -
Kees has it spot on.

I'm running into more and more users that don't want to learn about computers. They operate at a severe disadvantage and some of them flame anyone that suggest they learn more.

Kees wasn't rude at all except it may be taken as rude to those that want computers to work without learning how computers and Windows works.

- Collapse -
Jpegs converted to Jfif

Hi dcblogic! I'm not "techy" either and this problem has been making me crazy as well. By reading through this thread I was able to easily solve the issue. Go to your pictures folder, right click on the image you are using, click on rename, add .jpeg to the image name. It doesn't matter that under TYPE it is still showing as a jfif file. Try using the image. This worked for me and is a non "techy" easy solution.
Later... tried it again, didn't work! Grrr

Post was last edited on August 17, 2018 7:46 AM PDT

- Collapse -
Win10 Solution

Open regedit

Navigate to:




Content type


change "extension" value to .jpg

Close regedit, done.

- Collapse -

I had the same problem, and it was driving me crazy. You really saved my day. Thank you!

- Collapse -

I checked my registry, and it already contained .jpg.
I wonder why it's sometimes changed.

- Collapse -
Thank you

Thanks, this helped me too Happy

- Collapse -

Easy to follow instructions = quick fix. Thanks!!

- Collapse -

Thank you mate so much!!!

- Collapse -
JFIF back to JPEG as default - LIFE SAVER - thank you!

This fix worked perfectly. I noticed this undesirable & frustrating situation last week when a friend texted a photo of the group of us at a concert. Could not edit or change the extension with the limited knowledge this problem & the available software programs on my computer. Then I noticed ANY photo or image I downloaded was also being saved automatically with the .JFIF extension. Total nightmare.

I AM SO GRATEFUL for your post. Thank you again!

- Collapse -
Thank youuuuuuu

Thank u soo much! Total life saver! It was annoying to have to autoupdate the system and ended up having the pictures saved in an unknown Format. Tq again.

- Collapse -
JPEG to JFIF automatically! HELP!

From HKEY_CLASSES_ROOT, I can't find MIME. What do I do now?

- Collapse -

Thank you so much, I was having so many issues with this and didn't realise what an easy fix it could be. Life saver!

- Collapse -


- Collapse -
JFIF to JPG Solved!

Thank you for clearly answering this question. I was able to do this easily with your solution.

- Collapse -
I figured it out!!

It's actually quite simple, go to the image properties and rename it to have .jpeg at the end instead of .jfif it works every time

CNET Forums