Browsers, E-mail, & Web Apps forum

General discussion

Java Problem? Certain website not working

by archers44 / April 7, 2006 2:56 PM PDT

I've tried to visit several mainstream websites recently and am having problems getting them to work properly. They appear to work just fine with my work computer so I'm guessing its a problem on my end. This problem happens in both IE6 and Firefox. I use Windows XP at home and Windows 2000 at work (but a friend with XP home doesn't have these problems so I don't think this is an XP issue)

For example - it opens and looks like everything is fine - but if you go to a link for a specific show (say The Unit - and then enter the site) - the black bar at the top is supposed to have a pull down menu for other shows - mine doesn't (its just not there). Underneath that is supposed to be another bar for show information (episode guide, bios etc). On my home computer this doesn't exist.

On the homepage in the upper left hand corner above the image I see these characters: ');}; // -->

This got me thinking the problem is a Java script problem. I've tried uninstalling and reinstalling Java - even tried installing an older version (like what I have at work) but the problem persist. I've also tried playing with my Internet Options to no avail.

Any idea how to work around this. Obviously this isn't a life ending problem but its annoying - if for no other reason then I know there is a problem and I have no idea how to fix it!

Thanks for any suggestions!!!

Discussion is locked
You are posting a reply to: Java Problem? Certain website not working
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Java Problem? Certain website not working
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Java vs Javascript...
by John.Wilkinson / April 7, 2006 3:10 PM PDT

You're right, it does sound like a Javascript issue, but the catch here is that Java and Javascript are two separate beasts. (Click here for a comparison.) I'd suggest clicking here to download Windows Script 5.6, which with a little luck will solve the problem.

Hope this helps,

Collapse -
If you are using
by PudgyOne / April 7, 2006 4:35 PM PDT
In reply to: Java vs Javascript...

If you are using NoScript as one of your Mozilla Firefox extentions, you have to tell it to temporalily allow

That is just a part of the problem. You will also need to download the macromedia flash player. The FREE macromedia Flash Player can be downloaded at

Also, if you are using the extention Flashblock in your Mozilla Firefox Browser you'll have to click on the grey arrow for the other menu to appear.

Hope this helps.


Collapse -
problem exist in both Firefox and Internet Explorer
by archers44 / April 8, 2006 1:10 AM PDT
In reply to: If you are using

Thanks for your help Rick!

I do have the NoScript plug-in but I have allowed and unfortunately that didn't fix the problem.

The problem exist in both Internet Explorer and Firefox this is what is making it hard for me to figure out.

I do have flash and even updated it yesterday thinking that could be the problem - I don't have the Flashblock plug in so that part isn't an issue.

Thanks for your suggestions!

Collapse -
Now try this
by PudgyOne / April 8, 2006 5:59 AM PDT

Now try this.

You must be signed in as administrator.

Go to control panel

Click on internet options

click on security

click on custom level

make sure you are set at medium

come down to active scripting
allow or prompt

allow paste operation via script
allow or prompt

scripting of java applets
allow or prompt

click apply and restart your computer

Then go online

Open Internet Explorer

go to

download both the Flash Player and the Shockwave Player

close Internet Explorer.

Open Mozilla Firefox.

go to

download both the Flash Player and the Shockwave Player

close Mozilla Firefox.

Restart your computer.

Now try it and see if you can view them correctly. The use both Java scripting and the Macromedia Flash Player. The scripting iis needed so when you use Mozilla Firefox, you have to tell the NoScript to allow scripting for it to function correctly.

Try this and let me know if it is working.


Collapse -
No luck
by archers44 / April 8, 2006 6:26 AM PDT
In reply to: Now try this

Hi Rick,

I checked all the settings you suggested and that's how they were already. I downloaded a new Flash yesterday but had forgotten about Shockwave so I downloaded the update to that just now. Even after rebooting the problem persist.

If it makes a difference I emailed one of the website I was having a problem with (washpost) and say hey could there be a problem with the site and the next day the problem seemed to fix itself for a few hours but then it started happening again. So maybe the problem is on their end? I tend to be vigilant about keeping my home computer up to date. Perhaps I updated soemthing that is causing the conflict? The IT guys at work keep us pretty up to date but I'm not sure that they update as frequently as what I do at home.

Thanks again for all your help!

Collapse -
XP Setting
by PudgyOne / April 8, 2006 6:49 AM PDT
In reply to: No luck

I feel it must be an XP setting.

I do NOT have XP so I don't know how the settings are.

You need Java Scripting

and you need the Flash Player

for the website to function properly.

There must be a setting somewhere.

Also are you using the latest version of Mozilla Firefox ?

Are you using some type of firewall at home?

Windows XP Firewall and/or Zone Alarm?

Could be some Fiewall setting blocking this.

Sorry I tried what I know. Someone will have to help you with the settings in Windows XP to correct the problem.


Collapse -
by archers44 / April 8, 2006 9:17 AM PDT
In reply to: XP Setting

Hi Rick,

Thanks so much for your help! I really appreciate your advice! I agree completely that its a setting gone wrong somewhere - if nothing else maybe it will just fix itself - stranger things have happened!

Thanks again!


Collapse -
I don't think
by PudgyOne / April 7, 2006 4:43 PM PDT
In reply to: Java vs Javascript...
Collapse -
Still not working :(
by archers44 / April 8, 2006 1:07 AM PDT
In reply to: Java vs Javascript...

Thanks John for the info.

I didn't realize that Java and Javascript were that different.

I downloaded the Windows Script 5.6 but it didn't fix the problem.

Thanks for your suggestions!

Collapse -
Would you try something for me?
by PudgyOne / April 9, 2006 5:00 AM PDT
Collapse -
It works
by archers44 / April 9, 2006 8:30 AM PDT

I saw and heard it loud and clear!

It seems to be pull down menus that disappear or I see what looks like html coding on the actual page - I've done a bit of coding years ago but just basic stuff. So I don't understand what I'm seeing enough to know what it is. But what I don't understand is why the coding is visible on my computer and no one elses. And why they can see all the pull down menus and I can't. Baffling!

Thanks again for your help!


Collapse -
I do not see
by PudgyOne / April 9, 2006 8:48 AM PDT
In reply to: It works

I do not see the coding on the Washington Post.

So we now know you have the Flash player installed.

Now go here

and see if the drop down menu works. If the drop down menu works, then it sounds like a problem with

I noticed that they changed their website at CBS.

Try the drop down menu in the upper right hand cornoe and try to go to The Unit. It worked for me and it might now work for you.

It might have been that while they were changing the website you had the problem and it may now be corrected.

Hope this helps.


Collapse -
Doesn't check out
by archers44 / April 9, 2006 10:15 AM PDT
In reply to: I do not see

I don't see the pull down menu on the website. All I see is the black bar at the top - but I see pull down menus every where else - just there.

If it was a universal problem I'd assume the problem is on their end - but the fact that everyone else can see these site correctly using all sorts of operating systems and browsers and its only at home I can't see them that it makes me thing the problem is on my end.

My next step is to uninstall and reinstall Firefox to see if that helps (I don't have a clue how to do that with IE so I'll just stick with Firefox) - maybe that will fix the problem

Thanks again!

Collapse -
Re: certain sites not working
by Kees Bakker / April 10, 2006 7:42 AM PDT


Pudgyone brought this thread to my attention, because he only has Windows ME and thinks it could be a settings problem with XP. After investigating it, I don't think so at all, however.

Both pages, both and rely heavily on javascript. IE and Firefox however, have different javascript engines, and moreover, reinstalling the MS version (the windows scripting engine) doesn't help.

The particular text you see in the washington post page is recognizable in the source (View>Source) I see on both IE and Firefox. Have a close look at this piece of code (it located before the washingpost image in the upper left corner); I made it bold, but it isn't very clear nonetheless.

if ( now >= ''04190000'' && now <= ''04192359'' )
{document.write('<script type=''text/javascript'' src=''''></script>');};

// -->


The page is more difficult to understand, but uses the document.write construction also, and it could well be that it's just about the places where you miss elements on the page.

My guess: some malware intercepting the html-code but unable to correctly handle document.write statements (dynamic html).

Can you enter View>Source in IE (and in Firefox, it's View>Page source, I think or ctrl-U), search for the first occurrence of 04190000 and compare the code shown with you with the code shown above. If it differs, it's corrupted. And the only reasonable reason for corrupted code is malware, I should say. For a repeatable error like this, I don't suspect your modem, modem driver, ISP or winsock software.

Only my point of view, of course. But as you won't like malware on your system you'd better check.

Hope this helps.


Collapse -
Can't find the exact same code
by archers44 / April 10, 2006 9:59 AM PDT

Hi Kees,

Thanks so much for all the good information. I've done some digging and using the find I can't find the numbers 04190000 anywhere in the code (I tried using IE and Firefox to no avail). I also tried changing the settings from the DC homepage to the National homepage thinking maybe that would make a difference but still couldn't find it.

But the symbols you bolded );}; only appear once in the code:


</script> </HEAD> <body topmargin="2" leftmargin="5" marginheight="2" marginwidth="5" bgcolor="#ffffff"> <!-- *** HEADER FULL *** -->

<script type="text/javascript">

if ( typeof thisNode == "undefined")
var thisNode = "/" ;
var thisAncestor = thisNode.split("/")[0] ;
var homepage = true;
// -->

I understand the code just enough to know that I don't really understand what I'm looking at. But I think I got the entire segment (/script to /script)

But the fact that I'm not seeing what you're seeing makes me think that you're probably right that I have something bad on my computer that I really don't want there. Which opens up a whole separate can of worms doesn't it. So I guess I need to start doing a bit of research to see what I need to do to fix this problem - and if it means wiping my computer and starting over getting some help - I've ruined enough computers in my life to know that that won't end well for me!

Thanks again everyone for your help - I think you've sent me down the right path - not a path I want to be on but at least I know where I am so I can figure out how to get off!


Collapse -
Thank you Kees, and Jennifer
by PudgyOne / April 10, 2006 1:44 PM PDT

Thank you Kees for your help.


Here are some great tools to help you remove viruses and spyware.

As for all people you should have good virus protection. AVG FREE or AVAST are great virus programs

Also you need to have measures to stop spyware from getting into your computer. You can get C W Shredder to help remove some and you can also use SPYBOT SEARCH & DESTROY. Another good spyware remover is AD AWARE and one that stops spyware from getting into your computer is SPYWARE BLASTER. Then when all else fails you can get HIJACKTHIS.

If you use all these tools it will not elminate spyware from getting into your computer, but it will help. Some spyware gets into your computer using the Macromedia Flash player. If you feel that you still might have spyware in your computer, then you can go to TREND MICRO to do another online scan.

This may keep you busy for awhile.

Hope this helps.


Collapse -
if its not malware could it be something else?
by archers44 / April 10, 2006 2:13 PM PDT

Hi Rick and Kees,

I'm not sure I'm posting this in the correct category anymore but I'm hoping you two can point me in the right direction.

For as long as I've owned this computer, the security that I've had on it is: its been hooked up to a router (for the firewall - its not wireless), I have Norton Internet Security (for the anti-virus and firewall), SpyBot run daily, Ad-Aware which runs periodically, Microsoft AntiSpyware (since Dec 05). Those are the staples and all of the programs run weekly if not more frequently. I also had Microsoft OneCare installed for a while but uninstalled it because it was conflicting too much with my other firewall which I forgot to uninstall first. So while I know nothing is 100% certain I've also done my best to protect my computer.

So after getting Kees email I did some searching on malware removal on Cnet and across Castle Cops. I went through the entire process of removing malware from my computer (with the exception Symantec Blackworm removal because I didn't understand what I was supposed to be doing). I ran my computer through all the programs they suggested, cleaned my computer which removed thousands of files and the only problem any of them found was a tracking cookie which was fixed.

Unfortunately my problem persist. I've posted my hijack logs on their bulletin board hoping they'll find something but if they can't am I at the last resort of wiping my hard drive and starting over?

I always tell my IT guys at work I know enough to get myself into trouble but not enough to get myself out. Its been quite a while since I've done something like this - I guess I was due.

Thanks both of you for all your help and persistence! You have no idea how much I appreciate it!


Collapse -
Some homework for you.
by Kees Bakker / April 10, 2006 6:13 PM PDT

Play for Sherlock Holmes and you'll end up saying that it was 'elementary, my dear Pudgy and Bakker'.
Here we go:

- At work, in IE save both the washington post page and the cbs page as both html only and as full web page. That gives 4 files. Take them with you to your home on a diskette or a USB-stick or via mail.
- Same at home.
- Compare the 4 files (size, contents) - you can open them (especially the html-only version) with Notepad to see the source. If the are different, there's something wrong with reading the page online.
- See what happens if you click (in Windows Explorer) on the 4 files you made at home. They should open in your default browser (Firefox or IE). Use the address bar to access them in the other one.
- Same with the 4 files you made at work. Note the differences.
- This (especially the full web page) might show a difference between online and hard disk. If the html-files are the same, this points to security settings between local zone and Internet Zone. Then try moving the sites to the trusted zone and see if gives a difference.

I don't expect it will help, but try renaming your hosts file (then reboot) to see if it makes any difference. That's one of the basic things IE and Firefox have in common.

I could make some simple test files with document.write init that you can view both locally and on the net, but having the results of these experiments will limit the things to test, I hope. That's nice for both of us.

Collapse -
Failed Homework
by archers44 / April 11, 2006 4:29 AM PDT
In reply to: Some homework for you.

Hi Kees,

Do we get to wear the fun hats and move to London? If so I'm all in!

Well I've been able to save copies of the html only copies of the post and cbs website but I'm not able save full copies - it tries to save and says it cannot be saved to this destination. I tried changing the destination to no avail. it it makes any difference the regular save (not the save as) is greyed out - maybe they block you from saving the site?

Anyway - I'll check out what I can when I get home. I'll check tonight and see if I can save them at home - in which case I'll compare tomorrow at work.

Thanks again for your help!

Collapse -
(NT) (NT) I always hated homework!
by PudgyOne / April 11, 2006 6:25 AM PDT
In reply to: Failed Homework
Collapse -
Let's call it 'research' then ...
by Kees Bakker / April 11, 2006 7:51 AM PDT

or 'some experiments' or 'something to investigate'. Sounds better?

Anyway, I always did all my homework at high school and all that led to is a very unpaid and rather timeconsuming 'job' as a moderator here. Was it worth the trouble?
My son spends most of his time with WoW (World of Warcraft) in stead of doing his homework. I wonder what will become of him.

Not relevant at all, this post.


Collapse -
by Kees Bakker / April 11, 2006 7:12 AM PDT
In reply to: Failed Homework


I'd tried to save the washingtonpost page this morning at my work and both ways worked (or I wouldn't have suggested it, I dare to say now). But now at home the full save doesn't work either, nor the save as one file (*.mht). I've got no idea what the cause can be.
In fact, saving worked in Firefox.

And just one minute later, it worked in IE also! I can mail it to you if you want (it's one htm-file, and a folder with all pics), easily zipped. It's not recommended to publish your email-address on the forum (unless you want to receive spam), but you can mail me via my profile and mention your email address in the body of the mail. But maybe, the html-only version is enough to make conclusions, so let's see if it's necessary.

Maybe we really need a Sherlock Holmes. Although even he might be baffled by transient failures.

See you in London then? It's not far from Holland and there's a lot to see and do for tourists.


Collapse -
Thank goodness I'm not the only one!
by archers44 / April 11, 2006 8:29 AM PDT
In reply to: Strange.

Well I was able to save both the html only and complete files for both cbs and the post at home - go figure. So I can take them to work and try to read them (although if my computer at work continues to act up then I pushing it out the window and it might take a while! Happy

All that being said the file size of the html only files are similar - about 5 KB difference. I say that and honestly - I have no idea if 5 KB is alot in this case. I tried to open both in IE and Firefox and neither opened properly but they had lots of problems so I think that might be the fact that they're the html only files.

Thanks again!

I tried looking at the code - and for the files I save the code is completely compressed - it looks a mess and I'm having trouble reading it - am I looking for something in particular?

I definitely don't want spam - I spent 6 hours cleaning my computer last night looking for bad stuff - I want no more bad stuff ever! I'll send you a note via your profile.

I'm still hoping the castlecop gurus can find something in my hijackthis files - to me I'm reading greek - thank goodness so many others can read greek!

London sound like a plan - actually all my problems started when I returned from a trip to England - perhaps if I take another trip when I return the problems will fix themselves just like magic!

Collapse -
Re: I'm not the only one.
by Kees Bakker / April 12, 2006 1:27 AM PDT


5 kB probably has to do mostly with difference in the contents of the files at washington post. After all, it's news, and news varies.

The html-only files wouldn't open indeed, missing all kind of things. But the full saves should open from the hard disk.

If you can't find out, I would like to have a look at the files saved at your home to compare them with my own copies (that worked correctly). Both the html-only = 1 file, and the full save = htmlfile + folder (the html-file should have a different name from the html-only, of course). Please mail me via the forum mail mentioning your email-address and I'll reply with mine.

If the castlecops guys don't respond, I'd like to have a look at your hijackthis-log also, if you don't mind. But don't post it on the forum.


Collapse -
This is tricky
by PudgyOne / April 12, 2006 3:43 AM PDT

This is tricky. I tried to copy the page source and it told me I do not have enough memory.(511mb)

I tried to sen it as a compressed folder and I had to copy and paste everything there.

I thought working for a newspaper in Pennsylvania Dutch Country was tricky enough. I wish they would send me on a trip.

I don't know which ones will work for you. I NEVER ran into this type of problem before. Don't even know if it will be helpful for you.


Collapse -
(NT) I haven't made thing easy have I?
by archers44 / April 12, 2006 12:39 PM PDT
In reply to: This is tricky

Hi Rick,

Geeze - we all had trouble but it was different for each of us - its always the problems that appear simple that are the worst to deal with!


Collapse -
hijackthis link
by archers44 / April 12, 2006 12:35 PM PDT

Hi Kees,

If you want to look at my hijack this stuff here's the link to the info.

They're still working on it - just reading through the problems others are having mine are minor in comparisons so I hope they help some of these other people first. Mine's just annoying (only made more so because I can't fix it). Some of the others have massive problems! Puts it all in perspective I guess.

Talk to you later!

Collapse -
Looks ok to me...
by John.Wilkinson / April 12, 2006 2:30 PM PDT
In reply to: hijackthis link

I've been following this thread but haven't been able to figure it out either...everything says there shouldn't be a problem, but somehow it's there. As to your log, I'd just like to note a couple of things:

* I saw plenty of AV protection (Norton's installed, plus online scans with McAfee, Panda, and CA), but didn't catch a firewall...I'm assuming the low-level Windows Firewall?

* Microsoft Antispyware has been replaced by Windows Defender, an updated version of the software that remains free.

* There's an updated version of Java available here.

* Some will say I nitpick at this, but the entries with are ones I don't like...the company has too many business practices I don't approve of, so I'd take those entries out.

* Those ending with (no file) are obsolete and safe to delete.

Aside from that I'd say you're perfect, which is either good or bad depending on how you look at it. (Some of the others may be better off since at least they know what the problem is.) I wish you luck and if I see anything I'll be sure to jump in.


Collapse -
by archers44 / April 13, 2006 3:25 AM PDT
In reply to: Looks ok to me...

Hi John,

I actually have Norton Internet Security which has a firewall so I'm a bit concerned that you don't see that - maybe its not working properly? I also have a router on it simply for the hardware firewall protection. As someone who ruined 3 computers in 6 months when the Internet first became mainstream I've a bit hyper sensitive now.

I keep meaning to download the new version of Microsoft's program haven't yet - thanks for teh reminder its what I needed.

The Java program is old because I had the new version and when this problem first started I thought well maybe my version is too new and it can't read it properly so I got the version that a friend was using (and he wasn't having the problem and installed that instead). I believe Java actually prompted me to upload last night but I'll double check that.

The Dell stuff is just my laziness - I don't use most of it (I'm not sure that I use any of it).

Part of me says it might be better at this poitn if I could find some sort of relatively benign spyware that would be fixed easily because then problem solved. But instead I get a challenge.

The castlecop people closed my entry because they see that we're still discussing over here - but after all the cleaning I did with no results and the fact that you're not seeing a problem makes me think there isn't much else they can do to help at this point.

I worry at this point that I'm wasting everyone's time which is not what I ever intended (I thought this would be an easy quick fix kind of thing). Its not a serious enough problem to justify wiping my hard drive and reinstalling everything so it might have to be one of those annoying quirks that I just have to live with (and will hate my computer every time I'm reminded of it!) But I don't want to make everyone spin their wheels for nothing!

Thanks again for all your help!

Collapse -
System Restore?
by Kees Bakker / April 12, 2006 5:20 PM PDT


You write things started after your return from England. I'm sure that has nothing to do with it, but it gives a starting point for the troubles.

Can you do a System Restore back to before that time? It's still a mystery what happened, but I don't believe it's a hardware problem. So there's a good chance (well, a chance) that doing such will correct the anomaly.

Looking forward to receiving the html from your machine, so I can try it and compare it with mine.


Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?