General discussion

iTunes9 and podcasts not playing issue...

Hey everybody! This is my first post on cnet forums...
Anyway, I was hoping to get some light shed on my issue:
On my late 2008 iMac (running 10.5.8 and iTunes 9.1(79)) I can't watch most of iTunes podcasts. Cnet SD video podcasts work fine, and all audio podcasts work fine, too, so I'm guessing that the issue is video encoding/decoding. When I click play on most podcasts, they begin to load, I get the white box where they should appear, sometimes even sound starts to play, but there is no video(?), network activity is at it's peak, something is downloading, but podcast are not showing. Same thing when I download the podcast and try to watch it offline.
I have updated Quicktime to the latest version, I have DivX for Mac, Perian and VLC installed, too, that should cover all codecs...
Anybody having this issue? Has anybody some suggestions on how to fix this issue?
In Windows, on same PC, none of the video podcast work, only audio. Windows is loaded with all possible codecs there are and all ultra pirated and obscure formats play without any issues...

Discussion is locked

Follow
Reply to: iTunes9 and podcasts not playing issue...
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: iTunes9 and podcasts not playing issue...
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments

CNET Forums

Forum Info