Question

Issue with reinstalling PCI wifi driver

Having some issues reinstalling the TP-Link WN881ND PCI driver. I was having some issues so I uninstalled. When I tried to reinstall using the setup I ran into an error that says
"You have already installed a driver if you want to install the new driver, please uninstall the old one first"

Discussion is locked
Answer
Follow
Reply to: Issue with reinstalling PCI wifi driver
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Issue with reinstalling PCI wifi driver
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Clarification Request
Did you try removing it

In device manager?

Try there, try to install after and after a reboot.

Post was last edited on January 30, 2018 7:07 PM PST

- Collapse -
Uninstall

I've already uninstalled it in device manager and rebooted

- Collapse -
While for W8
- Collapse -
No driver files

TP link doesn't offer any driver files for this driver that I can find, only a setup.exe

- Collapse -
Yes. Driver files.

Inside TL-WN881ND_V1_130521.zip I found the usual .cat .inf and .sys files.

Remember this is usually very hard on everyday users. The faq-460 looks correct to me and I can see the files. Sorry folk, but it's old school driver install time.

- Collapse -
how to do it

If he can find those files, then place in the same folder, he can right clk on the .inf file and choose "Install" and it should work then.

- Collapse -
The new drivers at the site

Don't have the old school INF and SYS files.

On top of that the V1 hardware has no drivers for newer Windows. If the board is V1 then a lost cause unless they want to run Linux. Frankly I'd just swap it for another card or stick.

- Collapse -
Answer
Wifi

Does this tp-link show in programs and features?

- Collapse -
Answer
Solution?

How did you solve this problem? I can't find any solution. I deleted the driver and I received the same message when trying to install it again.

- Collapse -
I went back to check on my prior answer

And the driver package has changed as well as support for V1 hardware does not include Windows 10 so you have to remove V1 hardware if you have it as there is no driver.

- Collapse -
Answer
Try Apps & Features

Hi,
I had the same issue and apart from uninstalling that via device manager, after many tries I found out that I also had to uninstall the "driver app" from programs ("Apps & features") ...

Hope that helps

CNET Forums