had it warn me occasionally on things. The type of program that it is does not require updates which is why the last time was 2004.