(you're on the web design forum now, you know) you don't use Firefox or IE to make your application. Those are browsers only.

But you surely check your application works correctly on current versions of both, that is at least IE7, IE8, Firefox 3.0, Firefox 3.5. Any serious application should be tested also against IE6, Firefox 2, Opera, Chrome and Safari (both the Windows and the Apple variety).