Networking & Wireless forum

Resolved Question

IPv6 tunnel performance

by wahyunjati / November 13, 2014 3:41 PM PST

I'm analyzing the performance between a native IPv6 network and an IPv6 network that uses a tunnel through an IPv4 network by using iperf (my network consists of 3 routers and 2 PCs). I sent TCP packets through the network with varying window sizes, from this i got that the maximum bandwith of the native network is 58Mbit/s meanwhile the tunnel network is 27Mbit/s. I'm quite surprised with this result, does implementing a tunnel really reduce the network performance this much?

I've also tried looking into the cpu process and there's a higher persentage on the IP input then the IPv6 input, does this have anything to do with it? (I sent UDP packets with a bandwidth of 10Mbit/s)

CPU utilization for five seconds: 43%/17%; one minute: 8%; five minutes: 19%
PID Runtime(ms) Invoked uSecs 5Sec 1Min 5Min TTY Process
57 731948 611694 1196 17.35% 3.20% 7.94% 0 IP Input
27 362740 522378 694 7.86% 1.36% 3.13% 0 IPv6 Input
56 892 590 1511 0.24% 0.02% 0.00% 0 CDP Protocol
139 240 15291 15 0.08% 0.01% 0.00% 0 MLD
4 4 1 4000 0.00% 0.00% 0.00% 0 EDDRI_MAIN

I'm using c2801-adventerprisek9-mz.124-25a.bin, here's the configuration on one of the end tunnel router:

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
no aaa new-model
ip cef
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
ipv6 unicast-routing
!
voice-card 0
!
interface Tunnel1
no ip address
ipv6 address 2001::1/64
ipv6 enable
tunnel source FastEthernet0/0
tunnel destination 10.0.0.6
tunnel mode ipv6ip
!
interface FastEthernet0/0
ip address 10.0.0.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
ipv6 address FD87::/127
ipv6 enable
!
ip forward-protocol nd
ip route 10.0.0.4 255.255.255.252 10.0.0.2
!
no ip http server
no ip http secure-server
!
ipv6 route FD87::2/127 2001::2

thanks in advance, your thoughts are much appreciated Wink

wahyunjati has chosen the best answer to their question. View answer
Discussion is locked
You are posting a reply to: IPv6 tunnel performance
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: IPv6 tunnel performance
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Best Answer chosen by wahyunjati

Collapse -
You explained it well.
by R. Proffitt Forum moderator / November 13, 2014 11:00 PM PST

Adding more overhead will reduce speed. It's that simple and you explained it well.
Bob

Collapse -
thanks bob
by wahyunjati / November 14, 2014 4:55 PM PST
In reply to: You explained it well.

thanks bob, does this mean that the extra encapsulation/decapsulation process is resource intensive?

Collapse -
Or
by R. Proffitt Forum moderator / November 14, 2014 11:35 PM PST
In reply to: thanks bob

There is a trick in the land of IP networking that a pass through can start transmitting just down a few bytes in the stream. This is done in some gear but here's the rub of encapsulation. It may have to wait till the entire packet arrives then encap and then transmit. That blows away the trick that some gear uses to start moving the data out faster. Your post explained why it slowed down. I only nodded and echoed back the short version.
Bob

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

FALL TV PREMIERES

Your favorite shows are back!

Don’t miss your dramas, sitcoms and reality shows. Find out when and where they’re airing!