Mac Hardware forum

Resolved Question

iPhoto 6 to iPhoto 11 jump.

by shafiqkhan31 / June 24, 2012 11:15 PM PDT

I upgraded my MacBook 2,1, 2GB RAM running Tiger to Snow Leopard, after saving my stuff including photos on an External HD.
Now I can not open my iPhoto 6 photos (as these were on Tiger) to the new environment. In the first place I did not know that Snow Leopard did not have iPhoto in the package.
I have found my old saved iPhoto file in the Time Machine , I moved the folder to my Hard Disc, then opened it . The iPhoto opened but no photos.
How can I restore my photos which I saved in Tiger using iPhoto 6?
Be grateful for help. I have been on a steep learning curve since the change. I would like to have my photos back.
I managed to get my Music back from the iTunes as the iTunes enabled me to retrieve it from their records of purchase, but I am stuck for the photos.

shafiqkhan31 has chosen the best answer to their question. View answer
Discussion is locked
You are posting a reply to: iPhoto 6 to iPhoto 11 jump.
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: iPhoto 6 to iPhoto 11 jump.
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Best Answer chosen by shafiqkhan31

Collapse -
Was there any form of error/warning message when
by mrmacfixit Forum moderator / June 25, 2012 10:33 AM PDT

you opened the iPhoto Library in Snow Leopard.

You should have got a warning stating that this version of iPhoto was too old for Snow Leopard.

Either way, try the reinstall as suggested by brace yourself to be ready to purchase a new version of iPhoto


Collapse -
iPhoto 6 to iPhoto 11 jump.
by StevenDilley / June 25, 2012 11:39 PM PDT

Hello friends,

I would like to say, in iPhoto '11, select the option to "Repair the iPhoto Library Database" to check the iPhoto Library database for inconsistencies and repair them, if necessary. IPhoto '11 also includes the option to "Rebuild the iPhoto Library Database from automatic backup," which performs the same functions as it does in iPhoto '09, but should only be attempted if the "Repair the iPhoto Library Database" option does not help.

Best regards

Collapse -
No warnings.
by shafiqkhan31 / June 26, 2012 1:26 AM PDT

I still have not got my photos. I will be very happy buying iPhoto 11, but how do I get the photos? I high lighted the iPhoto in the Time Machine and then pasted the iPhoto in the Hard Drive, thereby transferring iPhoto as it was in the external drive, but no photos. This file was only 529.6 MB, I had some 900 photos which I thought I backed up before indulging in upgrading.
Please advise ,how can I get my photos back in the Snow Leopard.
Thank you for your interest.

Collapse -
Highlighting, copying and pasting is not
by mrmacfixit Forum moderator / June 26, 2012 3:01 AM PDT
In reply to: No warnings.

the way to move stuff from your Time Machine backup to your internal drive.

Time Machine creates a sequential backup after it takes the original, first, FULL backup.

To ensure that you have everything you need to use the Restore function of Time Machine to place iPhoto back to where it was and in the same state as it was at the time of the last backup.

Do that and get back with us. Stop the drag and drop stuff.

While we are here, can you confirm that you did actually do a Time Machine backup and not a drag and drop to the external drive.


Collapse -
the saga started with upgrade notion.
by shafiqkhan31 / June 27, 2012 12:28 AM PDT

As I stated in my original message for help. I backed up my photos on my MiniStation (Buffalo) External hard drive before upgrade. I did not know a thing about the Time Machine.However, I checked my photos were there on my External Drive before upgrade as I checked the success of my back up in the Tiger.

After upgrade to Snow Leopard I was faced with the Time Machine. I tried to open my External Drive but the Time Machine intervened. When I clicked the message came up that I can not open photos as they are in Time Machine. Whatever happened and how it happened ,it happened without me purposefully doing it. Then I did not see any escape and I got into Time Machine in order to retrieve the photos.

The Time Machine has been backing up since but there is no trace of the photos. My knowledge of te Time Machine is Zilch. I am doing whatever I am advised ,even that pretty badly.


Collapse -
That's a bit of a story change and may explain why you have
by mrmacfixit Forum moderator / June 27, 2012 11:57 AM PDT

no pictures.
Your MiniStation external hard drive was probably formatted as FAT32. It was formatted like that when you took it out of the box and plugged it in.
It worked because just about any computer can read and write to a drive formatted in that way.

You copied your pictures from the internal drive onto the external and, for some reason, appear to have deleted them from your internal drive.

Then you upgraded to Snow Leopard and rebooted with the external still connected. As soon as Leopard saw the external it asked if you wanted to use it as the Time Machine backup drive. You answered "Yes"
Time Machine then formatted your external drive as Mac OS X Extended(Journaled) and proceeded on with life as a Time Machine drive.
The format from FAT to Mac deleted everything that was on the drive, photos and all.

You never did have a Time Machine backup prior to the upgrade so you could not have found the old iPhoto Library in Time Machine. Any Time Machine backup taken after the upgrade would have included any photo's that were on the internal drive, assuming that iPhoto Library actually had any photo's in it. From what you are telling us, it would appear that there were no photo's in the library before the upgrade took place.

Sorry to say this, but I think your photo's have gone but, you "may" have a very slim chance of recovery using an Undelete program.


Collapse -
Thank you.

I am grateful to all of you who helped.
It appears that I shall have to pay a visit to the Apple store to see if I can find a solution.
Thank you.
I shall report on the result of my visit.

Collapse -
Use Tiger Disk
by KenHusveg / June 25, 2012 12:10 AM PDT

If you still have your Tiger disk try reinstalling iPhoto from there to Leopard.

Collapse -
by shafiqkhan31 / June 25, 2012 4:36 AM PDT
In reply to: Use Tiger Disk

I can give it a go!Thank you.

Collapse -
I tried.
by shafiqkhan31 / June 26, 2012 1:18 AM PDT
In reply to: Use Tiger Disk

I tried the Tiger Disc and extracted Iphoto but there were no photos.
I opened the external drive had iPhotos but no photos.

Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?