Question

Internet pages not loading

so, basically my internet pages are not loading properly. when it goes to a site, I cant scroll down, or view things unless i open another page and flick between the two while one loads.
how do i fix this. it never used to do it and I'm getting sick of it, especially when I don't need two pages up Happy

Discussion is locked
Follow
Reply to: Internet pages not loading
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Internet pages not loading
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
Re: internet pages not loading

Something seems wrong with your current browser.

So first try another one. Choose from Internet Explorer (free with Windows), Firefox (free from Mozilla) and Chrome (free from Google).
Once you can work normally (in one of the others) come back here and tell which browser has this issue.

Kees

- Collapse -
internet pages

thanks Happy
I switched to Firefox now. its currently working fine Happy
i was using Google chrome, and it only started playing up about a week ago. thanks for your help Happy

- Collapse -
Answer
Junk or corruption

Have you ever cleaned it out. They do get loaded with spent material (cookies, history, that sort of thing) after a time and do need cleaning. Check your setting goto the wrench>settings>history>click the remove all button then restart the browser. If that fails remove chrome browser then reinstall it; the software maybe corrupted.

Hello keys

CNET Forums