I'm not 100% certain, but that may be your first problem, besides the fact that it's a cheap iPhone knockoff. Does this look familiar?

Try the following settings below. If you still aren't seeing any results, the lack of 850 is the real issue.


APN: wap.cingular (note no dot com on end)
Password: (there are nine * I don't know what it is)
Login Request: Off
Allow Calls: automatic
IP address: Leave blank
DNS address: Leave blank
Authentication: CHAP is ticked
Data compression: Off
Header compression: Off

On the Ineternet settings... use the same profile above:
User Proxy: Yes
Proxy Address: wireless.cingular.com
Port: 80
Username and Password are blank