Networking & Wireless forum

General discussion

Intel(R) Centrino(R) Advanced-N 6250 AGN won't use n band

by rookie580 / October 27, 2010 7:50 AM PDT

I have a Intel(R) Centrino(R) Advanced-N 6250 AGN wireless adapter in a WIN 7 machine that connects just fine to the internet both wirelessly and wired....except it won't connect on n. We have a DLINK router that does a, b, g, and n. Another computer in the house is connecting on n, and mine is connecting on g (another computer can only do g so we can't make the router only n). 802.11n mode is enabled.

How do I make the adapter use n instead of g?

Discussion is locked
You are posting a reply to: Intel(R) Centrino(R) Advanced-N 6250 AGN won't use n band
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Intel(R) Centrino(R) Advanced-N 6250 AGN won't use n band
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
So few details.
by R. Proffitt Forum moderator / October 27, 2010 10:22 AM PDT

I'm left to guess this is a Dell. See if Dell has driver updates. Remember that many had those PRE-N devices and routers. What a mess.

Collapse -
not a dell
by rookie580 / October 28, 2010 12:32 AM PDT
In reply to: So few details.

Nope, not a dell. It's a Toshiba Satellite M645-S4050. I DL'd the most recent version of the driver from the Toshiba site(although the windows check for updated drivers and said it was good). So I went from 13.1 to 13.3....without effect. I'm still connecting on g.

Is there a way to tell it to connect on n?

Collapse -
Unknown at this time.
by R. Proffitt Forum moderator / October 28, 2010 1:13 AM PDT
In reply to: not a dell

I read you revealed the make and model and updated a driver on the laptop.

But what Dlink? Was it a PRE-N? Is it's firmware current? Did you try to set it to 802.11n only? Is it setup like the Cnet Networking Forum suggests?

Save the forum members from asking all these questions. Tell all the specifics related to the problem.

It's not a sure thing this can be fixed but it's a start.

Collapse -
dlink info
by rookie580 / October 28, 2010 5:32 AM PDT
In reply to: Unknown at this time.

D-link: DIR-628
most updated firmware from the dlink site 1.24NA
I tried setting the router to 802.11n only but while my computer could see the available connection, it couldn't connect.

This is what I copied from the status page from the router:

Wireless Radio :Enabled
802.11 Mode : Mixed 802.11n, 802.11g and 802.11b
Channel Width :40MHz
Channel :6
Secondary Channel :2
Wi-Fi Protected Setup :Enabled/Configured
Security Mode: WPA Only - Personal

I don't know what other information you need. Other computers can connect to this router as n. just not mine for some reason. I can't find a place to set my adapter to use n only

Collapse -
Not much left to try.
by R. Proffitt Forum moderator / October 28, 2010 5:46 AM PDT
In reply to: dlink info

I would have used AUTO (WPA/WPA2) as well as AUTO on AES and TKIP.

If that doesn't work then it's up to Dlink to add support for your Wifi N card.

Collapse -
It's a driver issue.
by DanielNTX / October 29, 2010 12:47 AM PDT

The OEM Intel drivers by default install the "Intel(R) Centrino(R) Advanced-N 6250 ABG" adapter instead of the "Intel(R) Centrino(R) Advanced-N 6250 AGN" adapter. You can verify this by going to Device Manager. To resolve this issue, download the latest Intel drivers in zip format and then do an update drivers and manually select the AGN version.

Collapse -
is there a solution to this problem
by mrbrightside12 / December 17, 2010 4:09 AM PST

I have an Asus G73jh-BST7 with Intel(R) Centrino(R) Advanced-N 6250 AGN and a DLink DIR-655 Xtreme N but it wont connect to using n i tried every thing from setting it to n only auto aes tkip reinstalling all the drives is it... is there a solution to this problem or is the DLink not compatible with Intel(R) Centrino(R) Advanced-N 6250 AGN

Collapse -
by R. Proffitt Forum moderator / December 17, 2010 4:16 AM PST

Your router setup is not compatible. I find it disturbing that no maker is offering online courses in networking. Even when it comes to how to select the router wifi settings they fail.

Here I have spent too many posts asking for the router settings and it's becoming clear that folk DO NOT WANT to become IT GURUs. They want it to work, right out of the box.

Collapse -
I tried all the drivers I could find
by rookie580 / December 17, 2010 10:08 AM PST

Honestly, I tried drivers from the wireless adapter manufacturer and the laptop manufacturer and the router. All the settings say that it is set up as N (AGN), yet...not connecting as N. So...I've not found a solution. Eventually I had to give up. Maybe I'll fight with it another day. If I get it to work, I'll post here.

Bob I appreciate your information and expertise. I'm sorry that those of us who are not experts irritate you with our questions. My understanding is that this forum is for people who need help to get it. We wouldn't be asking the questions if we already knew what we were doing. Also, since we aren't "guru's" most of us just don't know the right question or search to do so, yes, you end up answering similar questions. If it's that irritating, please let someone else do the answering for a little while and save yourself the headache.

Collapse -
Not so.
by R. Proffitt Forum moderator / December 17, 2010 10:19 AM PST

Over in the Cnet Networking forum we tackle this a lot. But it does require folk to reveal the settings, make, model, version, firmware versions and by now you get it that folk do not want to work that hard.

But do try it the Cnet Networking Forum way (see the stickies.)

We have the answers but we need the details.

Collapse -
why is it
by mrbrightside12 / December 17, 2010 4:16 PM PST
In reply to: Not so.

there's gateway laptop here and it uses the n network just fine. but the laptop with Intel(R) Centrino(R) Advanced-N 6250 AGN just connects with g... and not all ppl are network savvy that why we ask so we can learn and understand the problem... dob

Collapse -
It only slows folk down.
by R. Proffitt Forum moderator / December 18, 2010 12:57 AM PST
In reply to: why is it

When they can't try the methods that our techs use. We send them out with setup notes and space PC-Cards and usb wifi sticks to sniff out if some card has gone south.

There are those that try far too hard to fix an onboard wifi card. Since we charge by the hour we could try to save some cranky card but I'm sure the customers would start talking bad about us if we racked hundreds in service fees like that.

Collapse -
Identical issue w/ New Toshiba Laptop
by csoaz / December 26, 2010 12:37 PM PST

I have the identical issue with a new Toshiba laptop (Intel(R) Centrino(R) Advanced-N 6250 AGN). Linksys says its not the router. Toshiba says its the limitation of the built in driver. WHAT? It's supposed to be a/g/n/so why won't it connect to N?

Collapse -
Intel(R) Centrino(R) Advanced-N 6250 AGN won't use N band
by curtisimoe / April 10, 2011 12:00 PM PDT

I realize this thread is several months old, but apparently his problem is still evident. My machine is an Asus G73JH-BST7 running Windows 7 Home Premium and sports an Intel(R) Centrino(R) Advanced-N 6250 AGN built-in wireless adapter w/WiMAX. My router is a DLINK DIR-855 which is capable of generating wireless g/b/n at 2.4GHz and 5GHz simultaneously. For quite some time I battled with the same issued mentioned by several in this thread. All other machines connected without issue to wireless n (including my Mac Book at 5GHz respectively). The Asus would "see" the SSIDs (wireless signals) at both signal ranges and even prompt for the security key when attempting to connect. However, the connection would fail with an error message generated by Windows that the SSID could not be found and prompt the user to use the builtin network troubleshooter which also did not provide any viable solutions. I wanted to exhaust all possibilities before upgrading the firmware on my router. I tried removing the security protocol from the wireless; changing the g-signal to n-only; resetting the router to manufacturer defaults; running Windows updates; checking Intel updates for the wireless adapter; uninstalling/reinstalling wireless drivers; reinstalling the OS using the Asus restore media; disabling all other wireless devices accessing/not accessing the network...and a host of other troubleshooting approaches that are too detailed to name. The solution, in my case, was a firmware upgrade on the router. It was sold to me brand-new using revision 1.02 (This revision supported using the shareport for a 3G wireless adapter. All subsequent firmware upgrades removed this capability which is why I was hesitant to upgrade the firmware.)I upgraded my router to the latest firmware revision 1.23NA as of April 1/2011. I reapplied my original router settings manually. The Asus connected to wireless-n without a hitch. Perhaps someone can offer an explaination regarding what changed and why this worked and hopefully my scenario will help others.

Collapse -
Sorry but I can't find the one detail I want to read.
by R. Proffitt Forum moderator / April 10, 2011 12:14 PM PDT

"THE SOLUTION: I logged back into D-Link Setup interface, and re-enabled wireless security. This time I set the WPA mode setting back to "Auto (WPA or WPA2)" setting the DIR-655 Cipher Type back to "Tkip" where it was before. I was still only able to manage a G connection, not NG. I decided to experiment a little, changing the Cipher Type to "AES" and BAM!!! It connected in NG mode!!! This is the only security mode that I can get the 2 to connect with each other in NG mode."

Now I can say if this will help but after too many trips to the field and setting it up this forum's top post how we suggest many times I wonder if it's that old thing.

Collapse -
My solution as well!!
by mgraziano1975 / May 18, 2011 12:59 PM PDT

I applied this exact fix on my machine. Switched from TKIP to AES in the router setup, and my Dell E6410 connected via N instead of G.

Same Intel wireless card, but the router is a Netgear RangeMax NEXT WRN834B v2 with firmware version V2.1.13_2.1.13NA.


Collapse -
not for me :(
by rookie580 / May 18, 2011 10:10 PM PDT

I checked my settings and I was already using AES. Great idea tho! (changing from WEP to WPA fixed a previous intermittent internet connection issue --different computer/router setup...amazing how the type of security can mess up so much.)

Collapse -
Nod nod.
by R. Proffitt Forum moderator / May 19, 2011 4:36 AM PDT
In reply to: not for me :(

Moved to a wnr3500 (hope that's the model) and all good.

Yes, I'm using the suggested settings from the CNET Networking Forum sticky.

Collapse -
This should fix it.
by acarzt / August 3, 2011 7:04 AM PDT

Go to device manager. Open the properties to the wireless card. On the advanced tab or "change settings" button there will be an option along the lines of preferred band or frequency. Select 5ghz. Also set channel width to auto.

Collapse -
Please help
by skilowyo / February 5, 2013 6:02 PM PST
In reply to: This should fix it.

I know this thread has been dead fo quote some time, but I have the same issue with my dell precision that has this wireless card in it. I have went to advanced settings on the device and enabled 802.11n mode, changed the width and prefered band, but when i go to "wireless mode" at the bottom of the list, it lists everything up to 6.802.11a/b/g, but there is nothing in that list that has "n" in it. When I go to connect to my network it shows that the routers radio type is 802.11n. Any ideas? It is a rosewill rnx-n4ps router. The device in device manager is listed as Intel(R) Centrino(R) Advanced-N 6250 AGN and I just installed the latest drivers from intels site. Thanks!

Collapse -
If this is true
by R. Proffitt Forum moderator / February 6, 2013 12:13 AM PST
In reply to: Please help

And changing routers does not help you'll want to try other WiFi cards and USB dongles.

Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


Samsung Galaxy S8's major makeover

This year's flagship phone gets a sexy new design and Bixby, a house-made digital assistant.