Yes, it's possible. So long as the MacBook is supported by 10.5 anyway, and otherwise meets the minimum requirements for Mac OS X Server. If it's a newer model MacBook, there may not be any kernel modules to support the hardware on the MacBook in 10.5, which would lead to problems.