Linux forum

General discussion

Installing

by OmegaTomato / March 5, 2007 2:07 AM PST

Athlon 64 3500
1 GB PC3200 DDR
MSI RS480M2-IL motherboard
Alcohol 120% on XP Media Center being used to burn the ISO

I'm getting the following message when installing:

Decompressing Linux... Done

[ 40.058602] PCI: Cannot allocate resources region 3 of device 0000:00:00.0

User not known to the underlying authentication module.

------

That last line is repeated seven or eight times, and after that the system is unresponsive. I read that USB devices can cause driver conflicts when doing this install so I unhooked all of my USB devices. Unfortunately, I got the same result.

I tried checking the CD that I made with the built in testing function that's also on the iso. It found 4 errors. When I made another CD on my friend's computer using Nero instead of Alcohol 120% I got the same error and also found 4 errors on the CD (specifically it said "Check Finished: 4 checksums failed", I don't know what that means).

I tried making another CD with Alcohol but I made it at the slowest speed (I read that for some reason the AMD 64 specific iso that Kubuntu distributes has a higher probability of having problems than the other isos). It came up with the same errors.


Someone on another forum suggested that I try another CD rom drive as mine might be having issues. That ended up working (I suspect because my first drive is also a lightscribe drive which I bet Kubuntu doesn't like for some reason but my second drive isn't).

So, I made it past the installion screen (using the CD I made on a slower speed) but I got a new error. It comes up with a command line just saying ubuntu@ubuntu$~ (I think those last two characters are right, I'm doing this post from memory). If you got to this website: http://www.debianadmin.com/kubuntu-610-edgy-eft-step-by-step-installation-with-screenshots.html
I can make it past the second screen but not to the third screen.


Any ideas on how to remedy this? Of course, if you need more information I would be happy to give it.


Oh, one other thing. I'm going to try and install Kubuntu on my 2 GB USB drive. Will that be enough space? And if it's not, can I just use PartionMagic (v. Cool to partion my hard drive before I do the install that I won't have to have Kubuntu do it for me? My reasoning is I think using Kubuntu to create the necessary partitions necessitates it [Kubuntu] reformatting whatever particular partition it's going to install on, thus if I partition before it installs I wouldn't lose anything because that partition will be blank. Correct?


I know this is complicated (or I at least made it complicated) so thank you very much for your help.


More information:

I downloaded the 6.10 version (Edgy Eft) (to be specific I downloaded the AMD64 alternative install iso) from the website (not the torrent). Now, I thought that this one was stable. But perhaps I'm wrong.
Should I try to be installing the 6.06 version (Dapper Drake I believe it's called)? I wouldn't think that's the problem as this seems more hardware related but I'm obviously much newer at this.
I'm 99% sure that I need the AMD64 alternative install as I've got an AMD 64 bit processor. But, again, I'm still learning.
Thanks for the help.

When I put the CD I burned in either drive when Windows is running, it autoplays and allows me to install some stuff (I'm not exactly sure what's going on, is that the Live CD option?).

Discussion is locked
You are posting a reply to: Installing
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Installing
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
"the built in testing function that's also on the iso.
by R. Proffitt Forum moderator / March 5, 2007 2:15 AM PST
In reply to: Installing

"the built in testing function that's also on the iso. It found 4 errors"

All bets are off until you get zero errors. The error message is to be ignored, forgotten until there are no test errors.

Bob

Collapse -
What's wrong then?
by OmegaTomato / March 5, 2007 2:20 AM PST

I'm not sure why I got 4 errors on every disk I made. Should I redownload the iso and try burning with that?

What's really odd is that I made a CD on a friend's comptuer and that also had 4 errors? I did use my iso file though so maybe that's the problem.

I'll try making another CD with a new iso file and get back to ya'all.

Thanks.

Collapse -
When I see that I...
by R. Proffitt Forum moderator / March 5, 2007 2:23 AM PST
In reply to: What's wrong then?

Use another brand media, maybe pull out my CD Lens Cleaner disk, reduce speed and lastly swap in another drive.

You'll see similar wild goose chases on bum Windows CDs. An owner will supply what appears to be an endless number of errors and ask what they mean. Then we test the CD and it has errors. The poor owner sometimes gets miffed we toss out the errors and head back to the source of the problem.

Bob

Collapse -
Part 1 solved
by OmegaTomato / March 5, 2007 5:37 AM PST
In reply to: When I see that I...

I used Infra Recorder (a program recommended for burning isos by a website I found detailing how to install Linux). It got 0 errors on the test but I still get to the part with ubuntu@ubuntu~$: command line and I'm unsure what to do.

So, now that I've cleared up one problem I'm unsure what to do now.

I noticed that I only get to this point if I use my second CD-ROM drive. The first one gives me the first error described. I think it might be because the first drive is lightscribe capable whilst the second one isn't.

Oh, by the way, I tried installing without any USB cables plugged in as I read that sometimes Kubuntu has issues with them while installing.

So, I'll take any advice ya'all are willing to give.

Thanks.

Collapse -
That first PCI error was spotted on some Dell.
by R. Proffitt Forum moderator / March 5, 2007 5:41 AM PST
In reply to: Part 1 solved

It was sometimes resolved with a BIOS update. On a few machines there was no update and fixed by removing 'extra' PCI cards to free up IRQ and other resources. Not a true bug but limitations being hit in the architecture.

I'd not restrain myself to just one distro. Something new like PCLinuxOS 2007 RC2 may prove interesting.

Bob

Collapse -
What do you mean?
by OmegaTomato / March 5, 2007 6:36 AM PST

What do you mean by "removing" extra PCI cards? The only "extra" slot being used is for my graphics card and the others are empty. Do you mean remove the card or go into the BIOS and change something?

And I really like what I see with Kubuntu so I'm only going to try another distro if this one ends up being completely impossible to install.

Thanks.

Collapse -
Other items that can be disabled then.
by R. Proffitt Forum moderator / March 5, 2007 6:38 AM PST
In reply to: What do you mean?

Serial ports? Parallel Ports? What can be done without?

Sorry to see you get fixated on one distro. If there was any lesson we see in Linux Land is that carrying a torch for any distro only gets you burn marks.

Bob

Collapse -
Checked MSI website
by OmegaTomato / March 5, 2007 6:46 AM PST
In reply to: What do you mean?

I used the Live Update service available from MSI and there aren't any BIOS for my motherboard to be flashed with. There are some drivers but I'm hesitant (for obvious reasons) about just wantonly installing some of these things that operate at such a basic level when I don't know what they do and what they'll "fix."

Any thoughts would, of course, be appreciated.

Collapse -
Different Distro
by OmegaTomato / March 5, 2007 7:22 AM PST
In reply to: Checked MSI website

I've decided to try Ubuntu. I know they're extremely similar but I want to see what happens. As for my ports, I unplugged everything except for my monitor, power cord, and (PS2) keyboard and still had the same problem.

The thing that baffles me the most is that the screen I get to is set up nicely. It tells me that there's no warranty and tells me what to type to learn about the root user. I just can't find any installation guide that mentions this happening at all. It seems like a very nicely set up error for it is in fact an error.

Collapse -
When I noted serial and parallel, these items are...
by R. Proffitt Forum moderator / March 5, 2007 7:24 AM PST
In reply to: Different Distro

Disabled in the BIOS settings. Disabling a parallel port in the BIOS could free up an IRQ or other resource and cure the issue.

Bob

Collapse -
I don't like to say one distro is better than another, but..
by ahtoi / March 5, 2007 4:19 PM PST
In reply to: Different Distro

You seem to have lots of problem with this one. How about give either Mandriva2007 or Suse10.2 a try. I personally don't think Ubuntu is a newbie distro.

Collapse -
Video card
by OmegaTomato / March 5, 2007 10:11 PM PST

I figured out what was wrong.

I tried to boot Ubuntu instead of Kubuntu just to see what would happen. I got a very messed up (graphically speaking) screen that said it couldn't load the X system and that it had an error.

That prompted me to go into the BIOS (per Bob's suggestion) and disable everything I didn't need. When I switched my video card from PCI-Express installed one to the onboard one, I was able to boot Kubuntu.

Now I just have one much simpler problem. I'm trying to install it onto my 2 GB flash drive but it's not working too well. The installer get's to 99% and then crashes. The error basically says that the hard drive device ran out of room. Since what I've read indicates that the install is just over 2 GB I think that if I just got rid of a few of the extraneous programs that comes packaged with Kubuntu, then I could get it all on there. Oddly enough, the installer did not give me the option on what to install.

Thus, I was wondering if there is a way to go into the iso file I downloaded and delete some of the extra programs. Some things on there I just don't need or want (such as the 3D editing program). Thus, I was wondering if there is a way to access the iso and delete programs such as those and then burn a new CD? Even better would be an installer that let's me pick and choose which non-essential programs I want.

Thanks.

Collapse -
The usual liveCD fits on 1GB sticks.
by R. Proffitt Forum moderator / March 5, 2007 10:17 PM PST
In reply to: Video card

But I will not duplicate web pages about how to put such onto USB memory sticks. Instead I want to note a few things that may answer your question about customizing.

1. MySlax. Look that up and it's a build your own distro solution.

2. PCLinuxOS. Look at it's synaptic tool and I can uninstall what I don't use.

Cheers,

Bob

Collapse -
Remastering
by 3rdalbum / March 10, 2007 3:45 PM PST
In reply to: Video card

Remastering the CD is a non-trivial task. If you really want to try it, you could make some space available on a Fat32-formatted partition (four or five gigs should do it), download the Reconstructor program for Ubuntu, and run that to remaster the CD and choose what you want to get rid of from it.

Why not just install Ubuntu onto a hard drive, or into a virtualisation environment? Both those methods will probably be faster and less problematic than running from a USB device. With the latter, you could even put the virtual hard disk image onto the flash drive.

Collapse -
A different way...
by OmegaTomato / March 11, 2007 5:24 AM PDT
In reply to: Remastering

At another forum I was given a link to this: https://wiki.ubuntu.com/LiveUsbPendrivePersistent

Unfortunately, I'm having problems. I can't make partitions with either PartitionMagic (v. Cool or the Computer Manager (under Admin Tools). So, I follow the directions for making the partitions in Linux and that seems to work fine.

But then I run into another problem. I can't mount both partitions at once in either windows or Linux. I don't know why that is. They're both primary and the computer can tell that both are there, it just can't mount the second one. I've tried in Windows and Kubuntu (off the LiveCD) and I can't get it to work in either. I tried making both active but that didn't work.

So, if someone has an idea of how to solve this I would be appreciate.

So you know where it is that I'm having problem it's the "Formatting the Partitions" subsection. I can mount the first partition but not the second.

-Dave

Collapse -
Install on a USB drive
by clsgis / March 11, 2007 3:48 PM PDT
In reply to: Video card

Use a distribution that was designed to run off a USB drive. Slax or Damnsmalllinux or something.

When they tell you "you need at least 2.5 GB for a workstation type installation" they mean you'd better have a 6 GB drive. You need a swap partition. You could put all files on one partition, but it's nicer to have /home on its own so you can practice installing until you know what you're doing, without blowing away your user account each time. An EXT3 file system has 10-15% overhead for the journal and inodes. And EXT2 or 3 runs best when it is less than two thirds full.

If you absolutely must try to cram a full function system onto a USB stick, I recommend the so-called "poor man's install" described at Knoppix.net. You have room on a 1 GB stick for the 700 MB image, 100 MB swap, and a 200 MB "persistent home directory." The "poor man's" Knoppix runs just like the live CD, decompressing what it needs when it needs it, except the compressed file system image is on the USB stick. Downside is no upgrades. You're pretty much stuck with the software on that image until the next one comes out. Which is one reason to use a distro designed for thumb drives.

Maybe Kbuntu has a "poor man's" install option. (It should, since it runs the same way Knoppix does.) Did you look for it?

Collapse -
bad download
by clsgis / March 11, 2007 3:25 PM PDT
In reply to: Installing

If you burned several disks and they all have the same errors, that's a bad download. ISO files always come with an MD5 checksum. If it doesn't match exactly, don't waste a CD on it.

Collapse -
partitioning and making file systems
by clsgis / March 12, 2007 3:34 AM PDT
In reply to: Installing

In "A different way..." OmegaTomato couldn't mount the second file system on the USB drive, but he didn't say what the error message was. The following is not a criticism or a put down, it's friendly advice: Please google "Smart Questions" and read Eric Raymond's wonderful essay "How to ask questions the smart way." This is THE KEY to succeeding with Free software. If you don't give us the details we can't help you solve the problem, and we (volunteers) don't have time to coax them out of you.

The Ubuntu Wiki article recommends the partitioning programs fdisk and qtparted. I prefer cfdisk. But they should all work.

The Wiki article mentions the stale table warning from fdisk. Then it talks about booting DOS to "fix" it. That's silly. The "warning" is a reminder that the kernel does not know you put a new partition table on the drive. It's a "hot pluggable" device. All you have to do is remove it and plug it back in.

If fdisk/cfdisk/qtparted/gparted can see the partition table, but you can't mount the partition, check the file system. In fact, you should check the file system anyway. Let's say you have a SATA internal drive and you're not using SCSI emulation to talk to a CD burner. Then your hotplug USB thumb drive is (probably) /dev/sdb. Let's say you partitioned it with a small FAT32 for file transfer, a swap partition, and an EXT3 Linux partition for your persistent home directory. Then the command

dosfsck -n /dev/sda1

will tell you if the FAT32 file system is good. The -n option says don't fix it, just check. It will fail if you forgot to build a FAT32 file system after partitioning. (MS-Windows users say "high level format." Unix users say "build a file system." Same thing.) There's nothing to check on the swap, but you can reinitialize it. Don't do this to a swap partition you're using.

mkswap /dev/sda2

And finally you can check the EXT3 file system

e2fsck -fn /dev/sda3

The -f option says force a check even if it's marked clean. You'll have to run these as root, because regular users aren't allowed to mess with partition tables and file system checkers. Now that you know the file systems are good, we can go back to puzzling about the mysterious "can't mount" problem. We don't know what you tried to do, nor what happened, but here are some guesses. Did you try to mount a device that's not mentioned in /etc/fstab without spelling out the file system type and mount point? Did you try to mount it as an unprivileged user when that partition's entry in /etc/fstab doesn't have a "user" option? Did you misspell the device name? Did you try to mount it on a directory (or "mount point" that doesn't exist? Is your kernel missing the driver module for FAT32 file systems?

Popular Forums
icon
Computer Help 51,912 discussions
icon
Computer Newbies 10,498 discussions
icon
Laptops 20,411 discussions
icon
Security 30,882 discussions
icon
TVs & Home Theaters 21,253 discussions
icon
Windows 10 1,672 discussions
icon
Phones 16,494 discussions
icon
Windows 7 7,855 discussions
icon
Networking & Wireless 15,504 discussions

REVIEW

Meet the drop-resistant Moto Z2 Force

The Moto Z2 Force is really thin, with a fast processor and great battery life. It can survive drops without shattering.