HolidayBuyer's Guide

Computer Help forum

General discussion

Installation problems with various software (Windows Vista)

by APGamerZ / May 12, 2009 9:21 AM PDT

When trying to install a program I am greeted with a message: "Internal Error: failed to expand shell folder constant userappdata".

I am not on an admin account but since it requires to be run as administrator, this is not an issue. A similar error occurs when I try to install another application "Error 1606: Could not access network location %APP DATA%".

It's apparent that both problems have to do with my AppData folder. However, all permissions are set properly. The folder is in its proper place and everything appears fine. I have cleared temporary files from IE, but the problem still persists. I have deleted the User Shell key in the registry and restarted, but still the problem persists.

I am frustrated and just want to find a way to fix this problem. Oddly when I searched the internet for a solution many people have been having the same exact problem. The even stranger part is that I have only found entries of this problem within the last two weeks. I don't know if this is a virus pandemic or something less sinister. All I want is a definitive answer on how to fix this issue. Every response I have seen thus far has done nothing to alleviate the problem. Read this entire message carefully and then come up with a response.

Thank you.

Discussion is locked
You are posting a reply to: Installation problems with various software (Windows Vista)
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Installation problems with various software (Windows Vista)
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Suggest Running As An Admin Account
by Grif Thomas Forum moderator / May 12, 2009 10:15 AM PDT
Collapse -
Thank You.
by APGamerZ / May 13, 2009 6:59 AM PDT

I just realized my error was deleting the Key on my User account rather than the Admin account's key. Thanks for the help because I would never have fixed the problem without it. By simply revisiting the solution I thought I had already tried I was able to fix it.

Deleting the key in the admin account worked perfectly. Thanks a million.

Collapse -
What is "deleting the key"?
by gmoney34 / December 13, 2009 3:32 AM PST
In reply to: Thank You.

I have this same problem and would like to fix it as well but I don't understand what you mean by saying you "deleted the key."

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

HOLIDAY GIFT GUIDE 2017

Cameras that make great holiday gifts

Let them start the new year with a step up in photo and video quality from a phone.