Windows Legacy OS forum

General discussion

Install PNY flash driver problem.

by fredharr48 / July 24, 2005 2:41 AM PDT

Downloaded from PNY driver for W98SE.

Attempted to run setup.exe after unziping.

Got error message, "Class not registered".

Assume it is looking for file extension class such as
.sys, etc.

Does anyone know what class is needed so I can add
it to the registry?

Discussion is locked
You are posting a reply to: Install PNY flash driver problem.
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Install PNY flash driver problem.
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Any more words in that error message?
by R. Proffitt Forum moderator / July 24, 2005 3:14 AM PDT
Collapse -
No additional words, only "Class not registered".
by fredharr48 / July 25, 2005 3:21 AM PDT

No additional words, only "Class not registered".

Collapse -
Can't install PNY Attache driver
by Sunrise_22 / July 24, 2005 10:16 PM PDT

My system: PIII,8GB HDD,256MB RAM, Win98SE,BIOS enabled.
I have a PNY Attache 128MB USB 2.0 flash drive. I am unable to install the driver called downloaded from Mine is the first device in the first row displayed on this page)
I extracted,clicked on setup.exe. Got ''USB Flash Disk Driver Setup Utility'' box instead of the Welcome Screen & Installshield Wizard as described in the PNY installation guide on the site. Anyway I selected 'Install driver'/OK. In a couple of seconds got 'Installation Complete. Plug in device'. Plugged in the flash & nothing happened. Obviously the driver is not installed. It doesn't appear in Settings/ControlPanel/Add/Remove. Checked Run/msinfo32/Components/Problem Devices. It says ''This Device Has a Problem: Code=28 (0x1C)
The drivers for this device are not installed correctly. To install the driver
for this device, click the Driver tab, and then click Update Driver''. But I can't find any ''Update driver''.

I found out 3 things:
1) As a test I downloaded & installed the drivers ( & for the other 2 drivers displayed in the same row on the webpage.They installed smoothly & exactly as described in their installation guide. Also uninstalled easily.
2)It took less than 1 SECOND to download while it took about 3 minutes for the other two.
3)P20 & M20 appear in the Add/Remove box when installed.

Do these points convey anything? Could someone please try to download & install T20 & tell me? That would be a GREAT HELP. I have emailed them (at but they havn't been of much help. They want me to call but I cant do that because I live in India.Sorry,I've lost the ph no.

Thanks in advance.

Collapse -
After installing
by fredharr48 / July 25, 2005 3:38 AM PDT

PNY phone number for graphics is USA 1-888-316-1193.

I tried installing also after reading your post because I, too, have a PNY Attache 128MB 2.0 flash drive.
It seemed to install OK but when I atached the flash drive to the USB port nothing happened except the red light indicator on the flash drive came on as a steady light. Upon checking the control panel/systems the flash drive appears under Other Devices as 2.0 FD but with a yellow question mark. Properties showed error 28 so I tried to reinstalled the driver from the folder where I unzipped it. No driver was found there for the flash drive. Since the indicator was a steady red and a FAQ said don't remove it while the light was on, I shut down the computer and brought it back up.
Without the flash drive plugged in, the control panel showed nothing under Other devices, in fact, Other devices was not on the system at all.
Anyone -- Is the flash drive supposed to show on My Computer as a removeable device and do I have to assign a drive letter after (hopefully) a successful intall?

Collapse -
Why don't you call up technical help?
by Sunrise_22 / July 25, 2005 11:33 PM PDT

Yes, if the installation was OK it is supposed to show up as a Removable Disk in My Computer. Installation guide is silent on assigning a drive letter.

Did you get the Welcome screen & Installshield Wizard ?

I got the ph. no. for PNY technical help. It's 1-800-316-7079. Why dont you call them up & tell them there is something wrong with They are probably not aware of it.

Collapse -
Sucessful install of PNY USB 2.0 Flash Disk
by fredharr48 / July 27, 2005 1:56 AM PDT

I contacted PNY by email (

A technician (Rapael) replied with email with an attachment.

Followed instructions on email but the Flash Drive did not show up on My Computer or Windows Explorer.

Technician said I probably should reinstall W98SE but
knowing that was a lot of work he instructed me to assign the drive an unused drive letter (e.g. H) to upper and lower limit drive boxes of PNY USB 2.0 FD (under disk drives in My computer/control panel/system/device manager).

Then we created a desktop shortcut with only H: in the commmand line and accepted the name of the shortcut of
removeable disk H.

By clicking on the desktop shortcut we opened the flash disk and were able to copy data from Windows Explorer window and my floppy drive window to the Removeable Disk H window sucessfully.

Suggest you contact PNY at for a similar email and the CRITICAL attachment (which in my case was INF.zm9) You must have Winzip or unzipping capability to unzip and use it)

Collapse -
Also heard from PNY technical
by Sunrise_22 / July 29, 2005 4:03 AM PDT

I too had written to & received from Rafael a critical file with some instructions . But I have yet to try it out as I have lent my device to a friend! But I have an additional problem ------just discovered I have USB 1.1 in my computer bought in Nov 1999. (USB 2.0, came only in Apr 2000). Don't know if USB 2.0 devices are backward compatible. If it doesnt work I will have to get a USB 2.0 PCI card.

Collapse -
(NT) (NT) It should work, only slower.
by Kees Bakker / July 29, 2005 4:25 AM PDT
Collapse -
by Sunrise_22 / July 29, 2005 11:01 PM PDT

What is '(NT)' please?

Collapse -
by Sunrise_22 / July 29, 2005 11:07 PM PDT

What is (NT) please?

Collapse -
NT means 'No Text' in body, 'cause he said what he wanted...
by rdunn / October 18, 2009 2:25 PM PDT
In reply to: (NT)?

NT means 'No Text' in the body of the message post, 'cause he said what he wanted to, in the 'subject' of the message.

Most USB 2.0 devices are backward compatible... just works slower as a 1.1 device.

Collapse -
Advice for eveerybody above:
by Kees Bakker / July 25, 2005 5:23 AM PDT

Return the stick to the shop, ask your money back, and buy another make. If the shop can't supply a good installable Windows 98SE driver to supplement the hardware, you've got all the rights to a refund, in my opinion. They will easily be able to sell it to a Windows XP user, so they shouldn't mind at all to help you.


Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


Want to see the future of car technology?

Brian Cooley found it for you at CES 2017 in Las Vegas and the North American International Auto Show in Detroit.