Mac OS forum

Resolved Question

iMac won't connect to internet anymore using wireless

by Romands / August 13, 2012 6:58 PM PDT


Yesterday evenining I was suddenly unable to connect to the internet anymore using my wireless connection on my iMac. It says it's connected to the wireless network and it's sends through a correct IP-address but when I try to visit a webpage using Google Chrome or any other browser it says the DNS-lookup has failed, every other application that requires a working internet connection on my iMac also can't connect to the internet.

My iPod Touch can connect to the internet using my wireless connection just fine. I just hooked my iMac up to the network using an ethernet cable and now it seems I'm able to make a connection without a problem, however this is not a permanent solution. I'm using Mac OS X version 10.6.8 any ideas?

Thanks in advance.

Romands has chosen the best answer to their question. View answer
Discussion is locked
You are posting a reply to: iMac won't connect to internet anymore using wireless
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: iMac won't connect to internet anymore using wireless
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Best Answer chosen by Romands

Collapse -
iMac won't connect to internet anymore using wireless
by crew777dog / August 18, 2012 2:22 AM PDT

I had a very similar problem recently with my trusty Mac Powerbook G4. After trying many different methods to re-establish internet connection, I set it aside for several days. Unplugged, the (original) battery ran down to zero. I assume one could achieve the same result by removing the battery for a short period. Good news is, that when I plugged it in to recharge the battery, it began working normally.

I don't know if something like this will work with an iMac, but it's certainly worth a try...

Collapse -
No need
by Romands / August 18, 2012 4:48 PM PDT

No need it's already fixed but thanks for the suggestion.

Collapse -
Please share what exactly the problem was and
by mrmacfixit Forum moderator / August 18, 2012 11:39 PM PDT
In reply to: No need

how it was fixed.

I'm sure we would all like to know


Collapse -
by Romands / August 19, 2012 4:10 AM PDT

The problem was my iMac and my iMac alone was not able to make a connection to the internet using Wi-Fi. I had an ip address subnet mask, router address etc. Tried the usual, unplugging network devices, rebooting computer, renewing DHCP-lease and so on but nothing seemed to work.

It was like that for a couple of days then it just began working again with my current setup like it has been working these past couple years. No clue why. I've never had problems before with my Wi-Fi.

Collapse -
Have you tried
by Jimmy Greystone / August 14, 2012 12:19 AM PDT

Have you tried going into the network settings, then the settings for the specific connection, and renewing the DHCP lease?

Collapse -
by Romands / August 14, 2012 12:51 AM PDT
In reply to: Have you tried

Yep, it just renews it and ip address subnet mask and router numbers show up seemingly normal. I just don't understand why my internet connection seems fine one moment and is gone the next while every other device using the same wireless connection works fine...

Collapse -
Is it a secure WPA2 AES personal WiFi?
by R. Proffitt Forum moderator / August 14, 2012 12:57 AM PDT

I don't want to bore you with why just one system can get knocked down with those kid friendly hack tools. So try a secure WiFi and don't hide the SSID.

Collapse -
It's secure
by Romands / August 14, 2012 1:07 AM PDT

Yes, it's secured with WPA2 and the password itself is also very complex so I don't think it's very likely that my WiFI got hacked. The SSID is also not hidden so I don't think that's part of the problem either.

Collapse -
It was worth checking.
by R. Proffitt Forum moderator / August 14, 2012 1:45 AM PDT
In reply to: It's secure

The password complexity does not make it more secure. I'd rather not bore you why that is. But there can be issues with complex passwords that include non-alphanumerics.

In other words, stick to a-z, 0-9, A-Z for the passwords. Yes, that's a bug or limitation in some driver or such but rather than tilt at windmills you work with the system.

Collapse -
by Romands / August 14, 2012 1:59 AM PDT
In reply to: It was worth checking.

Ok, thanks for the tip but my password doesn't contain any non-alphanumerics anyway since I indeed had some problems connecting some devices to my WiFi using non-alphanumerics.

Does anyone else have a clue for what could be causing this problem?

Collapse -
Since the DNS failed.
by R. Proffitt Forum moderator / August 14, 2012 5:08 AM PDT
In reply to: Ok
Collapse -
Seems clean
by Romands / August 14, 2012 5:31 AM PDT
In reply to: Since the DNS failed.

I used this tool to check for Flashback and it came up clean then I used the terminal command in this article and it too came up clean. I also have Sophos Anti-Virus installed which I used to scan my computer, again nothing so I guess it's not a trojan or malware of some sort. Just doing some random Google searches now, lots of DNS problems but none specific to my situation so far.


Collapse -
Any possibility there is a router/WiFi information that can
by R. Proffitt Forum moderator / August 14, 2012 6:32 AM PDT

Any sharing about the router would be helpful. For example some routers have limits on how many machines can connect. As the router is not mentioned, I can't look to see if that is a factor here.

Collapse -
Here'a a test.
by R. Proffitt Forum moderator / August 14, 2012 11:10 AM PDT

Let's not use the DNS. should get you to If this is a DNS issue that may shed some light on this but as the details are so slim after all these posts I don't know what else to do but change hardware or reload the OS.

For example you could have shared the wifi connection details IP, netmask, default route, DNS entries. But some won't do that or can't. This means suggestion move to hardware or reloading the OS.

Collapse -
Connection details
by Romands / August 14, 2012 6:40 PM PDT
In reply to: Here'a a test.

Nope, it won't connect to using the link you gave me either. I'll give you a rundown of my network setup maybe that'll help. My modem is a Motorola SBV5121E which is connected to a D-Link DES-1005D which is in turn connected to a D-Link DWL-G700AP Wireless Access Point.

The IP I'm currently getting on my iMac from my wireless network is 78.21... and another three digits. (don't know how safe it is to post your entire ip address on the internet)
My subnet mask is
My router is

I've changed my DNS servers to those from Google, I've also tried the OpenDNS servers, still same result.

Collapse -
by Romands / August 14, 2012 6:43 PM PDT
In reply to: Connection details

Correction on the last post just to be clear the D-Link DES-1005D is an ethernet switch.

Collapse -
Excuse the butting in here,
by mrmacfixit Forum moderator / August 14, 2012 9:37 PM PDT
In reply to: Correction

but if you have a router in this network, then all your machines should be getting an IP address of 192.168.x.x
and not the 78.21.x.x

That number would indicate that only one computer at a time can use the internet as it is a derivative of the number that the modem has.

Even if the router were integrated with the modem, common in DSL connections, everything downstream of the modem would be getting their IP addresses from it which would result in a 192.168.x.x number.

Is this a Modem/Router combo or is there a standalone Router somewhere that was not mentioned?


Collapse -
Not that I know of
by Romands / August 14, 2012 10:17 PM PDT

There's another modem that I had not mentioned but I believe that one's used for my digital tv box since there seems to be no direct connection between that modem and the rest of my network, it just has one cable in it that goes straight up to the living room. So there doesn't seem to be a router of any sort in my network.

But then the question remains why did everything work simultaneously before and did my iMac and my iMac alone all of a sudden decide not to connect to the internet anymore?

Collapse -
by Romands / August 14, 2012 11:13 PM PDT
In reply to: Not that I know of

Update: apparently my internet provider itself works as a DHCP server, giving out IP adresses through my modem to my different devices, that would explain why I can connect various devices simultaneously without having a router. Still doesn't explain why I can't connect my iMac though. Maybe it's a hardware/software failure?

Collapse -
OK, but,
by mrmacfixit Forum moderator / August 15, 2012 12:09 AM PDT
In reply to: Update

unless you have a service other than the normal residential service, you would normally only have the one, prone to change, IP address going to the house.

78.21.x.x is an "outside" IP address which is given to you by your ISP. Your Router, which may be inside your Modem, supplies an "inside" IP address (192.168.x.x) to all the devices connected to your internal network and connects the two networks together. (inside to outside)

Some cable modems, notably Motorola, will act as a DHCP server when they are disconnected from the incoming cable and your devices are first connected and booted up. (it assigns 192.168.x.x addresses to those devices)
While this works quite well, it is no substitute for a dedicated Router.

Who is your provider?
Cable or DSL?
Normal Residential or Business?


Collapse -
My provider is
by Romands / August 15, 2012 12:27 AM PDT
In reply to: OK, but,

My provider is Telenet (I live in Belgium). Both my modems are cable and it's a normal residential connection. I do however know for a fact that my provider works as a DHCP server cause it's written in the manual and on their website. Like I said this has worked before with the same configuration for over 2 years so I don't see why these problems would suddenly come up now. Maybe they changed the maximum number of ip adresses assigned per user but I'd have to check with my provider for that.

Collapse -
Actually it does.
by R. Proffitt Forum moderator / August 15, 2012 12:22 AM PDT
In reply to: Update

Many ISP's lock IP''s to MAC (not to be confused with Mac) Addresses so all this discussion so far was a waste of time.

It's a shame I didn't get the network upfront.

It is not a hardware failure in my view. It's a network in need of setup.

Such as the usual.

ISP's Modem -> Router -> other things.

Anything else and you find you become a network Guru.

Collapse -
by Romands / August 15, 2012 12:52 AM PDT
In reply to: Actually it does.

Ok, since my network seems to be the problem, I'll just contact my provider to see if they can adjust/reconfigure my network. Thanks a lot for the amount of answers/help!

Collapse -
Wireless connection falls out
by jolysmoke / August 17, 2012 11:38 PM PDT
In reply to: OK

I don't know if there could be any connection,but for years now with T-Online router modems our Apple Machines have tended to lose the connection between Airport and the router modem. When it happens, it happens to all Mac computers with a wireless connection to that router.There is only one answer and that is simply to turn off the T-Online equipment and turn it back on again. The wireless connection re-establishes in about a minute. This happens about every other day.

Collapse -
Stop using the Airport as a Router
by mrmacfixit Forum moderator / August 18, 2012 12:02 AM PDT

and configure it to only pass traffic from the T-Online Modem/Router.

I suspect that you have two DHCP servers running on your home network. Devices connected wirelessly to the Airport probably have an IP address of 10.x.x.x while those connected directly to the Router/Modem have an IP address of 192.x.x.x


Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


Samsung Galaxy S8's major makeover

This year's flagship phone gets a sexy new design and Bixby, a house-made digital assistant.