Usually this happens during the setup of Internet Explorer 8, when that first IE8 welcome screen appears when you installed it. Choosing the "default" options during that setup isn't always the best option for many.

So....Open Internet Explorer, then click on Tools-Manage Add-Ons. Once there, click on the "Search Providers" listing on the left side, search through the listings then eliminate or disable all but the one of your choice. Now, click on the "Toolbars and Extensions" section and find any toolbars that you may not want, highlight each one and disable or uninstall it. (Some can be uninstalled from the Control Panel as well.) And since you mentioned the "Yahoo! Search" box, you may also have the Yahoo toolbar installed. It may be causing part of the problem.. Simply opening the Yahoo page and using their search function is different from having the entire toolbar installed. The toolbar throws extra stuff at you.. Uninstalling it and testing the waters may enlighten you.

It's your choice.

Hope this helps.

Grif