Networking & Wireless forum

General discussion

IBM T30 set up wireless network via Belkin F5D7010

by dipesh parmar / September 14, 2007 7:46 PM PDT

I had to reinstall XP Pro on my Pentium 4 IBM T30 model 2367 laptop recently, everything works fine including the internet network via my wired ethernet connection but not wireless. I've used and tried all 7 of the possible drivers for the Belkin wireless adapter, supposed to be version 7 in my case, plus reinstalled all possible drivers via the Lenovo/IBM website but the device manager still shows the network adapter as a network controller in yellow with an exclamation and question mark, i just cant figure out how to reconfigure this laptop to get wireless networking, which was working fine before the crash. I've done all the updates and installations for the drivers correctly, rebooting, etc. The Belkin network manager shows no network, and i cant add a network via this software so that it shows my Sitecom wireless router. Any ideas on what i'm doing wrong?

Discussion is locked
You are posting a reply to: IBM T30 set up wireless network via Belkin F5D7010
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: IBM T30 set up wireless network via Belkin F5D7010
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Usually drivers.
by R. Proffitt Forum moderator / September 14, 2007 10:06 PM PDT

But not just for the ethernet or wifi but the motherboard drivers are usually overlooked. Sorry, but the easy way out is to use the Restore CDs for the laptop then upgrade to XP Pro.


Collapse -
Ibm t30 wireless network problem
by dipesh parmar / September 15, 2007 1:25 AM PDT
In reply to: Usually drivers.

The worst bit is i didnt have any restore discs to begin with the laptop, but i will try as you suggest and download some motherboard drivers, thanks. I've spent a week messing about with it and its truly driving my potty !

Collapse -
IBM T30 wireless network error
by dipesh parmar / September 15, 2007 5:05 AM PDT

I'm still having the same problem, i've downloaded all the drivers i could see for the motherboard and anything else possible, still the same problem with the network controller on device manager showing up in yellow exclamation and question mark.

Collapse -
ibm t30 and belkin f5d7010 wireless problem
by dipesh parmar / September 15, 2007 8:47 PM PDT

Still no luck, exactly the same problem with the network controller error.I was thinking, when i take out the belkin network adapter that the netowork controller vanishes and every other bit of hardware is showing as being installed correctly, when i put the adapter back in the network controlled error returns. So surely this must have something to do with the belkin adapter? As i've said before, i've tried all the IBM and Belkin drivers, does anyone think trying a completely different network adapter pcmpcia card would be worth trying, or does anyone have any other suggestions ?

Collapse -
While you are not on Vista...
by R. Proffitt Forum moderator / September 16, 2007 12:31 AM PDT

You could check out how our members are finding ways (and drivers) via tools like EVEREST and more on our Vista Forum.

Sorry but I think a driver appears to be missing. You could have some other issue such as the cracked XP Pro I see floating into the service area from time to time. I've found no time to see what it has issues like this. Or your CD is not a XP SP2 CD. Again, that issue (SP2 CD) is one that rankles many since they feel the old XP (no SP) CD should be enough.


Collapse -
All I can say ...
by Kees Bakker / September 15, 2007 5:13 AM PDT

I got an T30 with a totally blank hard disk. I installed Windows XP, got all drivers from the lenovo-site, bought a wireless card (Belkin also), installed it, and it worked. I must have been lucky. But, alas, I can't tell you why it doesn't work with you.

A yellow exclamation mark in Device Manager is a clear sign of not having a working driver, I'm afraid.


Collapse -
And a useful program for future reinstalls.
by Kees Bakker / September 15, 2007 5:22 AM PDT
In reply to: All I can say ...
Collapse -
ibm t30 belkin wireless network controller error
by dipesh parmar / September 26, 2007 4:59 AM PDT

The laptop recognises the card when it is connected, but the lights on the card dont show anymore, they come on very dimly when the card is first connected but that is all. Do you think the card is damaged ? Under device manager, Under network adapters it just shows Intel(R) PRO/100 VE Network Connection. Underneath it has Other Devices in yellow, which has Network Controller in yellow in it. I downloaded everest home and under network i have windows network showing an intel(R) pro/100 VE network connection and then also a pci/pnp network it showed ibm pro/100 ve network connection and secondly a network controller(NoDB).
I dont have any cards used in this slot. Funnily enough, when my laptop crashed the only way i got it working was by trying out ubuntu, but i couldnt use it because i couldnt configure the wireless network on ubuntu, so i reverted back to windows xp pro.

Collapse -
It migjht be a good idea ...
by Kees Bakker / September 26, 2007 5:21 AM PDT

to try the card in another laptop and another card in this laptop.


Collapse -
belkin f5d7010 network controller error
by dipesh parmar / September 26, 2007 6:14 AM PDT

I've tried on another laptop and it shows on the device driver up as texas instruments pci-1410 cardbus controller, so i presume i need to find the driver for this and it should work?

Collapse -
belkin f5d7010
by dipesh parmar / September 26, 2007 6:23 AM PDT

Sorry, that was for the actual laptop ! It shows up on device driver as the belkin adapter, looking at the driver properties it seems the filename is netr61.sys, which i presume is what i now need to find?

Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?