Here I see four main possibilities:

1.) Right-click My Computer select Properties, select the Hardware tab, and click Device Manager. Once there, expand "universal serial bus controllers" and see what's listed. You should see a host controller for each port that exists, and there should be no caution flags. You may want to try reinstalling the drivers.

2.) Check your system BIOS and see if there is an option to disable USB ports. (Reboot your computer and press either F2 or F3, depending on model, to enter your BIOS.)

3.) The ports may have gone south...try inserting a USB PCI card and see if those ports work.

4.) At some point you or someone else disabled access to the ports. You may want to check permissions set on key files, such as USBSTOR.DLL and USBSTOR.SYS and make sure that general access is allowed.

John