Those drives appear to be SATA? If you've got two disc drives, try unplugging one and install the OS on the initial drive.. Make sure to install the SATA drivers at the appropriate time and after the first drive is formatted and installed, then plug in the second one and format it from Windows.

And in some cases, check the BIOS settings to disable "Native SATA Support" so XP can recognize the drives.

Hope this helps.

Grif