When you try to connect to a server, do you get a pop-up from zonealarm given you some options about allowing mIRC to connect to the internet? If so, make sure that you select the option that says to allow all connections on all ports, or the option that says to allow the program to connect to the internet. Also check de checkbox in de lowerleft corner which says to always use this option. Then click OK.

If you do not get such a pop-up, you must set your zonealarm configuration to allow mIRC to connect to the internet. If you don't know how that works just post and I'll tell you.

ZheepmeiZter