Android forum

General discussion

HTC MT3G Doesn't recognize USB connection after AC Charge

by ElCone79 / April 6, 2011 9:00 AM PDT

I have a HTC MyTouch3G (the one without the 3mm head phone jack) running Android 2.2.1 (the standard OEM updated version) and after I charge with an AC adapter when I try to connect it to my PC via a USB cable, the Phone won't recognize the USB connection and only charge the phone, the only way I know how to get the USB connection to work is to power-off the phone, remove the battery for a few seconds and power it up again. Anyone else is seeing this? Anyone know if this is normal or why this could be happening? or better yet, how to fix it?

Discussion is locked
You are posting a reply to: HTC MT3G Doesn't recognize USB connection after AC Charge
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: HTC MT3G Doesn't recognize USB connection after AC Charge
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
I've seen that.
by R. Proffitt Forum moderator / April 7, 2011 11:38 AM PDT

The owner had checked off that box "Don't ask me again." On the droids here you don't have to power cycle like that. You get to the home screen and slide your finger from the top of the screen to the bottom and tap "Select to change USB connection type."

Collapse -
Thank You but, it not that...
by ElCone79 / April 7, 2011 11:48 PM PDT
In reply to: I've seen that.

On the Alerts bar, the USB connection doesn't even appear after I use AC to charge my phone. It only indicates that it's charging (the colored battery indicator has a little lightning bolt on it) but the USB icon is not on the bar, so even if I pull down the bar there is no "USB connected" message so I could turn on the option to copy files over to my computer.

Thank you for your suggestion anyway.

Collapse -
Questions I'd have are
by Sovereign Forum moderator / April 8, 2011 1:02 AM PDT

1. Does this only happen on one particular PC or at least two different ones?

2. How much time passed between you charging with the AC and then plugging it in via USB to a PC?

3. Does the PC recognize that something was connected (I know you said the phone doesn't)?


Collapse -
Here are my Answers
by ElCone79 / April 8, 2011 2:17 AM PDT
In reply to: Questions I'd have are


1.- It happens on more than 1 computer
2.- It can be minutes or hours, the most I've waited is about 7 Hours
3.- No the PC doesn't recognize the Phone either.

Thank you for your follow-up.

Collapse -
So this tells us that
by Sovereign Forum moderator / April 8, 2011 5:15 AM PDT
In reply to: Here are my Answers

The problem is for sure on the phone side of things and that it's not because you are connecting from the AC to USB too quickly. From what it sounds like is that when the phone is charging via the AC and you plug it into the computer, the phone thinks it's plugged into the AC again (hence its charging again).


Has this been a problem since you updated the Android version?

Can you go to the SETTINGS > CONNECT TO A PC and change the default connect to DISK DRIVE and then maybe plug it into the PC after coming from the AC? I wonder if that would work.


Collapse -
More answers
by ElCone79 / April 8, 2011 8:25 AM PDT
In reply to: So this tells us that

I honestly can't remember if this started to happen after I updated to 2.2.1, but what I am sure is that there are no such seetings in Android for the USB connection, actually there are no settings for the USB connection.

Collapse -
Just wondering.
by R. Proffitt Forum moderator / April 8, 2011 8:29 AM PDT
In reply to: More answers

Is this an OS update from the carrier or "one of those others?"

Collapse -
Carrier Update
by ElCone79 / April 8, 2011 8:53 AM PDT
In reply to: Just wondering.
Collapse -
Last idea.
by R. Proffitt Forum moderator / April 8, 2011 9:55 AM PDT
In reply to: Carrier Update

While I can't know what apps are installed and all the settings, we can do one last thing.

Try another cable.

Collapse -
I already did...
by ElCone79 / April 10, 2011 11:52 PM PDT
In reply to: Last idea.

I have tried more than 1 cable and it's the same result... Maybe I will need to go through my apps and see if something might be causing this.

Collapse -
It's odd that you don't have that setting...
by Sovereign Forum moderator / April 11, 2011 4:21 AM PDT
In reply to: I already did...

You have two options left:

1) You take it to a store and have a tech look at it

2) You reset the phone to factory settings.

If you go with #2 and wonder about how to backup your data, let me know.


Collapse -
by toshiomm / April 19, 2011 10:34 AM PDT

it is true ,dude

Collapse -
I have the same problem .. did you ever get it figured out?

I have the same exact problem. I plugged my phone into a wall and now i can't get it to recognize the PC anymore. The phone thinks its plugged into the wall still. I'm not sure if that was what caused the problem or if it was something else, but its the same problem.

The options to enable USB Storage Device and USB Tethering and Internet Pass-Through mode are grayed out (disabled) and if you look in the battery status part of the settings it says "Charging (AC)" where it should normally say "Charging (PC)".

Normally when connected to a PC, you're unable to change the default USB connection type setting. But I can still change mine, because the phone doesn't realize that its connected to a PC.

Is it possible that the issue is a bad or limited USB cable?

I have been unable to get the USB cable to work again despite removing the battery and reinserting it.

The "Internet Pass-Through" settings sits there saying "Please plug in the PC cable" obstinately even though the cable is plugged in and the battery is charging.

Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?