Samsung forum

Question

HT-C5500 wont play newer disks

I am having problems playing newer disks on my HT-C5500... Titles include "Game of Thrones, District 9, and the Star Wars Complete Saga" disks. Is anyone having these issues/has anyone found a solution?

I have upgraded to the most recent firmware available (ver.1020.1) -- do I just need to wait and hope the next update fixes the issue?

Thank you!

Discussion is locked
You are posting a reply to: HT-C5500 wont play newer disks
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: HT-C5500 wont play newer disks
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Clarification Request
Problem solved?

In reply to: HT-C5500 wont play newer disks

I have the same problem when I try to play the blu-ray "Life of Pi". Can you advise how to solve the problem?

Same, I have the latest firmware available.

Thanks you!

All Answers

Collapse -
Answer
Don't wait. CALL.

In reply to: HT-C5500 wont play newer disks

Always call those in so they know what titles needs fixing first.

Collapse -
Good Idea

In reply to: Don't wait. CALL.

Will do when I have time... thanks!

Collapse -
Answer
Re: HT-C5500 wont play newer disks

In reply to: HT-C5500 wont play newer disks

Collapse -
Next?

In reply to: Re: HT-C5500 wont play newer disks

I turned off the BD-Live connection as suggested, and the disk will still not play. The disk will get to the menu screen of the title (without any background picture or sound however) and when I press play it gets stuck in a loop between playing and returning to the menu. The last time I tried it this morning I received a message on a red screen saying that my Blu-Ray player needs an update to play the disk, but as I mentioned I am running the most current version (ver.1020.1).

I spoke with a live-chat rep who suggested I restart my player using the stop button, but nothing has changed.

Any other thoughts?

Thanks for your time and help!

Collapse -
Answer
Update

In reply to: HT-C5500 wont play newer disks

I just got off the phone with a service rep. who took down the names of the titles and notified me that they are working on an update for these titles as well as Spiderman and The Avengers. They said that they should be releasing a response and update within the next few days.

Hopefully sooner rather than later!

Collapse -
Same issue.

In reply to: Update

I'm having the exact same issue with "Cowboys and Aliens" and "V for Vendetta." I don't know if these are already on the list of movies with playback trouble. Everything is up to date as fare as firmware is concerned. I have no trouble playing any other movies or DVDs for that matter.

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

SMART HOME

This one tip will help you sleep better tonight

A few seconds are all you need to get a better night's rest.