Spyware, Viruses, & Security forum

General discussion

hpHosts file too large for Spy Sweeper Hosts File Shield.

by Harv / May 30, 2005 8:23 AM PDT

After updating my hpguru HOSTS file, Spy Sweeper won't protect them with the Hosts File Shield, because the ''Hosts file is too large''. Anyone else having a similar problem with Spy Sweeper?

Discussion is locked
You are posting a reply to: hpHosts file too large for Spy Sweeper Hosts File Shield.
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: hpHosts file too large for Spy Sweeper Hosts File Shield.
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Yes ...
by Jake Barnes / May 30, 2005 9:09 AM PDT

When I activate SS ... it deleted my HOSTS file ... right now, I can't use it. I'm calling their tech support this week and returning the product. Why good is a security app that hoses your HOSTS file. Happenes every time I enable it ... just with the new v4.x builds.

Collapse -
I have Spy Sweeper 4.0.2 also.
by Harv / May 30, 2005 10:14 AM PDT
In reply to: Yes ...

But, my hpguru Hosts file is still intact. However, SS's Hosts File Shield won't protect them indicating ''Failure'' when I check the box.

Jake, I think you should still keep Spy Sweeper. Spybot S&D has a setting in Tools>IE Tweaks(I/E Symbol) where you can check ''Lock Hosts file read only as protection against hijackers''.

HTH Happy

Collapse -
Jake, you're right about the disappearing Hosts file
by Harv / May 31, 2005 6:55 AM PDT
In reply to: Yes ...

After updating to the latest version of Hoster 1.6 (hosts file editor), all my hosts files disappeared. As a temporary workaround, I put a check mark next to ''Lock Hosts file read-only as protection against hijackers'' in Spybot S&D, Tools>IE Tweaks>Miscellaneous Blocks. However, when you go into Hoster to edit the files by making the Hosts writable, the check mark disappears, which is a bit inconvenient, but a whole lot better than having to reintroduce your hosts files back each time you open Hoster. Wink In any case, let us know what Spy Sweeper support says about this bug.

Collapse -
Haven't talked to them yet ... I'm debating ...
by Jake Barnes / May 31, 2005 7:03 AM PDT

if it's worth my time or not ... but thanks for confirming that it's not just me ...

btw, it's not hoster that's doing it (that's just a good hosts file editor). When I updated to latest build of SS, that's when my HOSTS file just deletes ... I've had the ETC folder open and watched the ''details'' of HOSTS go from 293KB to 1 KB in 3 seconds ... as soon as I activated SS. Even when you shut it down, you have to take it out of start-up (msconfig) and reboot, or your freash new 293KB (or whatever) HOSTS file will instantly disappear. After reboot, if it's not a start-up item, the HOSTS file will hold ...

Collapse -
Collapse -
It could, of course, be something else...
by Jake Barnes / May 30, 2005 10:00 AM PDT
In reply to: weird

But everytime I try to enable SS ... I get this addition to my hosts file - www.popuptop.com #[IE-SpyAd] - always last entry ... and then the HOST file deletes ... but only when SS is enabled. Even when I delete the blank HOSTS file and rename a new/fresh HOSTS file - it holds for about 3 sec's - then deletes. I can't figure it out. Might be something in registry, but I can't find it or don't exactly what to look for ...

Collapse -
Jake, have you ever used a Hosts editor?
by Harv / May 30, 2005 10:42 AM PDT

You can delete or add entries and also do other kinds of editing on your Hosts file. The link for Hoster does not seem to work anymore. But, you can download HostsToggle here: http://reviews.cnet.com/5208-6132-0.html?forumID=32&threadID=65835&messageID=784180.

I'm using Hoster for my hosts editing. If you're interested, I can email the Hoster file to you, if you email me through my (CNET Virus) Profile by clicking on my name. HTH. Wink

Collapse -
Yea - I have it
by Jake Barnes / May 30, 2005 10:50 AM PDT

You can get the new hoster.exe at Donna's C of U site. I've used the program a lot. And that entry I posted earlier is included in MVPS HOST file ... but since I updated to the last build of SS, I get a MSAP pop-up saying:
"The user Jake, has decided to block the entry #www.popuptop.com pointing to IP address from being added to the Windows Hosts file." - but I still get deleted HOSTS file - until I disable SS, reboot then rebuild my HOST file from a back-up ... lol, I now have like 8-9 back-ups hidden away ... just untill I can figure this out. I might have to post a Hijack This log somewher, but I hate doing that. It's just easier not using SS untill I talk to them.

Collapse -
If you want Hoster.exe
by Jake Barnes / May 31, 2005 12:28 AM PDT
Collapse -
Thanks, Jake. Sorry I was not able to help you solve
by Harv / May 31, 2005 5:05 AM PDT
In reply to: If you want Hoster.exe

your problem. Sad

Collapse -
Link is Blocked
by BullyDude / March 13, 2013 9:13 PM PDT
In reply to: If you want Hoster.exe

When I click the link I get the following message:

<span id="INSERTION_MARKER">Forbidden

<span>You don't have permission to access hoster.htm on this server.Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle die request.

Collapse -
That's a message from the server.
by Kees_B Forum moderator / March 13, 2013 9:21 PM PDT
In reply to: Link is Blocked

Only their website manager can solve that for you. Maybe the site has a contact link somewhere?

Probably they changed something during the last 8 years (the link is from May 2005).


Collapse -
Have, I just thought ...
by Jake Barnes / May 31, 2005 7:32 AM PDT

Did the HOSTS file problem on your PC just happen when you:
1. Updated to SS latest build ...
2. Or when you downloaded the new Hoster.exe from the link I gave you?

Collapse -
(NT) (NT) *EDIT: lol ... I ment Harv ... not Have ... :(
by Jake Barnes / May 31, 2005 8:15 AM PDT
Collapse -
Webroot Spy Sweeper issue with Hosts Files
by greenice / May 31, 2005 12:52 PM PDT

Jake, Harv: There is definitely something wrong with the new Spy Sweeper version:

I recently upgraded Webroot Spy Sweeper to version 4.0.2 build 349; at the time, like yourselves, on finishing installation, I noticed a message warning me that my Host File was too large. I didn?t quite know what the software was on about, but checking and going through the summary of shields I saw that there was a new item added to this version that referred to ?Hosts File Shield? with an activate box. As I already had my Host File blocked through the options in WinPatrol I ignored the preference for this shield in Spy Sweeper and left it as it was, disabled. However, the original warning about the Hosts File being too large stuck in my mind, and after a few days I decided to visually check the Hosts File to see if it had been changed in any way. To my surprised it bloody well had!! The file showed 1kb down from 262kb, no entries, deleted!! By the way, I run the Hosts File from MVPS. Each time I re-installed the Hosts File it went right back from 262kb to 1kb, no entries!! I then closed down Spy Sweeper and again re-installed Hosts File but got the same dam issue. So, I then completely uninstalled Spy Sweeper and found I was able to finally re-install the Hosts File with no problems. I have informed Webroot tech support about this matter and I am waiting for their reply. In the meantime, I thought it best to post this in sympahthy with your issues. As soon as I receive reply from Webroot will post.

Cheers and keep safe.

Collapse -
Then you my friend have confirmed it ...
by Jake Barnes / May 31, 2005 1:29 PM PDT

That's exactly what happens to me ... and I use Spybot S&D entries + MVPS ... for me, it comes up to 293 KB. As soon as I enable the new SS (build), my 293 goes to 1 KB and if you look, it's completely blank!

Thanks for posting, I guess I'm not nuts ... again ...


Collapse -
Hosts file troubles started with the latest SS d/l.
by Harv / May 31, 2005 4:41 PM PDT

Jake, you can forget the advice I offered about protecting your hosts files through Spybot S&D, etc. The check mark in Miscellaneous Locks keep disappearing along with my hpguru Hosts file.

In regards to Spy Sweeper's Hosts File Shield, that option was included in the version before this troublesome one, but I did not have any problem with my hosts files disappearing.

Collapse -
Marianna just posted this at CC ...
by Jake Barnes / May 31, 2005 2:13 PM PDT
1. The LARGE HOSTS file problem is not resolved. And as MichaelJ said, this build completely clears out a HOSTS file that SS deems is too large...everything is cleared out...blank.
However, in this build the user can turn OFF all the Hosts Shield options and SS will ignore the HOSTS file. Thus you can turn over to HOSTS file protection to another program such as Giant AS and run large HOSTS files such as HPGURU's. Not a satisfactory FIX by SS, but it is a bit of an improvement IMHO..

I have the shield turned off ... and still get a wiped out hosts file ... so it's not an easy work-around.

Collapse -
Spy Sweeper issue with Hosts File
by greenice / May 31, 2005 2:51 PM PDT

I never did activate the Hosts Shield in Spy Sweeper and nevertheless get my Hosts File deleted of all content. I get a feeling that all Spy Sweeper versions from 4.0 upwards to and including the most recent (v4.0.2 buil 349) are unstable.
I will wait for Webroots reply and then decide whether to get rid of Spy Sweeper or not. It's a shame because I really like the app., it is also a resource hog, more so than previous versions.

Collapse -
I did a 30 day evaluation ...
by Jake Barnes / May 31, 2005 2:57 PM PDT

of SS v3.5X ... and it was good ... found nothing, but no issues. When I decided to purchase, I called Bolder/Webroot - and they gave me an early release of 4.X ... no problems until I was told to update the build ... that's when all hell broke lose ... 1st build found my printer, scanner, DI 7, IsoBuster, etc as stuff - and then just hung ... Webroot promised me a new build - that's what we have ... no hangs, but no HOSTS files either ... yea, I'm about ready to dump it.

Collapse -
Maybe a "good idea" .......
by Marianna Schmudlach / June 1, 2005 6:33 AM PDT
Collapse -
Marianna ... I called Webroot ...
by Jake Barnes / June 1, 2005 8:18 AM PDT

and submitted a support ticket (with url links to other forums). The tech I spoke with had ''no idea why that would happen'' ... just what I expected, they always assume it's the user. I told them that if they couldn't fix it - I would delete it, get a refund & post threads about it ...

They said they would ''escalate'' the issue ... we'll see.


Collapse -
Jake, keep us posted IF you hear anything :)
by Marianna Schmudlach / June 1, 2005 8:23 AM PDT

Fingers crossed !

Collapse -
Here's a link ...
by Jake Barnes / May 31, 2005 10:40 PM PDT
Collapse -
Also in...
by Donna Buenaventura / June 1, 2005 12:40 AM PDT
In reply to: Here's a link ...
Collapse -
That's what I was trying to say ...
by Jake Barnes / June 1, 2005 12:54 AM PDT
In reply to: Also in...

I tried every way I knew to lock that file down, properties/read only, winpatrol, spybot, etc - everytime I activated/enabled SS (last build), the HOSTS file would delete ... while I was watching ... kind of eerie to be honest ...

Collapse -
If many is seeing the issue..
by Donna Buenaventura / June 1, 2005 2:17 AM PDT

Webroot really need to fix it. Since they are already aware, let's wait and hope it'll fix in the next version for users who want to keep their SS Happy

So far, SS here is still working fine with or without 3rd party HOSTS file in place (keeping my fingers crossed that it will not delete anything without my consent). Wink

Collapse -
Donna, tell the rest of us why YOU'RE not affected
by Harv / June 1, 2005 5:56 AM PDT

by the latest SS update? Sounds like the rest of us had better attend church more. Wink

Collapse -
I have no idea really.
by Donna Buenaventura / June 1, 2005 6:54 AM PDT

I tried many times by enabling HOSTS file of Spybot S&D, MVPS, hpHOSTS and Mike Skallas HOSTS files. SS can read them all. No glitch, no hang, no deletion.

I tried too by using one 3rd party HOSTS file only and SS still dances with it Silly

I can't reproduce the issue that you and Jake got that's why I have no idea. Must be lucky with SS only.

Not lucky with other programs though that means I need to go to church too often! Grin

Collapse -
Webroot Spy Sweeper issues
by greenice / June 2, 2005 2:40 AM PDT
In reply to: Here's a link ...

I am still waiting for a reply from Webroot after submitting a support ticket about my Hosts Files issue; as yet nothing.
In addition to the Hosts Files problem I have also found what seems to be another issue; particularly after a scan, every program in memory multiplies in memory size, an increase to my mind far from normal, which scared the hell out of me. Even with 1GB of RAM I could see that my system resources were gearing up to go ballistic. I also found that this memory issue did not drop back until an actual reboot. So, I have completely uninstalled Spy Sweeper; my memory usage is now back to normal, in fact my PC is running fast and fine for the first time in weeks. You see, I was also having problems with my computer shut down; it was taking far too long to do so and sometimes during a shut down process a pop-up window warned me that Spy Sweeper needed to end or terminate. This slow shut-down problem with a glitch has now disappeared since uninstalling Spy Sweeper and everything is back to normal. I had not quite realized up to that moment that my OS in general had not been running as well as it should; I can now appreciate the difference.
As I mentioned, I submitted a support ticket 2 days ago and still have not received a reply; phoning is out of the question as I live on the other side of the Globe. I most likely will do away with Spy Sweeper anyway, as it is too much of a resource hog and seems to conflict with memory and at times with system processes. However, to be honest these issues seemed to have cropped up or got worse with Spy Sweeper versions 4.0 and up to and including the latest version 4.0.2 build 349.

Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?