General discussion

HP Scanner No Longer Works with Snow Leopard

Hi:

I just upgraded to Snow Leopard (OS 10.6.1). I have an HP DeskJet F4280 All-In-One. It used to work great under 10.5.x, but now it will print fine but not scan.

If I launch HP Device Manager, and double-click ?Scan Picture?, ?HP Scan Pro? window opens, but I get the following error: ?Sorry, scanner could not be initialized (Scanner not found.)?.

If I press the hardware ?Scan? button on the top of the unit itself, the power light blinks rapidly for about 10 seconds, then reverts to its normal state, and nothing else happens.

If I launch ?Image Capture? 6.0(424) I get this error: ?No camera or scanner connected?.

Under System Preferences>Print & Fax>Scan a window opens that reads ?HP Deskjet F4200 series? and I click on ?Scanner?, but it says ?No scanner selected?.

However, ?System Profiler? lists ?Deskjet F4200 series? under USB High-Speed Bus, and, as already mentioned, the printer works fine.

Any advice to get my scan function enabled again would be most gratefully appreciated. Thank you!

Discussion is locked
Follow
Reply to: HP Scanner No Longer Works with Snow Leopard
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: HP Scanner No Longer Works with Snow Leopard
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
The HP software does not work under 10.6

Check the HP website for further details of their work around

Check under Drivers and Downloads


P

- Collapse -
(NT) You can scan through Preview or Image Capture
- Collapse -
Solution
- Collapse -
thank you

Thank you very much for your help.

- Collapse -
HP PSC 1210 no longer works with Snow Leopard

This described problem is exactly the same as my all in one printer, HP PSC 1210. I will check out the Apple thread/link and report back if I can find a solution.

- Collapse -
Tried Apple thread/ link - still no good

I tried the steps in the Apple thread, doesn't work for my hp psc 1210 with my iMac 24 on snow lep. I unistalled all hp drivers, rebooted. I can't get the scanner to work with hp drivers, only printing.
Apple has another article stating to use the built in scanner app in snow lep. However I don't have any scanner tabs/buttons in system pref printers or image capture apps as it states I should.

I may try a clean install or consider a new scanner printer

- Collapse -
If all else fails,

take a look at a piece of software called VueScan.

There is a free trial period so if it does not work with your scanner, you are not out any money.

I use it on my Epson scanner but it supports hundreds of different brands and models

P

- Collapse -
To omerben

That site is for Windows computers.

This is a Mac forum

You post was deleted

P

- Collapse -
For help

I've got exactly the same problem!!

- Collapse -
Then check out the link

and read through the whole thread

P

- Collapse -
HP Scanners and Snow Leopard - Solution

Hi, CharPatton1

I had exactly the same problem so emailed HP. They replied with instructions which I could post here, if you like, but in a nutshell you need to go to applications and HP and click on Uninstaller and do it. Then go to HP support site and you will find a place to enter your all in one product number, and then you can download the updated software. You will need to reinstall your printer once you have installed the software and you will find that it all works again, brilliantly.

Good luck

Brunel2

- Collapse -
Still not working

I have had this problem on and off since purchasing a mac with Snow Leopard. Sometimes the scanner works; other times, the mac can't even recognize the scanner. I can always print and fax. I tried the suggestion to uninstall then download the drivers, etc. from HP Support. It has not solved the problem.

Any other suggestions?

- Collapse -
Correction - works with a different utility

Please disregard my previous post - I see now that I must use a different app to scan - "HP Scan" - which came with the new download.

- Collapse -
You must update your Mac Software first

Hi there - I just installed Snow Leopard and Scan Pro ceased working for me too. I read that the workaround is using Preview (which I like much better anyway). I tried that, though, and it didn't work at first.

I found that what I had to do was go to the Apple menu and then click software update. If there were any software updates available, I updated everything. I restarted the computer and then Preview was able to see the scanner and it worked.

So basically, your Mac software must all be up to the minute through Software Update. Like right up to the second. Then Preview will work with your scanner. Happy Worked for me anyhow. Take care.

- Collapse -
Uninstalling and reinstalling worked for me!

Just wanted to post here that I tried the updates in Mac and that did not fix the problem, so I did the whole uninstall/reinstall thing. It worked!!! Yay!!!! I'm a novice at the inner workings of computers so if I could do it, then it must not be too difficult. At the end of the reinstall, a prompt came up automatically to reinstall my printer/fax/scanner. I have a Photosmart c309a. They did it for me essentially, so I'm a very happy camper now. Happy Thanks for this thread - my husband and I have been baffled by this problem for months now!

- Collapse -
This comment was very useful!

I just stumbled across this exact problem today and thanks to this message and finding it quickly - (for once!) - I was able to sort the problem out straight away. Thanks sheilanawaz Happy

- Collapse -
HP Scanner No Longer Works with Snow Leopard

That's an easy fix.

- Collapse -
Effortless Scanning with Snow Leopard

Go to your Preview app on your Mac.
Click "File"
Click "Import from Scanner"
a window will open...
click "Scan"

- Collapse -
Sounds suspiciously like the solution offered

in the 3rd post of this thread

CNET Forums