"Can I upgrade the imbedded AS to 4.5?"

No, but you can use ActiveSync's latest version on the Host PC. I've done that without ill effect. Of course there will be some that want some iron clad assurance but who offers this?

As to the sync failures, those are classic and never were properly addressed. There are KB articles about them but we were left to call (and pay) Microsoft or the PDA maker about such. Sadly most of the time they just have you delete the items.
Bob