renoor,

You might try Screen Fit as an option. But the 16x9 option should display the screen properly. I might also recommend checking to make sure your drivers are up to date.

The other suggestion I have is to Edit the Name of your input from "----" to "DVI PC" or any of the other applicable options. That often resolves computer-related input issues.

--HDTech