Computer Help forum

General discussion

How to share a USB external hard drive on a home network

by ilympt / May 8, 2007 3:11 AM PDT

I have a home network connected to a Dlink router, all PC running XP SP2. I have no problem sharing printer, internal hard drive/folder and Firewire external hard drive, but for some reason, I cannot share my USB external hard drive.

I mean, I can set the 'Share' setting on the folder to share, but none of my networked computer can access the files. They do see the shared folder but when I clicked on it, it comes back with an error message "\\pc1\folder is not accessible, you may not have permission ...."

I am pretty sure it is some setting/configuration I am not setting properly, any help would be appeciated


Discussion is locked
You are posting a reply to: How to share a USB external hard drive on a home network
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: How to share a USB external hard drive on a home network
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Did You Change The 'Share' Permissions..
by Grif Thomas Forum moderator / May 8, 2007 10:29 AM PDT

RIGHT click on the drive, choose "Sharing and Security", then click on the "Security" tab, (if there is one), then give "Everyone" full control.

Hope this helps.


Collapse -
thanks for the reply, but...
by ilympt / May 8, 2007 1:39 PM PDT

Thanks for the reply.

Yes, "security" tab is set for everyone full control and the Share permisssion is also set properly. As I said, I don't have problem sharing a FireWire External HDD, only USB one. Really don't understand why...

Collapse -
Is this a permanent situation or temporary?
by lacsr / May 8, 2007 9:07 PM PDT

I do not know why you can't share this drive but if this is just a temporary thing, why not just move the external drive? If this is a permanent share, you could try something like this:
These devices are getting cheaper and better all the time, as other people are doing the same thing as you.

Collapse -
Sharing USB external hard drive (HDD) on a home network
by WindsurferLA / May 20, 2007 5:42 AM PDT

I have had somewhat similar experience. My home network has four computers (WinXP-pro, WinXP-pro, WinXP-home, Win98 ) linked together. The two USB hard-drives (one on USB 1.0 port and one on a USB 2.0 port) connected to the WinXP-home machine can no longer be seen by other computers on the network. As in your case, when I look at "My Network Places," the WinXP-home's USB HDD's are listed, but access is denied.

Any of the machines can access any of the shared files on the WinXP-home's C:\ drive, so the network is working. Furthermore, if the WinXP-home's external USB HDD is physically moved and connected to a USB port on one of the WinXP-pro machines, it can be viewed by other machines on the network, so the problem is not with the specific HDD. Of course, the files on the external USB HDD can be accessed directly from the WinXP-home machine through the "My Computer" panel, so the HDD is working properly. And finally, the problem does not appear to be drive letter related as the problem is encountered on both the HDD manually assigned drive letter "U" as well as the UDD with automatically assigned drive letter "E".

In the first paragraph above, I say the external USB connected HDD can no longer be seen by other machines on the network. Up until about two months ago, I used to be able to read and write to those HDD. I'm uncertain as to what has changed, but I've diligently sought to make sure all sharing parameters are correctly set.

In the past, I've suspected my Norton Antivirus software, but I'm running Norton on all of my machines. Also, the problem persists even when I temporarily turn on Norton Antivirus and worm protection. Thus, I've concluded that the problem is something associated with an interaction between WinXP-home and either an Norton Update or a Windows Update.

Moving the HDD to another computer would mean that I'd need to have that second machine turned on when ever I wished to address the external USB hard drive from the WinXP-home machine. The idea suggested in another reply of buying a device that would allow direct connection of the USB HDD to the network is an interesting option and will be investigated.

Finally... All WinXP OPsys have been updated with SR-2 and later updates.

Any suggestions as to how to solve this problem will be appreciated.

Collapse -
Sharing USB external hard drive - correction to prior post
by WindsurferLA / May 20, 2007 5:48 AM PDT

In prior post... I had blunder... Access to external USB HDD on WinXP-home machines is still blocked when Norton is turned OFF. (I had inadvertently said "on".)

Collapse -
Network Magic

I just purchased Network Magic just for fun because it was on sale at for $12. and it is really neat.

Shows all folders that are shared by putting an open hand under the drive or folder.

Hey, $12. is under the tip I leave in a good restaurant these days..

Collapse -
resolve you problem
by Timmy Milas / May 10, 2007 5:57 PM PDT
In reply to: Network Magic
Collapse -
Network Magic not working
by ilympt / May 10, 2007 9:58 PM PDT
In reply to: Network Magic

I downloaded Network Magic trial and installed it on 2 pc, I can set the folder to share from 1 pc and the other pc will see the Network Magic share folder but cannot access (same as using window share) it, I try to use the help from Network Magic but it did not solve the problem (firewall setting etc) Sad

Collapse -
How to share a USB external hard drive on a home network
by zeus1901 / December 27, 2009 3:51 AM PST

I just did a right click and share on a folder inside the drive. I, too, could not share the drive.

Collapse -
Same problem, but solved after below registry value change
by serendipitee / January 24, 2010 10:29 AM PST

Hi all,
I faced the same problem and solved the problem by googling around and after I this page:;en-us;177078

Follow the below instruction and restart computer.

1. Click Start, and then click Run.
2. Type regedit, and then click OK.
3. Navigate to the following key:
4. In the right pane, double-click the IRPStackSize value.
NOTE: If the IRPStackSize value does not already exist, use the following procedure to create it:
a) In the Parameters folder of the registry, right-click the right pane.
b) Point to New, and then click DWord Value.
c) Type IRPStackSize.

IMPORTANT: Type "IRPStackSize" exactly as it is displayed because the value name is case-sensitive.
5. Change the Base to decimal.
6. In the Value Data box, type a value that is larger than the value that is listed.

If you created the IRPStackSize value using the procedure described in step 4, the default value is 15. It is recommended that you increase the value by 3. Therefore, if the previous value was 11, type 14, and then click OK.
7. Close the Registry Editor.
8. Restart the computer.

Actually for me the solution worked only after changed the decimal value to 21.
good luck guys.

Collapse -
Thank you!!!
by RevBlackie / March 18, 2010 2:09 PM PDT

serendipitee --

I actually just signed up on the CNET forums specifically to thank you.

I know this thread is several months old, but this problem has been driving me crazy for weeks now. I have 5 large USB drives shared on my network. Until recently, everything worked great. Then, for some reason, three of the drives just refused to work anymore. They were visible on the network, but inaccessible. I've tried reformatting them (switching from NTFS to FAT32 and back), sharing and unsharing, changing permissions...the works. And none of it worked. But I found your solution with the registry edit -- which never would have occurred to me (especially since the Microsoft topic about it doesn't even seem to describe the same problem!). Everything came back online immediately, and all drives are now accessible.

So, in case you ever check this thread, Thanks! Your info was a lifesaver!

Collapse -
You are welcome!
by serendipitee / March 19, 2010 12:52 AM PDT
In reply to: Thank you!!!

I am glad it helped. Happy

Collapse -
Thanx also
by Marcs1102 / March 28, 2010 7:12 AM PDT
In reply to: You are welcome!

got a few 1tb external usb drives this weekend (on sale for $129!), and while the older 200 gig worked over the network, the newer ones didn't... did the reg change thing, and all is well now....

Collapse -
THANKS for your solution.
by olin.rajnoha / April 2, 2010 8:04 PM PDT

I registerd myself just to express my thanks to you.I had exactly the same problem then I followed your steps including creating the "IRPStackSize" variable (I used value 18) and it has worked since computer restart.

Great help. Thanks once again.

Collapse -
Problem persists when connecting windows 7 to vista machine
by PeteBoult / April 12, 2010 12:38 PM PDT

I tried to use your intructions and failed. But thnaks anyway.

The intructions did not make it clear which computer should have its registry edited - so I edited both. I'm using Vista and windows 7. I had to create a new IRPStackSize DWord Value in each and I tried 18, 21, and then in frustration 50 on both machines and still get the message "windows cannot access etc" in Vista and same message from widows 7, plus "you do not have permission to access etc" All my interal data drive (Not C drive exccept public) and even small USB sticks can be made available on either machine, but at least 3 external large USB drives (250GBs) do not seem to want to work.

Any other suggestions?


Collapse -
Your issue is worthy of it's own NEW DISCUSSION.
by R. Proffitt Forum moderator / May 8, 2010 11:59 PM PDT

The clue is the message and the fact the memory sticks work. Here's why.

1. USB memory sticks are often supplied in FAT format. This means no pesky hard to grasp USER accounts to deal with.

2. Bigger drives would have NTFS along with all the permission issues to solve. The message was your clue.

Collapse -
See external NTFS disks over network between Win 7 & Vista
by PeteBoult / May 9, 2010 10:12 AM PDT

Thanks B.
OK, so has anybody got an answer as to how to see external NTFS disks across the above network. Should I just give up and put Windows 7 on my other machine and will that help?

I need (or least think I need) NTFS because I handle some very large files (10GB plus) on a regular basis.


Collapse -
USB Drive Sharing
by igevo / May 10, 2010 5:26 PM PDT

Hello Folk

I followed the registry edit and after re-booting I re-shared the drives in question. They all worked fine and were available for read/write across the network.

All my drives are NTFS and I'm running 7 computers with a mixture of Win XP, Win 7 and Ubuntu.



Collapse -
So helpful
by birdboot / May 8, 2010 11:10 PM PDT

I followed this advice and it solved my problem. Thanks!

Collapse -
thanks a lot!
by cyberguido / September 5, 2010 1:43 AM PDT


thank you very much for helping me solve my problem Happy


Collapse -
registry value change
by biederb / October 9, 2010 2:19 AM PDT

Thanks serendipitee,

This is the only solution I've been able to find that worked, and this is 10 months after you posted it... I can now share my external usb dock drives over my home network even between winxp and mac osx!

Collapse -
by BrunoLeroy / October 30, 2010 1:19 AM PDT

Thank you very much for this invaluable piece of information. Like some of my predecessors,I registered just to let you know it worked like a charm for me too.
Had almost given up trying.

Collapse -
by zemonti / November 20, 2010 4:18 AM PST

Doesn't work for me.

Just to mention - whenever i created IPRStackSize the value was 0. I tried with many different values, but no luck.

I'm using Windows Vista 32 bit.

Collapse -
Try the wizard in SharePlugger
by meelix / February 16, 2011 11:06 PM PST
In reply to: :-(

You might have another problem. It might be correctly set/fixed by the wizard in a program like SharePlugger. This program is actually for automatically sharing USB drives (so you don't have to do it by hand all the time). Could work.

Collapse -
the site
by meelix / February 16, 2011 11:12 PM PST
Collapse -
Don't give up
by Levendaal / August 7, 2013 7:06 PM PDT
In reply to: :-(

I also registered just to say thanks to serendipitee--BUT ALSO to encourage zemonti and others who became discouraged to keep increasing the value until the shares work.

I started from 0 (there was no IRPStackSize; when I created it, the default value was not 15, but 0). I increased the decimal value by 3 several times (first I tried 3, then 6, then 9, then 12, then 15, then 18, then 21, then 24, then 27--each time restarting my laptop). That was fun. It finally worked at 27 Happy
(I noticed that the hexadecimal value changes automatically; when I arrived at decimal value 27, the hexadecimal became 1b, for instance). I'm on Windows 8, by the way.

Now I can finally see my entire E drive (which is connected via USB to my Win8 PC) from my Dune Smart B1. For Dune Smart users, please note that the drive is still not visible via the Dune Network Browser--I had to make a 'New Network Folder' from the Source screen (instructions for that are on several related forums). I can only access it through that shortcut, but it works! It's a 3TB drive, which means it doesn't work well if connected directly to the Dune, hence the need to access it via network sharing.

Thanks to serendipitee for this solution! I really tried everything before stumbling onto this thread.

Collapse -
Thank you
by Ixaera / January 23, 2011 8:35 AM PST

I had this exact problem sharing a partition on a 1TB USB hdd on Windows 7. I followed these instructions to the letter (21 worked for me, FYI), and presto, working share. I did not need to change anything on the computer that is not physically connected to the drive.

Thanks very much!

Collapse -
by WagonMan71 / December 16, 2011 6:49 AM PST

Thanks Serendipitee, fixed my problem straight away. Many thanks.

Collapse -
Thank you/How to share a USB external hd on a home network
by dellaccty / January 7, 2013 12:36 AM PST

I registerd just to express my thanks. I know this thread is old, but this problem has been driving me crazy for sometime on my XP pro thank you!

Collapse -
Thank you/How to share a USB external hd on a home network
by blumarlon / January 9, 2013 12:08 AM PST

I too also registerd just to express my thanks to Serendipitee. I know this thread is old, but this problem has been driving me crazy and I wanted to thank you.

Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


Meet the drop-resistant Moto Z2 Force

The Moto Z2 Force is really thin, with a fast processor and great battery life. It can survive drops without shattering.