The only option from within Word is to go insert->autotext->autotext. On the opening tab (AutoText), uncheck the "Show AutoComplete Suggestions" box. This will disable the suggestion of today's date, as well as openings and closings. However, this will not disable all features of autocomplete...it will still automatically fix spelling mistakes (such as awya and availalbe) and formatting (such as 1/2 and (R)). Basically, it will only disable the features found on the opening tab, none of the others. However, it may be more convenient to just ignore the date suggestions in order to maintain the few features you will loose.

Hope this helps,
John