Resolved Question

How to Open MS-DOS App in Win 7...?

I was saving an Important doc in a NotePad as usual, but when I went back the next day to open, it Wouldn't!? Can Anyone Plz help?
Specs:
Win 7 Home Prem - Dell Insp 1545 - 64 bit OS - Pentium (R) Dual Core CPU - T4300 @ 2.10 GHz Processor. I have 5 Hrs of work saved in that file & I don't understand Why it saved as a MS-Dos app & why it Won't open. Really Appreciate Anyone's Help! Thx!

Discussion is locked
lazer8 has chosen the best answer to their question. View answer
Follow
Reply to: How to Open MS-DOS App in Win 7...?
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: How to Open MS-DOS App in Win 7...?
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments

Best Answer

- Collapse -
Just a quick idea.

Run Notepad and then on its File, Open, click and have it show All Files, then navigate to that folder then open that file. (from Notepad, not Explorer)
Bob

- Collapse -
That's the Path I Took... Thx!

Thanks Bob... that's Exactly how I discovered the Encoding Error... Thx for the input!

- Collapse -
Glad you got it sorted

Good work.

Mark

- Collapse -
Thank youuuuu!!!! your quick idea has saved my work ;))))
Blush
- Collapse -
MS DOS App in Win 7

Hi Bob,

I did what you suggested to the post earlier and it loaded the file in symbols and was not decipherable. I read on another thread that if i rename the file with .txt it would open up but same issue. Any tips?

Em

- Collapse -
For now, I suggest a fresh new post with more detail.

This thread is more than 561 days old so let's start fresh.
Bob

- Collapse -
Thanks u very much.....

thanks your answer save my work..............................................really appreciate Happy Happy Happy

- Collapse -
Answer
What is the file extension?

What is the file extension of this file you saved?

What happened when you tried to open this file? What error messages?

Where does MS-Dos come into this?

What happens if you do this? Open Notepad itself, no files, just Notepad. Goto File > Open, navigate to where this file is, then select it. Does Notepad open and display the contents of this file? If not, what happens and what do you see?

Mark

- Collapse -
Reply to Mark Re: More Info

Hey Mark,

My file ended up in 'My Docs'... NOT Notepad.

When I hover over the file, it says: Type: MS-DOS Application.

When I Click to open, the Error message window w/ the Red X reads:

"The version of this file is not compatible with the version of Windows you're running. Check your computer's system information to see whether you need an x86 (32-bit) or x64 (64-bit) version of the program, and then contact the software publisher."

ALSO: When I click on "Properties"... under the General Tab it reads: Type of File: MS-DOS Application (.com)

Btw, I also found ANOTHER Small file that saved the SAME way... Just don't understand what happened & WHY... if it saved it as a MS-DOS App on my Laptop, then WHY can't it open it back up? Thanks for trying to help. MUCH Appreciated!!!

- Collapse -
Found a FIX!!! Encoding Error!

I opened up the Notepad & when I couldn't locate my
file, I selected "ALL Files"...



Found it there, THEN, I Changed the Encoding from the
Default ANSI to UFT-8...




The File opened with NO problem...

I Still Don't understand,
but it worked After

HOURS of STRESSING!!!!

Hope my Screw-up helps someone else
in the future.


Thanks Again for the interest in assisting me! Its good to
know that there are GOOD people out there willing to help a complete
stranger without expecting something in return... Special Thx to Mark & Grif...

- Collapse -
Tried Simply Renaming The File??

It sounds like it was named with an incorrect file extension.. RIGHT
click on the file, then rename it with a .txt file extension. It should
then open in Notepad again. You'll need to make sure that file extensions are showing in Control Panel-Folder Options-View tab. (UNCHECK "hide extensions for known file types".)

Hope this helps.

Grif

CNET Forums