Attention: The forums will be placed on read only mode this Saturday (Oct. 20, 2018)

During this outage (6:30 AM to 8 PM PDT) the forums will be placed on read only mode. We apologize for this inconvenience. Click here to read details

Windows Legacy OS forum

General discussion

How to get rid of boot menu

by az0000000 / July 14, 2005 10:10 PM PDT

I am with Win XP Pro on Acer laptop
Where can I switch of the option that shows at restart this menu:

Safe Mode
Safe Mode with Networking
Safe Mode with Command Prompt

Enable Boot Logging
Enable VGA Mode
Last Known Configuration
Directory Services Restore Mode
Debugging Mode
Disable Automatic restart on System Failure

Start Windows Normally
Return to OS Choices Menu

Probably it was activated from BIOS but I am not sure. I hope there is a way to switch it off from windows interface.
Thank you.

Discussion is locked
You are posting a reply to: How to get rid of boot menu
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: How to get rid of boot menu
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
What shows at..
by Papa Echo / July 14, 2005 11:15 PM PDT

Boot.ini ? and at
System Properties (right click My Computer)-->Advanced-->Startup and Recovery -Settings-->Edit startup Options ?

Collapse -
What you mean?
by az0000000 / July 15, 2005 1:02 AM PDT
In reply to: What shows at..

At System Properties (right click My Computer)-->Advanced-->Startup and Recovery -Settings-->Edit startup Options settings are ok.
Seems like there should be other reason for that...

Collapse -
My Computer Properties
by MarkFlax Forum moderator / July 15, 2005 9:55 PM PDT
In reply to: What you mean?

Papa Echo's suggestion was meant to be;

Right click My Computer, then select Properties, then in the Advanced tab click the Settings button under "Startup and Recovery".

Then in the Startup and Recovery dialogue, click the Edit button under "Default operating system".

Depending on your setup, the Boot.ini file should look something like this;

"[boot loader]
[operating systems]
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Professional" /fastdetect /NoExecute=OptIn"

Does yours?


Collapse -
by MarkinTO / July 15, 2005 3:13 PM PDT

Sounds like you got a stolen lap-top?

In any case, start it in SAFE mode, goto Control Panel, then Device Manager and then look for problems?

Look for Exclamation Marks or Red 'X's.

Right-click on these and figure out what's stopping it from starting. The system will tell you what's wrong.

Then, get back to us...

Collapse -
No way stolen!
by az0000000 / July 15, 2005 7:47 PM PDT
In reply to: Start-up

First, it is not way a stolen laptop, it is a computer that belongs to SFP Moldova organisation which's webdesigner am i Happy
I'll try the option you give, may be it'll help.
Thank you.

Collapse -
can winxp load?
by jeniesis1 / July 15, 2005 8:16 PM PDT

does your laptop load windows when you choose one of the boot options? when you select ''start windows normally'' does it start at all? if winXP loads and you can use the laptop normally without any problem other than seeing the boot option in startup, then you could just set the time on how long the computer displays the screen you can do this by: Right clicking My Computer>properties>advance>startup & recovery>settings; then you could just set uncheck the ''time to display recovery options when needed'' or put a smaller number than 30 secs. say, 1 sec perhaps?

hope this helps.

Collapse -
Ok, i'll try it...
by az0000000 / July 16, 2005 1:15 AM PDT
In reply to: can winxp load?

I will try these options.

Collapse -
Re: Get rid of boot menu
by trublubush / July 15, 2005 10:22 PM PDT

By default, this menu appears at boot time whenever the system was previously shut down with a resident module active that couldn't be terminated normally. Since the debugging process for this error requires services which, at this point in time, are no longer resident that would allow user interface, XP has no other choice than to red-flag that particular shut-down. The next time the boot process is activated, the ''red flag'' is recognized and XP will then activate the boot menu which you are seeing; the assumption being, that a problem occured during shutdown that the user could possibly repair through one of the menu's system boot options. This occurence, however, is not classified the same as an ''Improper Shutdown.'' You therefore, will not see the ''Scan disk for errors...'' interrupt.
The faulting module in most cases is a private launch by either a spyware/malware program or an OEM program requiring hardware interface software, ie., WIA(Windows Image Aquisition) services. If the hardware is unsafely removed, or not recognized, the faulting module can cause XP to lose that module's stack vector which prevents a normal termination. Was your laptop ever docked? You might have a resident program that is constantly searching for non-existant hardware. Is your anti-virus/spyware removal program active and updated? You may have a net-pinger that's trying to ''phone home'' during shutdown. A third possibility is a corrupt 'BOOT.INI' file. you can check this out by going to 'Start', 'Run'. Type in "msconfig" and hit the Enter key. When the tool menu appears click on the 'BOOT.INI' tab.

Collapse -
I will check for bad hardware
by az0000000 / July 16, 2005 1:18 AM PDT

Ok, thanks, i will see device manager for bad hardware... That all i would have to do as windows is always shutting down normally, not giving any error messages.

Collapse -
Tried that too
by az0000000 / July 17, 2005 10:55 PM PDT

So is it that i have a spyware program that causes troubles to Windows Image Aquisition service for example?

Popular Forums

Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


Your favorite shows are back!

Don’t miss your dramas, sitcoms and reality shows. Find out when and where they’re airing!