Tablets forum


How to get Adobe Flash 9 or higher on Kindle Fire HD 7?

by IndianQueenPoint / January 8, 2013 1:10 AM PST

I have a new Kindle Fire HD 7 and I want to access my Weight Watchers account. My browser will take me to the site but Adobe Flash 9 or higher is needed to open my tracking information. I tried to download Adobe Flash and it tells me I have a Linus OS and gives me some choices of what version to download: YUM, .tar.gz, rpm, APT. What do I choose?

Discussion is locked
You are posting a reply to: How to get Adobe Flash 9 or higher on Kindle Fire HD 7?
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: How to get Adobe Flash 9 or higher on Kindle Fire HD 7?
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Collapse -
by R. Proffitt Forum moderator / January 8, 2013 1:17 AM PST
Collapse -
How to install flash
by brandonmaui0000 / March 5, 2013 2:09 PM PST

Install aptoide from google play store

Collapse -
you can get flash on your kindle fire...
by Silverwinded / January 15, 2013 9:17 PM PST

Without voiding the warranty..

Hopefully you have already broken out of amazons world by downloading the following:

1 mobile for the dolphin browser
Dolphin Browser (sorry firefox isnt working with it right now, so you its your only other choice to get flash on a brower.
Es File Folder (can get on the amazon app store)
Adobe 11.1 or whatever adobe file you can get for andriod mobile. ONLY open this via the file folder system, amazon will not allow you to do this through thier app and install program.

You need to download the esfile folder first, then go into the downloads after getting adobe, install it, install dolphin..

Presto, you now can access flash online(without voiding the warranty) , I just watched with my wife last night to watch the latest castle on kindle.

Frankly, for how wonderful the kindle looks streaming content, it is a annoying to have to work around all of this.

Collapse -
Thanks for this.
by R. Proffitt Forum moderator / January 16, 2013 12:00 AM PST

It's an annoying workaround but good to know folk are finding easier ways than when I first looked into it.

Collapse -
Flash for my Kindle
by IndianQueenPoint / March 7, 2013 2:32 AM PST

This is the most promising info so far. I have tried going on and but have been unsuccessful in getting Dolphin HD browser. The browser on my Kindle (I think Silk) doesn't seem to allow me to download some files. Can you suggest another way for me to get Dolphin browser?

Collapse -
Look up? See aptoide ? I'd try that.
by R. Proffitt Forum moderator / March 7, 2013 2:45 AM PST
In reply to: Flash for my Kindle

I didn't try that.

Collapse -
Dolphin for Kindle
by Mz_Cheekz / March 19, 2013 2:59 PM PDT

I tried following the steps you said but I can't get dolphin through the app store. Please help.

Collapse -
I have not done this but my thought is
by R. Proffitt Forum moderator / March 20, 2013 12:52 AM PDT
In reply to: Dolphin for Kindle

Try researching "side loading on your Kindle Fire HD."

I see they didn't get the browser from the store but sideloaded it and used ES File Explorer to install.

This is only me sharing a bit more but not an offer to do much else as I have not done this to our KF HD.

PS. Try to always indicate which Kindle you have. My old black/white Kindle is not android based.

Collapse -
Dolphin for Kindle
by baebygurll / March 27, 2013 4:52 AM PDT
In reply to: Dolphin for Kindle
Collapse -
Downloaded flash but still not working
by acehygienist / November 26, 2013 11:44 PM PST

I have downloaded the ES file, Dolphin and Adobe flash 11.1 When I try to access the tracking tool of my weight watchers etools (in the Dophin), it still won't open. It's like it's trying but won't open. Any thoughts on what to try next?

Collapse -
Ask those that came up with this.
by R. Proffitt Forum moderator / November 27, 2013 1:33 AM PST

Doesn't WW have an app?

Collapse -
WW App
by acehygienist / December 1, 2013 3:34 AM PST

WW has a mobile app that you can use on the kindle fire HD 8.9, but it is not a accessible as the full website. Kindle does not have a WW app available.

Collapse -
My old B/W Kindle has no apps.
by R. Proffitt Forum moderator / December 1, 2013 3:41 AM PST
In reply to: WW App

Incomparable to modern tablets. That is, it's usually called an e-reader.

Thanks for confirming they did an app. I'm sure folk always want parity with the web site.

Collapse -
Install Flash to your Kindle Fire HD
by tim_fromcnet / August 25, 2013 10:25 AM PDT
Collapse -
Old post but it didn't fix it for
by R. Proffitt Forum moderator / August 25, 2013 10:41 AM PDT

So for now, why do this?

Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?