If you want the main monitor as #1 why not connect it to the video port that claims to be #1?

Also, here I see an option "This is my main display" on some video controls. Watch for that.