How to assign an alternate gateway from my DD-WRT router?

Aug 4, 2016 11:33AM PDT


I have a Linksys E1200 loaded with DD-WRT. I am trying to assign clients a gateway IP other than that of the router itself. I looked through a bunch of forum posts concerning DNSMasq, followed the steps, and my router still assigns clients its own IP address instead of the gateway I'm specifying. For example, I use the following code in the Additional DNSMasq Options box:


But I get, the IP of the router. What am I doing wrong? All responses are appreciated. Thanks.

Discussion is locked

Reply to: How to assign an alternate gateway from my DD-WRT router?
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: How to assign an alternate gateway from my DD-WRT router?
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
- Collapse -
I'd head to the DDWRT forums for this one.
Aug 4, 2016 11:39AM PDT
- Collapse -
I've found a lead.
Aug 4, 2016 3:22PM PDT

After examining the files on the router, the DNSMasq settings are stored in /tmp/dnsmasq.conf. However, the file resets when I reboot the router and my changes are not saved. I realized that I have to write it to a permanent file. How do I go about doing that?

- Collapse -
(NT) I have TO write it
Aug 4, 2016 3:29PM PDT
- Collapse -
After taking a few risks, I've found the answer.
Aug 8, 2016 10:14AM PDT

The dnsmasq.conf stored in the temporary folder did not save manual settings made by a terminal. It required JFFS, which the mega build was too big to support on the Linksys E1200. So I reverted to stock firmware, and then flashed the router with the mini build. This left enough space to support JFFS. I retried the dnsmasq settings on the webpage, and BOOM! It worked.

CNET Forums

Forum Info