Networking & Wireless forum


How resolve "Invalid IP Address" and "No Internet Access"

by timothyirvine / October 17, 2012 4:59 AM PDT


First, thanks for taking the time to work these forums and answer questions like the following.

I got a Gateway Windows 7 laptop for work. It connects to our wireless network at work. I took it home.

It connects to the home wireless network, but has "No Internet Access."

Upon running the oh so helpful "Diagnose" options in Windows, it tells me there is an "Invalid IP Configuration."

Attached are screenshots from the Win7 machine and from my Mac, which I used to access the router wirelessly. You can see that the windows machine (ip reads as an active wireless session on the router, but I can't figure out how to get it to go from the router to the internetz.

If you can please help me resolve that, it'd be great, as my IT guy at work basically says "well, it must be your router, then." Real helpful.
If you can help by letting me know how I can configure my router to take the windows machine online, that would be fantastic.


Discussion is locked
You are posting a reply to: How resolve "Invalid IP Address" and "No Internet Access"
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: How resolve "Invalid IP Address" and "No Internet Access"
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Collapse -
Attached Screenshot
by timothyirvine / October 17, 2012 5:03 AM PDT
Collapse -
1. I see that 169.x.x.x when the security is set to WEP.
by R. Proffitt Forum moderator / October 17, 2012 11:07 AM PDT

Easy to fix. Use WPA2 AES personal security.

2. Pictures are actually in your second post and are fine. If you didn't catch why no pictures it was discussed a few years ago and folks gave examples of how unsafe it was. That killed it. CNET was not going to allow unsafe things in the forums.


Collapse -
Now pulling my hair out. Yippee
by timothyirvine / October 18, 2012 11:33 AM PDT

Hey! Thanks for the answers.

So my IT guy took the laptop, scratched his head, and gave me admin rights - at which point logging on was fine.

For whatever reason, making my account an admin account meant it connected no problem to the work address. The IP was 172.xxxx something.

I go home. Log on. (I'm not an admin).

It doesn't work, same problem, same IP. However, now, when I look at available wireless networks, there is already a little exclamation point next to my network name, and it says it is unsecured. It's not unsecured - it should have prompted me for a password.

screenshot of that strangely now-unsecure router setting:

I need to go in and change my IP manually, which I can now do with admin rights - but I'm not entirely sure how to do that. Working on that via searches in Google, etc.

I also need to make my router's wireless require a password again - however, will change that suddenly require other users to have to adjust their passwords? Why is my iMac still wirelessly connected when its set to enter password xxxx and the router is set to unsecure?

Collapse -
Really wish I could edit my post
by timothyirvine / October 18, 2012 11:43 AM PDT

I am NOW an admin. not "not" an admin.

work network, not "address."

And I bit the bullet and changed the router security to WPA2-AES and my machine (and presumably every other housemember's) reconnected fine with the saved password.

Then I changed security on my laptop's wireless profile to match that of the router, and it's the same damn problem - invalid IP with the stupid IP.

So sort of back to square one, it seems. Changing the IP address and why it does that with my home network and not the work network.

Collapse -
The new clue here is the Office.
by R. Proffitt Forum moderator / October 19, 2012 1:30 AM PDT

As the IT person can have it set to only allow office network use you'll have to ask them to configure it to allow other network use.

Collapse -
I changed my IPV4 settings
by timothyirvine / October 18, 2012 11:57 AM PDT

Using my router information, and picking x.x.x.106 (other computers are 100-104) as my static IP.

Attached are screenshots:

Still nothing.

Turned off IPV6 and tried with just 4. Nothing. Both are back on now.

Still the same problem - despite the fact that the router now lists under active sessions my x.x.x.106 IP address.

Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


The most beautiful phone ever has one wildly annoying issue

The Samsung Galaxy S8's fast speeds and fantastic curved screen make it a top phone for 2017, but the annoying fingerprint reader could sour your experience.