How do I keep all networked devices online?

I have been using the same wireless setup in my home for over a year. We have a Belkin Surf wireless router and an Arris modem from Comcast, using cable internet from Comcast. In the house, we have 5 devices that are set up to automatically connect wirelessly: iPhone 4, an old iPod touch, a MacBook Pro, a Toshiba laptop, and a Brother printer. Until recently, there has never been a problem with connectivity.

Lately, certain devices have been losing connection. For example, last night my husband and I were both using our laptops with no problems. This morning, his is connected and my iPhone is connected, but my Mac is not (I get a timeout error and am not connected to the internet). Sometimes it's his laptop that drops the connection. Other times it's my son's iPod or my iPhone. It is never all of the devices at once (something is always connected), and each device always recognizes the network as existing yet cannot connect to it. The only way I've found to solve the problem is to unplug and restart the router.

I have also tried to change the channel that the router is set to, but that has not seemed to solve anything. The firmware is up to date. We are password protected in an area with few neighbors, and there never are any unknown devices connected when I check the client list for the router.

Any suggestions?

Discussion is locked
Reply to: How do I keep all networked devices online?
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: How do I keep all networked devices online?
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
- Collapse -
This area is well discussed.

Since WiFi is in the wide open, there are many reasons and causes for it to drop. As to the unknown devices, since I can spoof the MAC address you would never know if I connected to your network. There are many tools to do this now as well as, well, more.

The industry has done a poor job in many areas. Both the router quality is not that good (proof? Why else would they issue firmware updates?) and they don't explain that WiFi is not a sure connection.

We can improve our setups with a move to tighter security (noted at the top of this forum) such as router defaults then change the SSID (keep it simple) and then WPA2 AES personal but I find most owners are not ready to do that.

- Collapse -

It would be of more help if you would be able to offer suggestions rather than point out flaws. Yes, wifi is open and, therefore, never secure. I am not ruling out third party interference, but given our environment I am not leaning in that direction.

There have never been firmware updates for the router, so it is obviously up-to-date, but again your willingness to waste my time with your lack of suggestion is noted.

The router has always been set to WPA2 personal.

I read through the introductory troubleshooting posts of this forum, which were of no real help solving my problem. Perhaps I am missing something. I do not understand why a network that worked flawlessly for a year would suddenly and randomly become sporadic. I do not understand why the devices "see" the network when they are disconnected yet cannot connect to it until the router is rebooted. I am seeking suggestions and advice, not condescending attitude.

- Collapse -
I did offer suggestions.

You would need to tell more about your setup.

For example it's great you have it at WPA2 Personal but did you do anything non-stock? That is, we find some routers have issues if you turn on the firewall or deploy MAC filtering.

Why not talk about router flaws? You are feeling it so let's get it out in the open.

- Collapse -
Keep networked devices online

I really don't have an answer to this problem.

My interest is that I have the same problem. With the minor exception that two of my computers are wired to the router. They can see the connection but can't connect until I reboot the router. My router is a Belkin N+ etc. All of my computers are W7, my iPhone(s) are the 3G, my wireless printer is an Epson. Need I go on? I think not.
As you stated, the only solution is a reboot. That was the case with my last router and I suspect it will be the case with my next router. It seems the industry doesn't care beyond the purchase. I've contacted Belkin; their only suggestion was a firmware update. While there was an update available, it didn't solve the problem.

I make it a point to check the networking icon before I do anything and I have the router easily accessible.

- Collapse -
Let me share my quick fix.

I put my router on a timer and at midnight it go off. About 5AM it comes back on. It's a simple daily forced reboot of the router and has worked that way for many months.

- Collapse -
Let me share my quick fix

Well, you're correct that is a quick fix.

In my opinion it is not well thought-out though. If I turn off my router every night and boot it every morning, all of the automatic updates, for Windows and my security suite and several others won't happen until sometime during the day. Now I find that as inconvient as having to reboot the thing in the first place.

As you said earlier, you did offer suggestion; but not practical ones.

Oh, and I might add, I would need to purchase yet another piece of equipment.

- Collapse -
Or you can get the maker to fix your current gear.

That's a bit obvious so I didn't write it but now you have forced me to do so.

If your gear is failing, then you have it fixed.

- Collapse -
Get the maker to fix my gear

As I said in my original post, I contacted Belkin. Their only suggestion was a firmware update. Which was available, so I updated. The result has been; no change. The previous router was a Belkin, also. Maybe I ought to get a Cisco or something. Frankly, I suspect the industry just doesn't care if they produce junk. They know we'll buy it and after the sale, it's all on the consumer. Probably, if I spent big bucks, I'd be able to get a good router. We never had this issue where I worked. But I'll bet they spent thousands on hardware. I'm not that much of a high-roller.

I've been through the book for my router. It doesn't even suggest such a failure might be possible. I've looked at all of the settings and read all of the "what's this" pop-ups. I'm stumped. My hope was that someone on this forum could suggest a real solution.

I guess not.

- Collapse -
I have some workarounds.

At the top of this forum is a sticky. It should show the usual advice.

1. Latest firmware or if the support folk suggest a specific version, then that version.

2. ROUTER DEFAULTS!!! I am no longer explaining why hiding the SSID creates issues as well as never adds to security.

3. Move to WPA2 AES personal security after it is working.

4. Torrents? No complaining as you know why.

5. We have more tweaks such as pushing the 802.11n router back to 802.11g only. Can help cranky routers.

-> These are not "real solutions" but real workarounds.

- Collapse -
Some help

I would do a survey of the wireless signals in your area. I use inSSIDer for this. There are some good programs, just do a google search for wireless signal survey programs. You want to make sure your router is on a channel that does not have a lot of other devices on it. You also should check your wireless settings. Make sure you don't have your device set to autochannel. This would make your channel change whenever it detects a problem with the channel it's on, possibly kicking off your devices.

CNET Forums