Question

How do I get a mini DV tape out of a dead camcorder?

Hi guys, I have a panasonic pv- gs 150 camcorder. This camcorder was a gem to me and worked very nicely for years. Recently I was doing some family filming, when my brother was migrating, when i got home I tried to attach the camera to the TV only to realise that old betsy died. My concern is the Mini DV tape inside of betsy. I have scoured google searching for answers to my concern, and no one seems to know if there is some kind of manual mechanism to get mini DV tapes out of dead camcorders. Do any of you techies know any solution? I have tried everything from charging the battery, to connecting the camcorder to the adapter, to resetting the camcorder, same response...no power.
These camcorders need power to eject the tape, so please, help?

Discussion is locked
Follow
Reply to: How do I get a mini DV tape out of a dead camcorder?
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: How do I get a mini DV tape out of a dead camcorder?
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
The answer is not out there.

And even my answer is unclear to most. I found I had to forget about repair and use anything and everything to get the tape out including small metal cutting snips and of all things a butter knife.

I doubt the procedure is documented anywhere.
Bob

- Collapse -
it seems you're correct...

Just by the response, I've been gettin on various forums including cnet... I guess the techies wanna keep this one secret, and its been working so far.
I sent it to the repair shop, turned out to be a failed power supply circuit... they serviced it, and its back up and running. whew.

CNET Forums