General discussion

how do I disable the touchpad on my Dell Latitude D620 lapto

I don't see anywhere in device manager where I can disable my touchpad. I do a lot of editing and the touchpad gets in the way of my palm and sends the cursor flying. Can't deal with it. I have an external mouse and when plugged in it works, but touchpad still on also, so not fixing my problem
Please help.

Discussion is locked

Follow
Reply to: how do I disable the touchpad on my Dell Latitude D620 lapto
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: how do I disable the touchpad on my Dell Latitude D620 lapto
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
TouchPad shut down

Download TouchFreeze. This freebie shuts down the pad when you begin typing. If it doesn't work with your pad, search the web for other programs like it.

- Collapse -
Touchfreeze downloaded

OMG!! IT'S PERFECT. MY EDITING IS BACK UP TO SPEED AND I AM SO GRATEFUL FOR YOUR INPUT AND TIMELINESS.

THANK YOU SO MUCH
DFROST2123

- Collapse -
Must be some other ways.
- Collapse -
DISABLE TOUCHPAD

THANK YOU FOR YOUR POST. IT'S ALWAYS NICE TO HAVE A BACK UP PLAN. I AGREE.
I DID GO TO THE SITE THAT YOU SAID TO READ AND I DID DOWNLOAD THE TOUCHPAD DRIVER FROM DELL, BUT STILL DIDN'T HAVE THE RIGHT OPTIONS TO USE IT OR IT JUST WASN'T USER FRIENDLY ENOUGH.
ANYWAY, WENT AND DOWNLOADED TOUCHFREEZE. I LOVE IT. IT WORKS GREAT.
SO PLEASED FOR THE QUICK REPLY AND HELPFUL INPUT.

THANKS SO MUCH
DFROST2123

- Collapse -
Turn off Touchpad

Go into the BIOS F2 Go down to next to last then change the PS2/Touchpad to serial mouse It has three options for the touchpad. the left most has to do with serial mouse, the middle has to do with ps2 and the right is the system default. The first will only use the mouse only turn off the touchpad, The middle while using the mouse turn off touchpad. The last you can use both the mouse and the touchpad and is the default. I did check the first one and my usb wireless mouse works and it turn off the touchpad.

CNET Forums

Forum Info