Question

How can I get my print spooler service started?

One day my printer was working, the next day not. It keeps saying my printer spooler service is turned off.
I've done lots to try and get it started, but nothing is working. I've gone into "services" and it does indicate the spooler is stopped. But when I click "start", I get a message saying "error 5 access denied". Can anyone give advice?
My computer is Compaq Presario SR1750NX, with WIndows XP
The printer is Canon Pixma IP4000

Also, I have tried to reinstall the printer, but it will not let me install the drivers because...........spooler service not started. Very frustrating!!

Discussion is locked
Follow
Reply to: How can I get my print spooler service started?
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: How can I get my print spooler service started?
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
The first work I do is to get XP up to SP3.

XP is way out of date and drivers can get wonky and fail.

After Windows Update is done I clear the Event Viewer and reboot after I set the Spooler service to automatic. XP is an old 10+ YO OS so I'll skip all tutorials on basic OS use and repair for the moment. That is, after this much time you would be comfortable with the services and viewers.
Bob

- Collapse -
Give it a try

Ok Thanks, I will give that a try and let you know what happens. Still open to any and all suggestions!!

Deb

- Collapse -
The problem as it is presented.

Is that there are far too many causes. Without some clues to narrow it down, we have to start with the basics such as the windows updates then get to the Event Viewer to clear that, reboot and see if clues are found on the next start up.

It could be as simple as someone installed a new antivirus+firewall and set the security to MAXIMUM. But without more clues, that's just something I ran into last week.
Bob

- Collapse -
If That Doesn't Work, Then Do This

First, click on Start-Run, type: "services.msc", then press the "Enter" key.. Scroll down to and set the "Print Spooler" service to "Automatic" and "Start" it.. Maybe multiple times till it sticks.

Next, what has worked for me (in both XP & Window 7), is to delete the contents of the following folders, then restart the computer.:

C:\Windows\System32\spool\PRINTERS

and

C:\Windows\System32\spool\drivers

Once done, you may not have to reinstall the printer. Try disconnecting the local printer (unplugged the USB cable), wait a few seconds, and then reconnect it. If that doesn't fix the issue, you may need to reinstall the printer. Also, be sure to check the settings in the "services.msc" again, just to be sure it's still set to "Automatic" and the service is started.

And if that doesn't get it done, then try uninstalling the "XPS Printer Writer" in 'Devices and Printers'. You may need a separate tool such as the "XPS Removal Tool" by rogosoft.

Hope this helps.

Grif

- Collapse -
Pretty similar to MSFT's article at link.
- Collapse -
This is what I've tried

Hello,
In response to Grif, I have already done your first suggestion many, many times. I will try clearing those folders as you suggest.

I do already have SP3 and I have tried going into Data Execution Prevention and adding system32\spoolsv.exe.
Needless to say, that didn't work either. I will now try clearing the Event Viewer as Bob has suggested.

I'm on vacation next week, so it looks like I will be spending a good portion of that just trying to print!!!

Thanks for all of your help, it is greatly appreciated!!!

Deb

- Collapse -
(NT) Cleaning Out Those Folders Should Help
- Collapse -
Nothing works

Ok, I have now tried everything that Bob and Grif have suggested and nothing works. I still can't even uninstall the printer to re-install because of the message " print spooler service off"
Any other ideas/suggestions before I simply throw my computer out the window and buy a new one? Happy

Thanks,
Deb

- Collapse -
This is starting to sound as if the OS was damaged.

Did anyone use a registry cleaner? I've found those to create damage so deep...

But tell more about this nothing works. I'm left with an uneasy feeling you didn't delete the contents of the folder. That we can address in another way but nothing works is too vague.
Bob

- Collapse -
Here's more info....

Ok, I'm pretty good with computers but certainly not a tech expert like you guys. When I said "nothing works", I meant that I tried all of your suggestions from the above thread, but none of them did the trick.

I'm the only person that uses the computer. I don't even know what a registry cleaner is so I didn't use one. I checked a few things so I could be a bit more specific.

In the Event Viewer, I deleted all the contents of the folders EXCEPT for in the security folder there was something called a "success audit" from 2006. I did not delete that. Should I have? Everything else was cleared out of the folders.
In the system folder, all the error logs showed the source as "Service Control Manager"

And one final thing I thought was odd.....when I open my "printers and faxes" window, it shows no printers at all. Is that normal when the spool service is turned off? I thought it would still show my printer even though it won't print.

As always, any advice you can offer is much appreciated.

Thank you,
Deb

- Collapse -
Deleting Events is not what I see being suggested.

"In the Event Viewer, I deleted all the contents of the folders EXCEPT for in the security folder there was something called a "success audit" from 2006. I did not delete that. Should I have? Everything else was cleared out of the folders.
In the system folder, all the error logs showed the source as "Service Control Manager""

Please read Grif's advice above to delete the folder using Windows Explorer. You would not accomplish this task in the Event Viewer.
Bob

- Collapse -
about the printer icon

Even if the print spooler service is not running, the printer icon should ideally appear. but if it's not showing up there, reinstall it. make sure that you first uninstall the printer completely from your computer, run a registry cleaner if you have and then reinstall. It should fix any issue.

- Collapse -
Re: registry cleaner

The first part of this advice is OK. But running a registry cleaner is a bad idea.

Kees

- Collapse -
Uninstalling Printer

I have tried to uninstall and reinstall the printer, but it gets so far in uninstalling, then won't continue saying "cannot uninstall, printer spooler service is stopped"

Any ideas?

- Collapse -
Answer
Do you have a friend or other support there?

I read this over and it appears you are not following the advice given. You've headed to the Event Viewer and that was not advised.

Let your friend help you on this one.
Bob

CNET Forums