Samsung forum

Question

How can I fix Allshare which STOPS seconds after it starts ?

by deus0065 / June 25, 2012 12:57 AM PDT

On Win 7, just off the top, when I start Allshare, it quickly stops.Worked well for the several months I have used it with a BR Player. Windows Event log shows the error has two events. The first appears to reach Kernalbase.dll, the second, .net framework.

I will copy the error logs below and hope someone can assist.

- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
<Provider Name="Application Error" />
<EventID Qualifiers="0">1000</EventID>
<Level>2</Level>
<Task>100</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2012-06-25T14:29:07.000000000Z" />
<EventRecordID>32840</EventRecordID>
<Channel>Application</Channel>
<Computer>Trooper</Computer>
<Security />
</System>
- <EventData>
<Data>AllShare.exe</Data>
<Data>2.1.1.0</Data>
<Data>4f507dda</Data>
<Data>KERNELBASE.dll</Data>
<Data>6.1.7601.17651</Data>
<Data>4e2111c0</Data>
<Data>e0434352</Data>
<Data>0000d36f</Data>
<Data>2ec</Data>
<Data>01cd52dedbf48e08</Data>
<Data>C:\Program Files\Samsung\AllShare\AllShare.exe</Data>
<Data>C:\Windows\system32\KERNELBASE.dll</Data>
<Data>1e640085-bed2-11e1-a990-485b3942449f</Data>

- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
<Provider Name=".NET Runtime" />
<EventID Qualifiers="0">1026</EventID>
<Level>2</Level>
<Task>0</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2012-06-25T14:29:05.000000000Z" />
<EventRecordID>32839</EventRecordID>
<Channel>Application</Channel>
<Computer>Trooper</Computer>
<Security />
</System>
- <EventData>
<Data>Application: AllShare.exe Framework Version: v4.0.30319 Description: The process was terminated due to an unhandled exception. Exception Info: System.ArgumentNullException Stack: at System.Collections.Generic.Dictionary`2[[System.__Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089],[System.__Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]].FindEntry(System.__Canon) at DLNA.Controller.DeviceObserver.PreviewOnDeviceDiscovered(DLNA.Device) at DLNA.Controller.Server.ServerObserver.CreateDMSThreadProc(System.Object) at System.Threading.ThreadHelper.ThreadStart_Context(System.Object) at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean) at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object) at System.Threading.ThreadHelper.ThreadStart(System.Object)</Data>

Discussion is locked
You are posting a reply to: How can I fix Allshare which STOPS seconds after it starts ?
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: How can I fix Allshare which STOPS seconds after it starts ?
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Collapse -
Answer
see above
by deus0065 / June 25, 2012 1:03 AM PDT

I forgot to say I have reinstalled the app and .net framework.

Collapse -
Answer
How can I fix Allshare which STOPS seconds after it starts ?
by deus0065 / June 25, 2012 1:06 AM PDT

I have reinstalled the app and .net framework.

Collapse -
Answer
A new cause from me.
by R. Proffitt Forum moderator / June 25, 2012 2:28 AM PDT

I found the newer antivirus with built in antiphishing and firewalls to cause troubles here. But the real test is to try another PC. I find it works there and then I'm troubleshooting Windows.

This area is a fine test of today's makers. They write an app and it works on a stock machine with say the stock Norton. The users change stuff, run a registry cleaner on a more secure antivirus and it doesn't work anymore.

The question then is who gets to fix it?
Bob

Collapse -
How can I fix Allshare
by deus0065 / June 25, 2012 5:40 AM PDT
In reply to: A new cause from me.

No got anti virus but it may be that an update to .net has broken Allsahre--but then why only me with problem ?

Collapse -
It's not only you.
by R. Proffitt Forum moderator / June 25, 2012 5:45 AM PDT
In reply to: How can I fix Allshare

But since it's only a small percentage of machines this is the big question. Who gets to fix this?

You claim that you know it's .net at fault so who issues that?
And did you uninstall .net to test this theory?

As a software author of a few .net apps I have yet to see a .net update break my app. But users continue to believe this.
Bob

Collapse -
How can I fix Allshare
by deus0065 / June 25, 2012 8:22 AM PDT
In reply to: It's not only you.

No guessing here. See the second error log above--Allshare is in conflict with .Net.

Collapse -
And I asked a question, proposed a test.
by R. Proffitt Forum moderator / June 25, 2012 9:53 AM PDT
In reply to: How can I fix Allshare

It appears that we can't work on this one. As such, you have Samsung to call next and those that support your Windows PC.

Sorry I couldn't help you.
Bob

Collapse -
possible solution
by mirkotc / July 5, 2013 12:44 AM PDT

I guess that I have a solution for the issue:

I had installed Allshare media server software in my main PC (Win 7 Pro 64 bits).
I had a Cisco Linksys router (150 Mbps plus 100 Mbps wired).
The connection of the PC and the router was wired.
Allshare server worked OK.
The I changed to a dual band router and installed a Wifi network card in the PC. So I had two network interfaces in the PC.
The Allshare service started to crash continuously.
I tried to use other DLNA servers but they kept crashing.

Then I deactivated the Wireless interface in the PC and the Allshare service started to work OK.
When I reactivated the Wireless card the crashing started again.

Finally I created a network bridge between the two network interfaces in the PC (the wired and teh wireless) so the Allshare server could only see one interface.

So far the Allshare server has been working flawlessly for a couple of days.

I am using the DHCP of the router for all the devices connected to my home network, which include Ipods, Ipads an other three PCs with Win 7. So far it has worked OK.

My idea is that the issue is related to having more than one network interface in the Allshare server, so the service does not know which one to use. After the interfaces had been bridged, the Allshare service only saw one network interface and the problem seems to be gone.
Any additional comments would be great.

Collapse -
Good find.
by R. Proffitt Forum moderator / July 5, 2013 1:05 AM PDT
In reply to: possible solution

But I'm sure that Allshare is coded for the more common system with a single active network connection. Glad you found a solution.

This thread is more than 375 days old.
Bob

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?