Question

HL50A650C1F doing the Power Cycling thing need Help!

My 2008 HL50A650 DLP as of just now, after 7 years and still running the original bulb, now cycles on and off on its own. No clear indication as to what the problem is by the LEDs flashing in any particular order. They operate as they should when the unit is turn off and right back on. When it goes off and is coming back up I hear whining noise from the back sometimes. But when it comes back up, it is as if nothing ever happened. The bulb, although is 7 years old and has well over 10,000 hours on it, is working just fine. The only way to stop the cycling is to unplug the TV. But when plugged back in it starts cycling all over again.

I did a search here and on the Internet and can't narrow this one down. I swear I have seen it discussed here or somewhere and just can't find it.

Any assistance will be greatly appreciated.

Thank you.

Discussion is locked
Follow
Reply to: HL50A650C1F doing the Power Cycling thing need Help!
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: HL50A650C1F doing the Power Cycling thing need Help!
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
Sounds like it needs service.

While 7 years without service is great, it looks like it's time. Try the usual unplug and plug in of the lamp.

- Collapse -
Answer
Re: Power Cycling

CNET Forums