Question

Hibernate will not automatically work in Windows 10

Hi People,
My HP Pavilion a1624n will not hibernate by itself after installing Windows 10. It will go to sleep with no problem.
It used to work with no problems in Windows 7. I have checked the advanced power settings, reset them to normal and then back to Hibernate. At first I thought it was Outlook keeping it from hibernating. But even if I exit all programs (outlook, chrome, firefox, etc.) it just won't hibernate. I created a shortcut in Windows 7 (C:\Windows\System32\rundll32.exe powrprof.dll,SetSuspendState 0,1,0) on my desktop that will make it hibernate, but I miss being able to walk away and forget about it feature of hibernate.
I first did the upgrade Windows 10 and then a clean install of Windows 10.
Any ideas to fix this?
Thanks in Advance.

Discussion is locked
Follow
Reply to: Hibernate will not automatically work in Windows 10
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Hibernate will not automatically work in Windows 10
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
Did you try the old delete the HIBERFIL.SYS method?

It's on the web so I won't go on. More at http://www.tenforums.com/tutorials/2859-hibernate-enable-disable-windows-10-a.html

There could be outdated BIOS and post windows 10 work that needs to be done. That is, I'm running into folk that upgrade or install 10 but didn't know what to do after. Even I can't know this area as there are some million different PCs and yours is the one I don't know.

But I can share my guide on post Windows installs. I find the drivers from the maker for motherboard chipset, audo, video, lan, WiFi and install in that order.

- Collapse -
Thank You

I haven't tried that, but definitely will. I did google before posing here, but didn't see that, received mostly microsoft and windows 7 & 8 related returns.
After upgrading to Windows 10 the only driver issue I had was with the video driver. The picture on my display would not stretch to fill up the screen and I had to find and install the correct Nvidia GeoForce program to fix that.

- Collapse -
The delete of the hiberfil

Applies to About Window NT and up. It's an old issue which each version repeats.

I don't want to upset folk but Windows 10 isn't entirely new so the old advice about hiberfil.sys, and much more applies.

- Collapse -
It didn't work

I did the elevated command prompt to enable hibernate. Rebooted my machine, hibernate is set to 45 minutes and it's still in sleep mode.

- Collapse -
If it's sleeping, it may never hibernate.

I noticed that in Windows XP.

- Collapse -
BTW. I flubbed the initial reply.

I thought it was not hibernating at all. For far too long I've set it to sleep or hibernate but never expected a Windows PC to sleep for say 45 minutes then at the 1 hour mark hibernate. For that I just set it to hibernate at the 45 minute mark.

- Collapse -
Thanks for your help and suggestions.

I will do away with the sleep setting. I had my Windows 7 os set to sleep at 30 minutes and then hibernate at 45 minutes, worked like a charm.
I have chatted with 3 Microsoft techs about this, first one changed the power plan to Balanced (because that is what is recommended). No hibernate. Second tech said that Hibernate is not an option in Windows 10 - this after I gave them the reference number from first tech support. Third tech gave me a link to enable the hibernate button to show up in the start/power/menu spot and said that if that doesn't make it hibernate automatically, then I need to wait for more updates from Microsoft to fix it.
I do appreciate your replies on this. Happy

- Collapse -
It sounds more like a driver issue than an OS one.

Tomorrow I'll set up my test W10 laptop which is some old Sony Core2Duo machine that got the upgrade and minimal work on drivers by me. BBL (10-4-2014 PST.)

- Collapse -
45 minutes?

I am curious, where would you have a need for such timing? So the computers setup auto-function and this will not work with "sleep"?

- Collapse -
In the past it worked like this.

You could let the machine go to sleep and after more time it would hibernate. These are personal choices but even I ran into a PC that it didn't work so I went with what worked about a decade ago. That is I would select one or the other.

- Collapse -
So they are not exactly the same?

I am just trying to get clear in my head why use one over the other. Although I have always used "sleep". I seem to recalled some win10 do have hibernate..and some don't have. One that I am using now don't have.

- Collapse -
Now that I have done more tests in 10.

The question had me be sure to test this as I made my way across a few W10 machines. One I wrote in detail the steps and results.

OK, you did ask why someone would mix sleep and hibernation. Sleep isn't truly power off so let's say I want the PC to resume as fast as possible. Sleep wins. But let's say I'm not around to power it off. Hibernation to the rescue.

So I leave the machine at lunch, it sleeps in say 30 minutes. At 2 hours I'm not coming back so there's a scenario to hibernate at 2 hours.

- Collapse -
I got it.

Like you said, use what you have...and both that I use don't have it. I think I it like this, I know all the Hdd. are off or idling (it felt cool). I just hit the space bar when I want to use the computer. I wonder, would I have to log back in if I were in hibernation mode (just thinking out loud).

- Collapse -
The log back in from sleep or hibernation

Is a setting. Your choice.

- Collapse -
Answer
OK, back and it works here.

Platform: A Dell i15r with the Intel i5 460m, 6GB RAM, stock OS was W7 and Microsoft's W10 upgrade.

TWO CHANGES were made without any use of command line.

1. In the W10 Search the web and Windows box I typed Power Options to get to that control panel.
2. I selected the Balanced plan.
3. Click on the Change Plan settings.
4. Since I wanted to not wait a hour I set the Plugged in sleep time to 5 minutes. Click Save Changes.
5. Hibernate isn't showing so I clicked on "Change advanced power settings."
6. The Power Options panel shows and I click on the + mark to the left of Sleep.
7. Click on the + mark to the left of Hibernate.
8. Changed the Plugged in: entry to 10 Minutes.

Click OK on Power Options and close other dialog boxes.

Working fine here. It slept at the 5 minute mark, then woke up to do the hibernate work.

- Collapse -
I tried but no luck.

I set mine to sleep at 5 & hibernate at 10, all it did was sleep.
I did the command line to turn off the hibernate and delete the hiberfil.sys file, command line to re-enable the hibernation - that created a new hiberfil.sys file.
I set sleep to 5 and hibernate to 10 and it just sleeps and never goes into hibernate. This is really strange. Looks like I will be waiting for Microsoft to release an update (hopefully/eventually).

- Collapse -
My BIOS is too old.

In the power section of my BIOS all I have is a setting for after power failure and a setting for "Wake on LAN".
Thanks though, maybe this'll help another person.

- Collapse -
A few machines. What's in common.

1. BIOS is all stock. Factory or default settings.
2. All were upgrades from 7,8 to 10 from a factory issued OS and drivers.
3. All were gone over to see if I needed driver updates.
4. All were current on the bios versions.

So in my limited testing it works. But I have very clean laptops with newish models (2009 was the oldest) and factory issued BIOS settings an OS to upgrade to 10 from.

CNET Forums