kcbrandon, Right click your Desktop>Arrange icons by and uncheck "Auto Arrange" and Uncheck "Align to Grid".

Tufenuf